Win95 on real Raspi


282 posts   Page 11 of 12   1 ... 8, 9, 10, 11, 12
by mimi123 » Wed Feb 25, 2015 1:31 pm
Dietmar wrote:Hi all,

Internet works on Raspi2 XP SP1 :mrgreen:
Image
have a nice evening
Dietmar

Security-wise, XP1 is catastrophic. Open Windows Update. I would like to see how long it would take :lol:
Please test SMP mode
Posts: 583
Joined: Thu Aug 22, 2013 3:32 pm
by Dietmar » Wed Feb 25, 2015 7:07 pm
I tested also the brandnew Qemu.
Now, Win95, 98, XP, Nt4 works again with it
but is slower than Thoroniers Qemu in
qemudidi2.rar on http://199.231.94.230/

Thoronier: 57 bogomips on XP SP1
qemu-2.2.0.tar.bz2 with newest updates from git: 48 bogomips for XP SP1

Interesting: win95, Nt4 is very fast on both,

have a nice evening
Dietmar

EDIT: Correction, Win95 crashs on new Qemu again, brrr :mrgreen:
EDIT: The Cirrus driver CirrusLogic5446PCI, needed for 256 colours, does not run on new Qemu.
Settlers II starts in 53 sec, with sound and normal speed. Win95 works like in old times, with Internet, just all.
Posts: 361
Joined: Sun Sep 04, 2011 5:43 pm
by ric96 » Fri Mar 06, 2015 12:26 pm
i am trying to compile it on a pi2 and i get this error pl. help

Code: Select all
CC    ui/vnc-tls.o
ui/vnc-tls.c: In function ‘vnc_tls_client_setup’:
ui/vnc-tls.c:313:9: error: ‘gnutls_kx_set_priority’ is deprecated (declared at /usr/include/gnutls/compat.h:342) [-Werror=deprecated-declarations]
ui/vnc-tls.c:320:9: error: ‘gnutls_certificate_type_set_priority’ is deprecated (declared at /usr/include/gnutls/compat.h:347) [-Werror=deprecated-declarations]
ui/vnc-tls.c:327:9: error: ‘gnutls_protocol_set_priority’ is deprecated (declared at /usr/include/gnutls/compat.h:344) [-Werror=deprecated-declarations]
cc1: all warnings being treated as errors
/home/pi/raspidev/qemu/rules.mak:18: recipe for target 'ui/vnc-tls.o' failed
make: *** [ui/vnc-tls.o] Error 1


this happen with "make -j4" and just "make" !!!!
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by Dietmar » Fri Mar 06, 2015 6:07 pm
Hi ric96,
which version of Qemu did you compile?
I tested Thoronier Qemu
and brandnew Qemu via git,
both work for me.

Thoronier Qemu with my patches I get from

wget 199.231.94.230/qemudidi2.rar

Brandnew Qemu via Git works without patches,
but crashes a lot of times and is SLOW,
have a nice day
Dietmar

PS: Unrar did not work for me on Raspi2. So I uncompress it on a windows machine.
Posts: 361
Joined: Sun Sep 04, 2011 5:43 pm
by mimi123 » Sun Mar 15, 2015 5:33 pm
Windows RT would be better. http://winocm.moe/projects/bringup/ospo ... rm-a-hand/ for the way it can be done.
I see it fitting nicely with win86emu.
Posts: 583
Joined: Thu Aug 22, 2013 3:32 pm
by ric96 » Wed Mar 18, 2015 12:05 pm
Dietmar wrote:Hi ric96,
which version of Qemu did you compile?
I tested Thoronier Qemu
and brandnew Qemu via git,
both work for me.

Thoronier Qemu with my patches I get from

wget 199.231.94.230/qemudidi2.rar

Brandnew Qemu via Git works without patches,
but crashes a lot of times and is SLOW,
have a nice day
Dietmar

PS: Unrar did not work for me on Raspi2. So I uncompress it on a windows machine.


i tried exactly as you posted in the first page of this thread, however in the armv7 debian jessie apt-get install qemu works perfectly.
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by nick13131 » Fri Mar 20, 2015 3:06 pm
Quite stellar. I think this forces my hand to buy a Pi 2...

Question that I haven't seen the answer to: How do you do this for XP? I see on the first page for 95, but not XP. This is quite cool!

With all those steps, perhaps it would be easier to make a shell script to do it all. If anybody would like to work on that with me, I'd be happy to do it.
It's Pi o'clock somewhere!
Posts: 20
Joined: Mon Nov 10, 2014 3:21 pm
by MasterPineapple » Sun Mar 22, 2015 9:52 pm
I recently got a RasPi 2B, and i tried this out and got:

qemu: malloc.c:3096: sYSMALLOc: Assertion `(old_top == (((mbinptr) (((char *) &((av)->bins[((1) - 1) * 2])) - __builtin_offsetof (struct malloc_chunk, fd)))) && old_size == 0) || ((unsigned long) (old_size) >= (unsigned long)((((__builtin_offsetof (struct malloc_chunk, fd_nextsize))+((2 * (sizeof(size_t))) - 1)) & ~((2 * (sizeof(size_t))) - 1))) && ((old_top)->size & 0x1) && ((unsigned long)old_end & pagemask) == 0)' failed.

IDK what i did wrong here.
am i missing a file or what?
Posts: 2
Joined: Sun Mar 22, 2015 9:30 pm
by ric96 » Sun Mar 22, 2015 11:29 pm
MasterPineapple wrote:I recently got a RasPi 2B, and i tried this out and got:

qemu: malloc.c:3096: sYSMALLOc: Assertion `(old_top == (((mbinptr) (((char *) &((av)->bins[((1) - 1) * 2])) - __builtin_offsetof (struct malloc_chunk, fd)))) && old_size == 0) || ((unsigned long) (old_size) >= (unsigned long)((((__builtin_offsetof (struct malloc_chunk, fd_nextsize))+((2 * (sizeof(size_t))) - 1)) & ~((2 * (sizeof(size_t))) - 1))) && ((old_top)->size & 0x1) && ((unsigned long)old_end & pagemask) == 0)' failed.

IDK what i did wrong here.
am i missing a file or what?

Dont use raspbian, use debian jessie. http://sjoerd.luon.net/posts/2015/02/debian-jessie-on-rpi2/
Just use apt-get install qemu.
You might have to setup X.

Qemu doesn't seem to work on raspbian on pi2.
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by MasterPineapple » Sun Mar 22, 2015 11:55 pm
Im pretty stupid lol.
forgot to even apt-get qemu XD
ill try what you said tho ;)
Posts: 2
Joined: Sun Mar 22, 2015 9:30 pm
by nick13131 » Mon Mar 23, 2015 2:14 pm
I followed the instructions on my B+ on the first page, but when I download a Windows 95 image from online, Some images bring up a window I'll explain in a moment and others just throw an error.

Now, with some images, as well as after using apt-get install qemu, a window pops up as if booting, then displays on the screen:
Code: Select all
I/O Error. Replace image, then press any key.

No matter what, I can't get any further than that.
It's Pi o'clock somewhere!
Posts: 20
Joined: Mon Nov 10, 2014 3:21 pm
by ric96 » Mon Mar 23, 2015 2:53 pm
Rpi2 running win95 and 98 using qemu
https://www.youtube.com/watch?v=ESJq8IeSYfg
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by ric96 » Tue Mar 24, 2015 12:48 am
nick13131 wrote:I followed the instructions on my B+ on the first page, but when I download a Windows 95 image from online, Some images bring up a window I'll explain in a moment and others just throw an error.

Now, with some images, as well as after using apt-get install qemu, a window pops up as if booting, then displays on the screen:
Code: Select all
I/O Error. Replace image, then press any key.

No matter what, I can't get any further than that.


Yes that happens on raspbian lately for some reason, used to work well earlier!!
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by Nick7 » Mon May 11, 2015 10:54 pm
Hi,

I'm new with Raspi and Linux etc. I want to use WinXP (incl. internet) with QEMU on a Raspi2. Can someone post a tutorial with all steps what i have to do? :)

I bought the Raspi2 with a 32GB SD Card. My Host PC is a Win7 Intel Core i5. Now what should i do?

Thx for your help :)

Nick
Posts: 1
Joined: Mon May 11, 2015 10:45 pm
by mahjongg » Tue May 12, 2015 12:23 am
Nick7 wrote:Hi,

I'm new with Raspi and Linux etc. I want to use WinXP (incl. internet) with QEMU on a Raspi2. Can someone post a tutorial with all steps what i have to do? :)

I bought the Raspi2 with a 32GB SD Card. My Host PC is a Win7 Intel Core i5. Now what should i do?

Thx for your help :)

Nick
not realistic, get rid of your angst, and use linux, it works...
User avatar
Forum Moderator
Forum Moderator
Posts: 9070
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands
by kusti8 » Tue May 12, 2015 1:46 am
mahjongg wrote:
Nick7 wrote:Hi,

I'm new with Raspi and Linux etc. I want to use WinXP (incl. internet) with QEMU on a Raspi2. Can someone post a tutorial with all steps what i have to do? :)

I bought the Raspi2 with a 32GB SD Card. My Host PC is a Win7 Intel Core i5. Now what should i do?

Thx for your help :)

Nick
not realistic, get rid of your angst, and use linux, it works...


+1

I heard it took about 6 hours or so for this to boot up, and it's not usable. Find a Linux equivalent or don't use the pi, it's as simple as that.
There are 10 types of people: those who understand binary and those who don't.
User avatar
Posts: 3315
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA
by thyme » Tue Jul 07, 2015 3:16 am
Dont use raspbian, use debian jessie. http://sjoerd.luon.net/posts/2015/02/debian-jessie-on-rpi2/
Just use apt-get install qemu.
You might have to setup X.

Qemu doesn't seem to work on raspbian on pi2.



Qemu 1.6 doesn't seem to compile with jessie's version of gcc. Do you have any tips for compiling this on the raspi2?
Posts: 4
Joined: Tue Jul 07, 2015 3:14 am
by ric96 » Tue Jul 07, 2015 3:34 am
thyme wrote:
Dont use raspbian, use debian jessie. http://sjoerd.luon.net/posts/2015/02/debian-jessie-on-rpi2/
Just use apt-get install qemu.
You might have to setup X.

Qemu doesn't seem to work on raspbian on pi2.



Qemu 1.6 doesn't seem to compile with jessie's version of gcc. Do you have any tips for compiling this on the raspi2?

Can u give me the error output?
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by thyme » Tue Jul 07, 2015 3:48 am
ERROR: "cc" either does not exist or does not work

This was after I installed gcc/g++, make, etc using apt. The Jessie base install did not have them. I did a little searching, and this seems to be an incompatibility with versions >=4.8 of g++.
Posts: 4
Joined: Tue Jul 07, 2015 3:14 am
by ric96 » Tue Jul 07, 2015 3:51 am
thyme wrote:ERROR: "cc" either does not exist or does not work

This was after I installed gcc/g++, make, etc using apt. The Jessie base install did not have them. I did a little searching, and this seems to be an incompatibility with versions >=4.8 of g++.


Try this
Code: Select all
apt-get purge gcc g++
apt-get autoremove
apt-get install gcc-4.7
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by thyme » Tue Jul 07, 2015 4:02 am
Alright, I'll try it out. Thanks for the quick reply!
Posts: 4
Joined: Tue Jul 07, 2015 3:14 am
by thyme » Tue Jul 07, 2015 4:26 am
Try this
Code: Select all
apt-get purge gcc g++
apt-get autoremove
apt-get install gcc-4.7


No dice, "gcc-4.7-base has no installation candidate." :/ I was able to get 3.4 installed, but I got the same error when compiling qemu-1.6. Can you check which version of gcc you have on your pi2? When you get a chance of course!
Posts: 4
Joined: Tue Jul 07, 2015 3:14 am
by ric96 » Tue Jul 07, 2015 4:52 am
thyme wrote:
Try this
Code: Select all
apt-get purge gcc g++
apt-get autoremove
apt-get install gcc-4.7


No dice, "gcc-4.7-base has no installation candidate." :/ I was able to get 3.4 installed, but I got the same error when compiling qemu-1.6. Can you check which version of gcc you have on your pi2? When you get a chance of course!

Hmmm... Thats very unusual, i won't have my pi for another day or two, in the mean time try
apt-get install g++-4.7
I'll look for other solution in the mean time.
My apologies for shameless YouTube Plugs...
youtube.com/sahajsarup
twitter @sahajsarup
skype srics1996
e-mail: sahajsarup@gmail.com
Blog: http://www.geektillithertz.com/wordpress
Web: http://www.geektillithertz.com
User avatar
Posts: 1240
Joined: Sun Mar 17, 2013 6:03 am
Location: NOIDA, India
by A1i3n » Fri Aug 21, 2015 6:04 pm
Hi!
I'm new with raspbian but i would like to run fallout 2 with the emulator could someone tell me how to do it?
Posts: 1
Joined: Fri Aug 21, 2015 5:47 pm
by mahjongg » Thu Aug 27, 2015 9:43 am
A1i3n wrote:Hi!
I'm new with raspbian but i would like to run fallout 2 with the emulator could someone tell me how to do it?

Yeah, I can see you are new here, there is now way you can run fallout 2, or any other serious Windows 95 software on the PI!
Even if you can get windows to boot, and that is a big if, (even experts can not manage it) even booting it would take unbearably long.
User avatar
Forum Moderator
Forum Moderator
Posts: 9070
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands