clifmeister
Posts: 5
Joined: Thu Mar 29, 2012 1:34 pm

Re: Keyboard layout (solved)

Fri Apr 27, 2012 4:11 pm

Hi,

I was having trouble with the screen overscan in Debian Squeeze and while trying to fix it I discovered that my keyboard has a different layout than the system expects. I have a US keyboard, and it appears to expect the UK layout.

for example the number keys on my board when shifted should be:

! @ # $ % ^ & * ( )

but when I type them connected to my PI I get

! " £ $ % ^ & * ( )

So when I need " or # I can't seem to find them. Is there a way to change the keyboard layout to US?

Thanks,

Clif

shirro
Posts: 248
Joined: Tue Jan 24, 2012 4:54 am

Re: Keyboard layout

Fri Apr 27, 2012 4:54 pm

If you are not from the UK you might want to do some of the following:

Keyboard - look for the uk and change it to your type (us will do us, aus, can, nz etc). Then save and exit.

sudo nano /etc/default/keyboard




Locale - uncheck the uk and check the one you need and then set it as default. Mine is en_AU UTF-8

sudo dpkg-reconfigure locales

Timezone

sudo dpkg-reconfigure tzdata

Reboot to get the full effect.

clifmeister
Posts: 5
Joined: Thu Mar 29, 2012 1:34 pm

Re: Keyboard layout

Fri Apr 27, 2012 7:01 pm

Thanks, that is exactly what I was looking for!

Clif

shirro
Posts: 248
Joined: Tue Jan 24, 2012 4:54 am

Re: Keyboard layout

Mon Apr 30, 2012 4:19 pm

Instead of the manual edit for keyboard this may be easier:

sudo dpkg-reconfigure keyboard-configuration

Poofjunior
Posts: 35
Joined: Tue May 15, 2012 5:27 pm
Location: Claremont California

Re: Keyboard layout

Wed May 16, 2012 6:59 am

Many Thanks! I've been able to adjust the layout to "us" qwerty settings as well.

One note though: rather than using the default keyboard (I can't remember which it was set to... ), I reconfigured my keyboard to an "apple" keyboard, and the Raspberry Pi now takes about five times as long to boot up.

Does anyone remember the default keyboard?

it's the underline in
XKBMODEL = "__________"
in the file located here: /etc/default/keyboard

User avatar
RABIS50
Posts: 8
Joined: Tue May 15, 2012 6:56 am

Re: Keyboard layout

Wed May 16, 2012 1:41 pm

@ shirro

You wrote:
Keyboard - look for the uk and change it to your type (us will do us, aus, can, nz etc)

My questions is, do you have a list of allowed letters, especially for German (ge or de)?

Thanks
RABIS50

logoff
Posts: 8
Joined: Mon Feb 27, 2012 12:08 pm

Re: Keyboard layout

Fri Jun 01, 2012 3:48 pm

I think you should use "de" for german (deutsch).

For instance: "fr" for french, "es" for spanish, "it" for italian, "pt" for portuguese, and so...

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Keyboard layout

Fri Jun 01, 2012 5:01 pm

It's the ISO country code, as distinct from the ISO language code. In some cases those are seen together separated by a hyphen. Hence en-GB or en-US. Most countries however are more boring, de-DE, es-ES etc. but some have surprises, for example ja-JP which appears to differ for no reason, since there is no jp language code or JA country code.

DarylMc
Posts: 7
Joined: Mon Jan 23, 2012 3:38 pm

Re: Keyboard layout

Thu Jun 14, 2012 10:31 pm

Raspberry Pi now takes about five times as long to boot up
There is a fix here

Code: Select all

sudo setupcon
http://www.raspberrypi.org/phpBB3/viewtopic.php?p=79249

anacron
Posts: 1
Joined: Tue Jul 10, 2012 10:21 am

Re: Keyboard layout

Tue Jul 10, 2012 10:25 am

manual editing didn't work for me, but

Code: Select all

sudo dpkg-reconfigure keyboard-configuration
did work great!

Code: Select all

 sudo dpkg-reconfigure console-setup
is also useful

rocketero
Posts: 64
Joined: Wed Jul 11, 2012 5:45 pm

Re: Keyboard layout

Mon Jul 16, 2012 11:20 am

Poofjunior wrote:Many Thanks! I've been able to adjust the layout to "us" qwerty settings as well.

One note though: rather than using the default keyboard (I can't remember which it was set to... ), I reconfigured my keyboard to an "apple" keyboard, and the Raspberry Pi now takes about five times as long to boot up.

Does anyone remember the default keyboard?

it's the underline in
XKBMODEL = "__________"
in the file located here: /etc/default/keyboard
for US, PC keyboard:

sudo nano /etc/default/keyboard

and do changes to look like this:

XKBMODEL="pc104"
XKBLAYOUT="us"

save changes, then:

sudo setupcon

now try by pressing SHIFT+2 should give you @ (before with UK was ")

elenipapadimitriou
Posts: 1
Joined: Sun Feb 01, 2015 12:57 pm

Re: Keyboard layout

Sun Feb 22, 2015 6:36 pm

hello,

I'm from Greece and I have a raspberry pi b+.I wanted to change my keyboard's language,I did change it to Greek and then reboot it. I couldn't login.Because my keyboard was writing only in Greek.My next step is to reinstalling the Operating System.Is there any other way to login without losing my data?Thank you.:)

wwwillem
Posts: 1
Joined: Wed Oct 19, 2016 3:20 am

Re: Keyboard layout (solved)

Wed Oct 19, 2016 3:31 am

I followed what "rocketero" suggested, worked like a charm

in addition, it makes sense to update at the same time "/etc/default/locale"

change en_GB.UTF into for example en_US.UTF

after this change you should login/logout

check with the command "env | grep LANG"

adadion
Posts: 1
Joined: Mon Dec 05, 2016 8:00 am

Re: Keyboard layout (solved)

Mon Dec 05, 2016 8:03 am

You can use simple command too

Code: Select all

sudo setxkbmap us
to change to US layout, or change the 'us' to other locale.

Return to “Troubleshooting”