Page 1 of 1

RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 2:48 am
by vcapeluto
Hey guys,

I have installed Windows 10 IoT and Ubuntu Mate 16.04 and the Pi does not boot following all the instructions from the documentation, does anybody know if there's any trick on this or something?

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 3:29 am
by DavidS
vcapeluto wrote:
Mon Mar 04, 2019 2:48 am
Hey guys,

I have installed Windows 10 IoT and Ubuntu Mate 16.04 and the Pi does not boot following all the instructions from the documentation, does anybody know if there's any trick on this or something?
How did you write the images to the SD Card?

Also have you tried Raspbian?

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 4:11 am
by DougieLawson
It's most likely that your version of Mate doesn't have the right bootcode & firmware for the newest Raspberry.

You need a version built after 16th November 2018.

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 5:23 pm
by vcapeluto
DavidS wrote:
Mon Mar 04, 2019 3:29 am
vcapeluto wrote:
Mon Mar 04, 2019 2:48 am
Hey guys,

I have installed Windows 10 IoT and Ubuntu Mate 16.04 and the Pi does not boot following all the instructions from the documentation, does anybody know if there's any trick on this or something?
How did you write the images to the SD Card?

Also have you tried Raspbian?
I wrote Windows IoT with the IoT Dashboard app and Ubuntu with the app Win32 Disk manager

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 5:24 pm
by vcapeluto
DougieLawson wrote:
Mon Mar 04, 2019 4:11 am
It's most likely that your version of Mate doesn't have the right bootcode & firmware for the newest Raspberry.

You need a version built after 16th November 2018.
Is there an available version built after 16th November 2018?

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 5:30 pm
by code_exec
vcapeluto wrote:
Mon Mar 04, 2019 5:24 pm
DougieLawson wrote:
Mon Mar 04, 2019 4:11 am
It's most likely that your version of Mate doesn't have the right bootcode & firmware for the newest Raspberry.

You need a version built after 16th November 2018.
Is there an available version built after 16th November 2018?
No, although there will be.

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 6:00 pm
by fruitoftheloom
vcapeluto wrote:
Mon Mar 04, 2019 2:48 am
Hey guys,

I have installed Windows 10 IoT and Ubuntu Mate 16.04 and the Pi does not boot following all the instructions from the documentation, does anybody know if there's any trick on this or something?


Regards Windows 10 IoT Core you will need the latest Insider Preview and hope that Microsoft Developers have updated the the kernel / firmware to support the 3A+

You will need a Microsoft Account to download, it seems the latest version is 17763:

https://docs.microsoft.com/en-us/window ... commercial

https://www.microsoft.com/en-us/softwar ... windowsiot

https://social.msdn.microsoft.com/forum ... WindowsIoT

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 6:12 pm
by feelslikeautumn
code_exec wrote:
Mon Mar 04, 2019 5:30 pm
vcapeluto wrote:
Mon Mar 04, 2019 5:24 pm
DougieLawson wrote:
Mon Mar 04, 2019 4:11 am
It's most likely that your version of Mate doesn't have the right bootcode & firmware for the newest Raspberry.

You need a version built after 16th November 2018.
Is there an available version built after 16th November 2018?
No, although there will be.
Still probably won't boot out the box. The version of firmware is from September. You would have to https://wiki.ubuntu.com/ARM/RaspberryPi ... ader_files and copy a dtb file for the 3a+ if one doesn't exist. You don't have a lot of memory on the 3a+.

Re: RPI 3 A+ does not boot

Posted: Mon Mar 04, 2019 9:07 pm
by code_exec
feelslikeautumn wrote:
Mon Mar 04, 2019 6:12 pm
code_exec wrote:
Mon Mar 04, 2019 5:30 pm
vcapeluto wrote:
Mon Mar 04, 2019 5:24 pm


Is there an available version built after 16th November 2018?
No, although there will be.
Still probably won't boot out the box. The version of firmware is from September. You would have to https://wiki.ubuntu.com/ARM/RaspberryPi ... ader_files and copy a dtb file for the 3a+ if one doesn't exist. You don't have a lot of memory on the 3a+.
But those copies of the bootloader files are from April 2018. You'll need bootloader files from November 2018 for it to boot on the 3A+.

It doesn't seem like flash-kernel will work on the Pi 3A+ out of the box either as there appears to be no entry in the database for the 3A+.

Re: RPI 3 A+ does not boot

Posted: Tue Mar 05, 2019 10:31 am
by jamesh
vcapeluto wrote:
Mon Mar 04, 2019 2:48 am
Hey guys,

I have installed Windows 10 IoT and Ubuntu Mate 16.04 and the Pi does not boot following all the instructions from the documentation, does anybody know if there's any trick on this or something?
Does the Pi boot when using Raspbian?