Page 1 of 1

Internet Connection Not Working

Posted: Wed Sep 04, 2013 6:52 pm
by Chenmunka
I am unable to connect to the internet under RiscOs.
The OS is a clean install of RiscOs on a new SD card, with TCP/IP enabled as the only change from the new install state.
A clean Raspbian install on another SD card accesses the internet without difficulty.

The RiscOs install gives an error message Timeout on Accessing DNS Servers.

The Network Configuration under !Configure has DHCP enabled, no changes to the default gateway. I am at a loss. Any ideas?

Re: Internet Connection Not Working

Posted: Thu Sep 05, 2013 1:13 pm
by microbitsuk
just set a host name in internet configuration host names it can be anything that you want pieyed is good
make sure that you hit the set, then close, then save.

Re: Internet Connection Not Working

Posted: Thu Sep 05, 2013 7:02 pm
by Chenmunka
Thanks for the suggestion. Unfortunately, that hasn't solved it. I still get Unable to resolve host - timeout on accessing DNS servers.

I feel I need to get into the routing tables in RiscOs. All I can see in the Network Configuration utility is HOSTS which is not the file to be changed in this case.

Re: Internet Connection Not Working

Posted: Thu Sep 05, 2013 9:34 pm
by microbitsuk
Try entering your gateway address for your internet modem router into gateway

Re: Internet Connection Not Working

Posted: Fri Sep 06, 2013 8:48 am
by Chenmunka
No, still not working. Thanks for your continued support.

I won't be able to work on this over the weekend but I'll try pinging outwards from the router and checking its logs next week.

Re: Internet Connection Not Working

Posted: Fri Sep 06, 2013 12:02 pm
by SEDev
If you're using DHCP then try clearing the gateway field. IIRC connection will fail when there's both DHCP and a gateway address.

Re: Internet Connection Not Working

Posted: Sat Sep 07, 2013 6:03 pm
by Chenmunka
Despite my last post about the weekend, I have tried plugging the Pi into a different router. It worked, connecting to the internet without problem.

I suspect therefore that the answer lies in the router configuration. However, as other systems plugged into the router have worked - including systems running Windows, iOS, Android and the Pi itself on Raspbian, I can't think what routing parameter(s) block the RiscOs connection.

To recapitulate:
The Pi is running a clean installation of RiscOs from NOOBS with networking turned on.
The Hostname has been set
Setting the Gateway and leaving it blank have both been tried
DHCP is on
The error is consistent - Timeout in accessing DNS servers
The router (Belkin) is set to obtain DNS server addresses from the ISP
Connection failure only occurs on RiscOs

With another router (BT Homehub3) the connection works.

Still hacking!

Re: Internet Connection Not Working

Posted: Sun Sep 08, 2013 10:46 am
by Burngate
I'm probably just going to muddy the waters here, but ...
Is my memory correct in telling me that RISC OS uses UDP rather more than TCP for its networking?
If so, and the Belkin router has those ports blocked whereas the BT one has them open ...

RGB=AC8300

Re: Internet Connection Not Working

Posted: Thu Sep 12, 2013 6:32 pm
by Chenmunka
Thanks to everyone who helped in this problem.

I have proven that the root cause of the fault lay in my router, although the exact nature of the fault is not known. After fiddling with the router settings without success, I attempted a factory reset to start again clean but it bricked. A replacement has solved the problem - as mentioned before other routers didn't show the problem.

That doesn't however explain why the fault only manifested itself on RiscOs and not on any other system. I had tried looking at the UDP/TCP issue as suggested but that made no difference either. I think we shall never know.

Thanks again.

Re: Internet Connection Not Working

Posted: Mon Nov 11, 2013 9:06 pm
by darrenwoodall73
So no actual resolve found. I have had my RPi for many months now. First attempt to get started failed with the problem described. There was no support then so it's been in a box ever since. I recently found the motivation to have another go to no avail. Different router, different cable. Improved power arrangement. RPi lights indicate network connection, DHCP configured on /etc/network/interfaces. Nada! Router doesn't see mac address and no ip address assigned according to ifconfig? What the hell is wrong with this thing? Dare I admit to being an ex network engineer and I'll be buggered off I can work it out. Is there any history of faulty ethernet ports reported? Just a bit Raspberry Pied off right now. Any constructive advice not already mentioned would be gratefully received. Ta

Re: Internet Connection Not Working

Posted: Tue Nov 12, 2013 12:59 am
by DavidS
First what is the working internet config on your current computer?

Next if you Open Configure, and click on Network Configuration, then Internet, and then on interfaces, click on Configure Next the 'Ethernet Over USB'?

Then if you close 1 level and click Status next to 'Ethernet Over USB' what does it show?

Then Close back till you are at the Internet Configuration, and click on Host Names, what is set in there?

Now close back to Internet Configuaration and click on Routing, make sure that GateWay is blank and nothing is checked.

Re: Internet Connection Not Working

Posted: Tue Nov 12, 2013 1:00 am
by DavidS
ALSO: What version of RISC OS are you using?

Re: Internet Connection Not Working

Posted: Wed Dec 11, 2013 12:26 pm
by heuristicjohn
I have had the same problem. With Raspbian and RISCOS on the same SD card, I could access the internet via Raspbian but not via RISCOS. The following workaround put things right (not sure why !)
1. click on !Boot to get Configuration window
2. Click on internet icon to get Internet config window
3. Tick TCP/IP box. Click on Interfaces icon to get Interfaces window
4. Tick box USB0 Ethernet over USB. Click on Configure, choose button 'via DHCP'
You then have to restart the system, and then can use Netsurf
I have tried this on two SD cards with RISCOS v5.21, and it worked. However, on a third card with RISCOS v.5.19 it failed.
Any comments on why this works, or better approaches, would be welcome !