Page 1 of 1

The Disc Drive is Empty

Posted: Fri Nov 16, 2012 12:07 pm
by msmithy12
Hi, I installed RISCos a few days ago and was not impressed. So i abandoned that SD card and sat in a darkened room for a few days!

Then while surfing youtube i found a RISCos RasPi vid that looked like it was for a usable OS. So i did a little research and found out my software is defective. Basically on boot (which is so fast im sure it loads before i put the power on!) I get a message " Machine Start up has not completed successfully: 'The disc is empty' "

I guessed this was in reference to no physical media (ie something separate to the SD card) but now i believe i have made an installation error.

I used dd in ubuntu 12.04 LTS

Followed the same instructions as i used to install raspbian and fedora for my Pi and i rembered the sudo sync command.

My pi has no keyboard ATM because my wireless desktop set caused an error. Is that the issue?

Any1 got any ideas?

Thank You

Re: The Disc Drive is Empty

Posted: Tue Nov 20, 2012 3:48 pm
by msmithy12
Tried 2 more SD cards that i have lying around, and re-downloaded the image twice. Still no luck! :cry:

Re: The Disc Drive is Empty

Posted: Tue Nov 20, 2012 3:50 pm
by RaTTuS
you need a 2GB card [or bigger]
you need the latest version of riscos - redownload it
you need a keyboard - not a wireless one

Re: The Disc Drive is Empty

Posted: Sat Nov 24, 2012 5:06 pm
by michthom
I'm having very similar problems, and have tried several SD cards, including one brand new from the PiHut that I'm using for BerryBooting multiple OSs with no issues.

Every time I only get as far into RiscOS as the OP.

I've ordered a RiscOS Open SD card but if that fails too, I'll have to conclude I have a faulty bit of hardware? Faulty RasPi??

Any other theories welcome at this point...

Re: The Disc Drive is Empty

Posted: Sat Nov 24, 2012 5:59 pm
by theom
I asked the author of the SD driver, and this is what he said:
It's tricky to know what to suggest. FileCore does a lot more cross-checking
of disc parameters and free space maps than is possible with FAT, so if the
image has been incorrectly written, then it would produce the error "Disc
not understood - has it been formatted?" rather than a drive empty error.

Drive empty could be caused by a bad contact with the card detect switch
(since Linux presumably can't cope with cards being swapped, I don't know
offhand if it even bothers checking it). After detecting an inserted card,
the first thing SDIODriver does is the card initialisation sequence - this
is so that it can discover the card's address (RCA) and various other things
like whether it's an MMC or an SD card and whether it's byte addressed or
sector addressed - things which are required in order to be able to
correctly formulate other commands. If these initialisation commands aren't
responded to, SDIODriver assumes the card was incorrectly inserted, or
perhaps that someone inserted a passive micro-SD-to-SD adaptor with no
micro-SD card in it, and so treats it the same as if the slot was empty.

It's also useful that it starts from scratch like that because the module
can be reinitialised or re-loaded after boot - so there's no guarantee that
there's any card in the slot any more - and also because on multi-slot
machines like the Pandora, the second slot has (a) not been initialised at
all by the bootloader, and (b) may or may not contain a card.

Nevertheless, it would appear that in this case, the card successfully
initialised (enough for the bootloader to load RISC OS) but then failed the
second time, when SDIODriver starts. I don't think I've seen that myself
since we fixed the pull-up resistor issue, despite having regularly used
several different brands of card.

I can only speculate about why some people find it fails. It could be a
mechanical problem with their SD sockets, it could be something to do with
their power supply, or the exact card they're using (how much power they
draw, how slowly they initialise, and so on). It might be that SDIODriver is
trying to run the card at a speed that it doesn't work at, if the bootloader
configures it differently somehow - but that's hard to confirm, especially
when the bootloader is closed-source :(

That gives some things to try, but I don't think we have any definite answers... The RISC OS SD stack has been written completely independently from the Linux version, so cards that work on Linux may not on RISC OS, or vice versa. If any pattern develops then we're most interested...

Re: The Disc Drive is Empty

Posted: Sat Nov 24, 2012 6:10 pm
by michthom
Fab information, thanks. I've also found a number of related threads, collected here to help others on this quest: ... 06#p214506 ... 55&t=22173 ... 28&t=22502

So far I'm disheartened by the comment here ( ... 37#p218637) where svrsig says:
This problem with SDFS not recognising the RISC OS partition seems to occur with a particular combination of SD card, power supply and Raspberry Pi version. The version immediately prior to the one with mounting holes seems indicated and certain SD cards
I think that implies I may be buying another RasPi sooner than I thought :?

Re: The Disc Drive is Empty

Posted: Sat Nov 24, 2012 9:44 pm
by michthom
I can confirm that in my case, reformatting the SD Card with the tool mentioned above made no difference.

Re: The Disc Drive is Empty

Posted: Mon Nov 26, 2012 3:21 pm
by Tirpitz
I also observed this error message on Pi, especially, if I used 4 or 8 GB card (Kingston for video). I was not entitled to find solve of this problem. But if I tested RISC OS with 2 GB microSD card from my Nokia, system started without any problem.
It looks RISC OS is more squeamish for SD cards. I founded compatibility list topic ... 55&t=23904 .

Re: The Disc Drive is Empty

Posted: Tue Nov 27, 2012 7:51 pm
by michthom
And now I've tried with a new SD card preinstalled from RiscOS Open Ltd - same problem.
Looks like my particular Raspberry Pi board is not going to play nice with RiscOS. Boo!
Any ideas or do I just have to man up and buy a Model B 512M and hope that the latest boards have the bugs all squished...

Re: The Disc Drive is Empty

Posted: Wed Nov 28, 2012 12:33 pm
by NigelJK
Try a beefier power supply.

Re: The Disc Drive is Empty

Posted: Wed Nov 28, 2012 7:38 pm
by michthom
Thanks Nigel. I tried the Pi powered from a 10W iPad USB adapter (2A max current) and the rest of the peripherals hanging off a powered Logic USB adapter, also 2A rated but with no more joy.

Re: The Disc Drive is Empty

Posted: Wed Nov 28, 2012 8:43 pm
by Jochen
I have an installation of RISCOS on a 32GB card, which worked perfectly for quite a while. Yesterday and today it produced that very error. Low resolution mode and Disc drive is empty.

I fixed it by cleaning the contacts of the sim card with a soft cloth.


Re: The Disc Drive is Empty

Posted: Thu Dec 13, 2012 5:17 pm
by michthom
Well, I have my new version RasPi, and can confirm that the exact same power supply, USB hub, mouse keyboard and importantly RiscOS SD card, booted perfectly just now.

So there's another data point that early versions of the RasPi have some compatibility issues when faced with RiscOS!

Now to get Elite running... :D :D :D

Re: The Disc Drive is Empty

Posted: Thu Dec 13, 2012 5:49 pm
by nr.
That's interesting, as I have two early Pis, ordered in the bunfight on the first day. One of them runs RISC OS perfectly, but I haven't tried the other yet. I may grab another SD card and give it a bash to see what happens.

Oh, and I have Elite running as well :) ArcElite under !ArcEm emulation, and Elite:New Kind compiled from source running on Raspbian. It needs the Allegro libraries, else I'd try compiling it with gcc on RISC OS as well.