Page 1 of 1

HID for wireless KB/Mouse?

Posted: Mon Nov 12, 2012 6:19 am
by Gibber
Hi,

I have been using an HP wireless keyboard and mouse with my Raspberry Pi and it has worked great for all Operating Systems so far except RISC! RISC works fine with a conventional USB KB/Mouse but I would like to be able to use the wireless ones.

I found a shareware package called !HID http://www.xat.nl/en/riscos/sw/usb/hid/#top_of_page

It looks like it should add wireless KB/mouse support. I downloaded it and move it to the !Utilities directory but when I double click to execute I get a popup Message from HID "not open for update". When I acknowledge that I get numerous other errors. The HID website says it needs release 5.09. I am running 5.19. Is that OK? Also says it needs USBdriver 0.43. I have not been able to find this or determine which version I have.

Has anyone else gotten !HID working on the Pi, or any other wireless KB/mouse solution?

Any suggestions appreciated.

Re: HID for wireless KB/Mouse?

Posted: Mon Nov 12, 2012 1:37 pm
by poglad
Nightmare... after the hassle of having to break out an old monitor, keyboard and mouse so that I could have a play with RiscOS, I thought I'd get one of those small wireless keyboards with a built-in mouse pad so that at least that side of things would be neat and tidy. I'm glad I didn't buy it yet.

I'm surprised that the RiscOS people don't think that lack of wi-fi support and lack of bluetooth keyboard support isn't a dealbreaker? I know those things didn't exist in 1989, but even so... :o

Re: HID for wireless KB/Mouse?

Posted: Mon Nov 12, 2012 2:02 pm
by NigelJK
My Keysonic ACK-540RF(UK) works out of the box. This is a mini keyboard with a mouse pad. I'm using !WinMenu as it has no middle button. An you have to set up the keyboard with the NumLock off or the Keyboard (correctly) types the blue numeric numbers.
The keyboard was originally purchased for use in my (Windows 7) media centre.

Re: HID for wireless KB/Mouse?

Posted: Mon Nov 12, 2012 2:04 pm
by poglad
Ah, thanks for sharing! :D

Re: HID for wireless KB/Mouse?

Posted: Mon Nov 12, 2012 2:23 pm
by bhtooefr
poglad wrote:I'm surprised that the RiscOS people don't think that lack of wi-fi support and lack of bluetooth keyboard support isn't a dealbreaker? I know those things didn't exist in 1989, but even so... :o
To be fair, there's a rather small group of people doing development (without those people, RISC OS would still be stuck on rather old hardware, and that hardware being nearly unobtanium for those outside of the UK), and keeping it running on up to date hardware is hard enough.

(And, given that the last real RISC OS laptop was in 1992 or so... Granted, it's been run on the Pandora, the Touch Book, and now the Raspberry Pi velcroed to Atrix Lapdocks, and in those applications, wifi becomes important.)

Re: HID for wireless KB/Mouse?

Posted: Mon Nov 12, 2012 2:48 pm
by ukscone
the logitech mk400 wireless keyboard & trackpad work out of the box except no middle button so you'll need one of the methods to emulate the middle mouse button using the winkey (or other key)

Re: HID for wireless KB/Mouse?

Posted: Mon Nov 12, 2012 3:49 pm
by poglad
I take back my moan... I just pulled the bluetooth USB dongle out of my work PC and put it into the Pi, and booted up RiscOS... it immediately detected the wireless keyboard and mouse. In this case, a Logitech K520. Clicking the scroll wheel worked fine as the middle button. Bravo!!!

Re: HID for wireless KB/Mouse?

Posted: Tue Nov 13, 2012 1:16 am
by Ed_Macha
Hi!

I have the BK-1816 (wireless keyboard and mice), it works well for Raspbian and Arch.

Regards,

Edmundo

Re: HID for wireless KB/Mouse?

Posted: Tue Nov 13, 2012 8:36 pm
by sawdust
Ed_Macha wrote:Hi!

I have the BK-1816 (wireless keyboard and mice), it works well for Raspbian and Arch.

Regards,

Edmundo
Have you tried it, or intend to try it with RISC OS? Else why post in this thread?

Sawdust.

Re: HID for wireless KB/Mouse?

Posted: Wed Nov 14, 2012 1:43 am
by Ed_Macha
sawdust wrote:
Ed_Macha wrote:Hi!

I have the BK-1816 (wireless keyboard and mice), it works well for Raspbian and Arch.

Regards,

Edmundo
Have you tried it, or intend to try it with RISC OS? Else why post in this thread?

Sawdust.
Hi Sawdust,

My apologies. I don't know why, but I forgot to mention that it works on RISC OS too.

Regards,

Edmundo Macha

Re: HID for wireless KB/Mouse?

Posted: Wed Nov 14, 2012 9:05 am
by sawdust
Ed_Macha wrote:
sawdust wrote:
Ed_Macha wrote:Hi!

I have the BK-1816 (wireless keyboard and mice), it works well for Raspbian and Arch.

Regards,

Edmundo
Have you tried it, or intend to try it with RISC OS? Else why post in this thread?

Sawdust.
Hi Sawdust,

My apologies. I don't know why, but I forgot to mention that it works on RISC OS too.

Regards,

Edmundo Macha
Glad to hear it Ed :) How are you finding RISC OS? Is this your first experience with the OS?

Re: HID for wireless KB/Mouse?

Posted: Wed Nov 14, 2012 1:49 pm
by thradtke
My HAMA wireless desktop set isn't fully working: The keyboard does but the mouse doesn't. Is there any way I could help RISC OS identifying the mouse as HID device?

Re: HID for wireless KB/Mouse?

Posted: Thu Nov 15, 2012 1:25 am
by Tide
Hard to tell try the following:

Press CTRL+F12 to get to the CLI, a task window will open
(if this doesn't work for you: F12 opens the CLI at the bottom of the screen while freezing everything else)

type *USBDevices and identify your mouse
type *USBDevInfo n (where n is the number of the USB device)

For more information

type *USBConfInfo n

Re: HID for wireless KB/Mouse?

Posted: Thu Nov 15, 2012 6:14 pm
by thradtke
This is what I got:

Device 3 is a working, wired mouse. I suspect device 5 must be the wireless desktop.

Code: Select all

*USBDevices
No. Bus Dev Class Description
  1   1   1  9/ 0 Synopsys DWC OTG root hub
  2   1   2  9/ 0 Standard Microsystems Product ID 9512
  3   1   3  0/ 0 Logitech USB-PS/2 Optical Mouse
  4   1   4 FF/ 0 Standard Microsystems SMSC9512/9514 Ethernet device
  5   1   5  0/ 0 Vendor ID 040B 
*USBDevInfo 2
USB release     : 0200
Device class    : 09
Device subclass : 00
Device protocol : 02
Max packet size : 40
Vendor ID       : 0424
Product ID      : 9512
Device ID       : 0200
# of configs    : 1
Manufacturer    : ''
Product         : ''
Serial number   : ''
*USBDevInfo 5
USB release     : 0110
Device class    : 00
Device subclass : 00
Device protocol : 00
Max packet size : 08
Vendor ID       : 040B
Product ID      : 2013
Device ID       : 0200
# of configs    : 1
Manufacturer    : ''
Product         : ''
Serial number   : ''
*

Re: HID for wireless KB/Mouse?

Posted: Fri Nov 16, 2012 3:05 pm
by poglad
Any updates on this? I'm getting exactly the same problem - we must have the same set up, as mine is vendor 040B as well.

I noticed that it says "# of interfaces : 1". Could this be why only the keyboard is working? I would have expected it to report 2 interfaces, one for keyboard, one for mouse.

UPDATE: Just to clarify - when I tried it with my work keyboard/mouse (the Logitech ones) it worked fine. But I can't steal them and take them home with me LOL... the one I have for home is a Sumvision Paradox Touch keyboard with mousepad.

Re: HID for wireless KB/Mouse?

Posted: Fri Nov 16, 2012 3:14 pm
by thradtke
poglad, what is the part number of the desktop set you use at work? I'm really keen on getting one that works under RISC OS.

Re: HID for wireless KB/Mouse?

Posted: Fri Nov 16, 2012 3:19 pm
by thradtke
Oops, missed this:
poglad wrote:[...] Logitech K520 [...]

Re: HID for wireless KB/Mouse?

Posted: Sun Nov 18, 2012 9:05 pm
by poglad
I think it might be MK520 not just K... it works like a dream anyhow.

Re: HID for wireless KB/Mouse?

Posted: Mon Nov 19, 2012 9:58 pm
by MicroMark
I was using a ps2 to USB wired adaptor which was working fine, BUT I got fed-up with the wires across the living room (getting tangled AND tripping me up!).

So I bought a Logitech K400 mini keyboard with a built-in touch pad, it worked out of the box with RISC OS!
I had to run !WinKey as it only has 2 buttons.

But on Raspbian I had to unplug and re-insert the USB receiver to get it to work?

Re: HID for wireless KB/Mouse?

Posted: Tue Nov 20, 2012 3:07 pm
by misterbleepy
I'm using a Logitech K260 wireless keyboard & mouse - cheapest branded thing Argos had when I got the Pi - works fine on Raspbian and RISCOS - and the mouse has 3 buttons and a scroll wheel

Re: HID for wireless KB/Mouse?

Posted: Fri Nov 30, 2012 7:13 am
by thradtke
poglad wrote:I think it might be MK520 not just K... it works like a dream anyhow.
Bought one a couple of days ago when a local outlet had it on offer for 35 EUR. At first, it felt a little cheap, but it does a good job.

Re: HID for wireless KB/Mouse?

Posted: Fri Nov 30, 2012 10:42 am
by Burngate
Bought a wireless KB/mouse from Maplin, months ago for the Pi. Stuttered so much I ditched it.

Got it back out to try it on RISC OS, works perfectly, no stuttering.
BUT it still stutters occasionally on Raspian.

Rapoo, KB says E9070, mouse 9060

Re: HID for wireless KB/Mouse?

Posted: Mon Dec 03, 2012 6:07 pm
by MicroMark
Update:-

As I am mainly using RISC OS, I got fed-up with the lack of a Middle mouse button on the Logitech K400 keyboard, so I bought a M325 wireless (scroll-wheel) mouse - used the Unifing software on my Windows laptop to pair the mouse in addition to the keyboard - plugged the receiver back into the RPi and Hey Presto! - it all works fine, tried it so far in RISC OS and Raspbian.

Re: HID for wireless KB/Mouse?

Posted: Thu Dec 06, 2012 6:11 am
by Terrahawk
I've been using the Thinkpad USB Keyboard with Trackpoint. The middle Trackpoint button works fine as the "Menu" mouse button. Nice and small keyboard too.