Page 1 of 1

!RDPClient not working with Server 2008 R2

Posted: Thu Nov 08, 2012 1:43 am
by felix123
Just found RISC OS yesterday, and it seems to be quite a fast OS.

I'm trying to use the Pi as a thin client. I downloaded !RDPClient. I successfully connected to a Windows 7 machine, but when I tried to connect to a WIndows 2008 R2 server, I got a message saying "RDPClient may have gone wrong. Click Continue to try to resume or Quit to sotp RDPClient". I can connect to the 2008 server using Remote Desktop Connection on Windows and rdesktop on Raspbian. How should I go fix it?

Re: !RDPClient not working with Server 2008 R2

Posted: Thu Nov 08, 2012 1:04 pm
by NigelJK
Are you sure that the server is running the service and that remote connections are allowed?
Also 2008r2 can be very odd with permissions.

Re: !RDPClient not working with Server 2008 R2

Posted: Thu Nov 08, 2012 1:18 pm
by tedhale
OP says he can connect from other systems, so yes RDP is running on the server.

First thing I would check is the RDP authentication level required.
You need to check the box "allow connections for clients running any version of remote desktop"
Server may default to "only allow clients that use network level authentication"

There are also settings in group policy that affect RDP.

Re: !RDPClient not working with Server 2008 R2

Posted: Mon Nov 12, 2012 1:11 pm
by felix123
Yes, it is set to allow any version.

Re: !RDPClient not working with Server 2008 R2

Posted: Fri Nov 16, 2012 4:51 pm
by deroelli
Hi,

Can someone give me a quick tutorial howto install and start !RDPClient?

I'm absolutely new to risc os, but i've read the introduction. Here is what i've got working so far:

- Download the *.zip file
- extract the zip to sd card (so i have a !RDPClient directory)

When i double-click on the new icon all i get is a information message how to use !rdpclient, got all the options etc. at the bottom of the message there's a example how to connect:
Run !rdpclient.connect ....

So my question is: where can i place that command? I've tried the small CLI (by pressing F12), i've tried the command line window by pressing CTRL + F12 but in both cases all i get is a: fatal error message that my window manager is running and that i have to close it.

So can anyone help me?

Re: !RDPClient not working with Server 2008 R2

Posted: Sat Nov 17, 2012 3:00 am
by Kazaii
deroelli wrote:Hi,

Can someone give me a quick tutorial howto install and start !RDPClient?

I'm absolutely new to risc os, but i've read the introduction. Here is what i've got working so far:

- Download the *.zip file
- extract the zip to sd card (so i have a !RDPClient directory)

When i double-click on the new icon all i get is a information message how to use !rdpclient, got all the options etc. at the bottom of the message there's a example how to connect:
Run !rdpclient.connect ....

So my question is: where can i place that command? I've tried the small CLI (by pressing F12), i've tried the command line window by pressing CTRL + F12 but in both cases all i get is a: fatal error message that my window manager is running and that i have to close it.

So can anyone help me?
I'm stuck in the same boat. New to Riscos :(

Re: !RDPClient not working with Server 2008 R2

Posted: Fri Nov 23, 2012 4:39 pm
by NigelJK
RiscOS has a type of command file (or Batch file in MSpeak) called an 'obey' file. They are text in nature and then just require setting the filetype to 'obey'. Any commands in the file will be run if the file is double clicked. If these files live in the !Application directory then there are 2 special ones to consider:

!Boot - will run the commands in the file when the OS first 'sees' the folder.
!Run - will run the commands in the file when the application is double clicked.

If you look inside any application (shift d-click) you will get the idea,

Re: !RDPClient not working with Server 2008 R2

Posted: Wed Nov 28, 2012 5:44 pm
by deroelli
Great, that was quite easy. Thank you!