Page 1 of 1

Ethernet on RISCOS not detectable

Posted: Fri Sep 14, 2018 11:28 pm
by andalus
Hi,

I am running RISCOS for my first time. I tempered a bit with the OS and its windows, but it doesn't detect my Ethernet adapter. It has only a USB-to-Ethernet adapter mentioned in its networking.

Anybody knows how may I let the RISC OS detect the ethernet adapter?

I am using Raspberry Pi 3.

Best,

Amjad

Re: Ethernet on RISCOS not detectable

Posted: Wed Sep 26, 2018 6:24 pm
by andalus
would anybody jump to help? :(

Re: Ethernet on RISCOS not detectable

Posted: Wed Sep 26, 2018 8:59 pm
by fruitoftheloom
andalus wrote:
Fri Sep 14, 2018 11:28 pm
Hi,

I am running RISCOS for my first time. I tempered a bit with the OS and its windows, but it doesn't detect my Ethernet adapter. It has only a USB-to-Ethernet adapter mentioned in its networking.

Anybody knows how may I let the RISC OS detect the ethernet adapter?

I am using Raspberry Pi 3.

Best,

Amjad

Maybe ask the developers ??

https://www.riscosopen.org/forum/

Re: Ethernet on RISCOS not detectable

Posted: Thu Sep 27, 2018 1:50 pm
by bulldozer
Hi what RISCOS are you using and which Pi you are using. I have an out of the box Pi 3B and a SD card from ROOL and it works quite nicely.

Re: Ethernet on RISCOS not detectable

Posted: Thu Sep 27, 2018 2:10 pm
by bulldozer

Re: Ethernet on RISCOS not detectable

Posted: Sun Sep 30, 2018 7:41 pm
by andalus
bulldozer wrote:
Thu Sep 27, 2018 1:50 pm
Hi what RISCOS are you using and which Pi you are using. I have an out of the box Pi 3B and a SD card from ROOL and it works quite nicely.
I am using RPi 3B. I installed the OS from the website and put it on the SD card. The OS opens with no problem. but it seems it can't detect or see the ethernet nor the wifi adapters.

Re: Ethernet on RISCOS not detectable

Posted: Sun Sep 30, 2018 8:56 pm
by andalus
bulldozer wrote:
Thu Sep 27, 2018 2:10 pm
Also an interresting piece at http://www.riscos.org/networking/riscos.html
Also perhaps of interrest : https://www.riscosopen.org/wiki/documen ... Networking
Thanks. I've looked into those posts but they assume I have the ethernet card icon. I don't.

Re: Ethernet on RISCOS not detectable

Posted: Sun Sep 30, 2018 8:56 pm
by andalus
fruitoftheloom wrote:
Wed Sep 26, 2018 8:59 pm
andalus wrote:
Fri Sep 14, 2018 11:28 pm
Hi,

I am running RISCOS for my first time. I tempered a bit with the OS and its windows, but it doesn't detect my Ethernet adapter. It has only a USB-to-Ethernet adapter mentioned in its networking.

Anybody knows how may I let the RISC OS detect the ethernet adapter?

I am using Raspberry Pi 3.

Best,

Amjad

Maybe ask the developers ??

https://www.riscosopen.org/forum/
Thanks. This is what I eventually did.

Re: Ethernet on RISCOS not detectable

Posted: Mon Oct 01, 2018 9:40 am
by bulldozer
andalus wrote:
Sun Sep 30, 2018 7:41 pm
bulldozer wrote:
Thu Sep 27, 2018 1:50 pm
Hi what RISCOS are you using and which Pi you are using. I have an out of the box Pi 3B and a SD card from ROOL and it works quite nicely.
I am using RPi 3B. I installed the OS from the website and put it on the SD card. The OS opens with no problem. but it seems it can't detect or see the ethernet nor the wifi adapters.
If you downloaded it strait it shouldn't be a problem but I see that you also submitted the question on the ROOL forum. WiFi is not supported by RISCOS at this moment.

Re: Ethernet on RISCOS not detectable

Posted: Wed Oct 03, 2018 6:28 pm
by andalus
It is working now.
on RISCOS forums they said that USB-to-Ethernet adapter that i see on my settings is the Ethernet. but because they Ethernet on the RPi 3 is USB based then that's why it appears this way.

Another point of confusion that happened with me is, after the RISCOS fails to get an IP address from DHCP, it falls back to manual IP address. Even If I try to reboot again, the IP assignment settings is set permanently to manual assignment!!! I assumed it should try DHCP every time it boots but it seems it is not. I had to go to the IP assignment settings and change it to DHCP to get it to work with DHCP server.
Now things are fine. thank you all for your valuable assistance.

Amjad

Re: Ethernet on RISCOS not detectable

Posted: Thu Oct 04, 2018 10:05 pm
by bulldozer
Your welcome no problem. If you have more questions please don't hesitate to ask...