Page 1 of 1

RISCOS & RPiZero screen issues...

Posted: Mon Feb 15, 2016 10:21 pm
by ausppc
The RiscOS SD card image I found was compiled by a forum user. Is there an actual official image provided by (?) for the PiZero?

The mouse pointer appears outside of the desktop area but still not to the top-leftest of my display.

Same again but for lower-rightest of my display.

I had to click a little way outside of the window border to reposition the window slider.

Edit: I haven't had a chance to try this but this looks like a somewhat promising post re: RiscOS on the PiZero -

2nd Edit: After following the directions of the above link, the start-up is a little different but I still end up with a desktop that has messed up geometry.

Startup now waits at this point until the Esc key is pressed...

Re: RISCOS & RPiZero screen issues...

Posted: Wed Feb 17, 2016 7:30 am
by BrokenFrog
I think you need to disable overscan in the config.txt.

Do this AT YOUR OWN RISK! I'm doing it from memory! You might completely muck up how the computer boots up, and need to reinstall the original image. My guess is you've got nothing to lose unless you've adjusted your hand-eye co-ordination to the mouse being slightly out of place all the time!

Click on the SD icon to open a Filer window. Hold down shift and double-click the !Boot application. Inside there, you will see a "directory" called Loader (It's not really a directory, it's actually a secret partition on the SD card, used for the pre-RISC OS boot-up files and the RISC OS ROM image). Double click the Loader directory. Inside there, you will see config.txt file. You might want to make a copy of this somewhere else before continuing.

Click on config.txt and it should open in an editor. Look for any entries mentioning "overscan". It may be worth deleting them and adding an entry at the end saying:

Code: Select all

Save the file as config.txt in the same place as the original.

As for the issue where you have to press Esc to continue booting. This is because it's trying to connect to a network and maybe your Pi doesn't have an ethernet cable connected to attach it to a network. If you wait, it will eventually carry on regardless, but it's tedious.

If you're NOT connecting it to a network, you can either press Esc to get past it or allow it to finish in its own time. Once you've managed to load the desktop, click on the SD icon to open the filer window. This time, just double-click on the !Boot application (no shift key required) and look for the Network icon. Click on it and you will be presented with three options: AUN, Access and Internet. My guess is Internet has a green light under it? Click on it and untick Enable TCP/IP Protocol Suite. Click Close, then Click Save. You will have to reboot your Pi for the changes to take effect and it will give you an option to do so now or later. It's up to you, but next time it boots, it should just skip the command to check for a network connection.

As I said, from memory...

Re: RISCOS & RPiZero screen issues...

Posted: Wed Feb 17, 2016 6:24 pm
by svrsig
Startup now waits at this point until the Esc key is pressed...
If you have turned on IP, then this is the correct behaviour unless you add a USB/Internet dongle. If you turn off IP then it won't pause.

Re: RISCOS & RPiZero screen issues...

Posted: Wed Feb 17, 2016 8:12 pm
by ausppc
Thank you both - very helpful! I'll be trying those suggestions.

btw I noticed that Linux Mint doesn't mount the RiscOS image after it's been created but another OS I used does mount the FAT partition so I've been able to view and otherwise mess around with the files on that partition - backing up and modifying the config.txt file won't be a problem. Thanks again!

Edit: Now I've had a change to try adding 'disable_overscan=1' to config.txt - success! Now I can finally have a proper play with RiscOS. Thanks again. :D