calverb
Posts: 12
Joined: Wed Sep 12, 2012 9:32 am
Location: North Lancashire

Can't Start, Won't Start

Tue Sep 25, 2012 9:20 am

I'm looking for some help in getting RISCOS working on my PI. I have downloaded the image and written it to an SD card.

Network Cable plugged in
USB keyboard and mouse connected
HD TV as monitor.
Power up.
The screen displays a graphic background with a command window.
No mouse pointer.
Messages are no keyboard (clearly an error as I can type commands into the window though they are too small to read reliably) and Error: the disk drive is empty.

I have checked my DHCP server (Home Hub) and it isn't allocating an address to the Pi though the LEDs on the Pi show network activity.

Typing something like !boot in the command window just tells me the drive is empty.

Have I missed something ?

Bob

microbitsuk
Posts: 33
Joined: Fri Sep 09, 2011 10:04 am
Location: Perth WA
Contact: Website

Re: Can't Start, Won't Start

Tue Sep 25, 2012 9:44 am

type desktop then press return

sawdust
Posts: 40
Joined: Fri Jul 27, 2012 7:09 am

Re: Can't Start, Won't Start

Tue Sep 25, 2012 10:37 am

Is it just the ROM image you have downloaded and installed or the distro image?

Sawdust.

calverb
Posts: 12
Joined: Wed Sep 12, 2012 9:32 am
Location: North Lancashire

Re: Can't Start, Won't Start

Tue Sep 25, 2012 1:58 pm

microbitsuk wrote:type desktop then press return
Thanks - that did the trick, a sort of xyzzy invocation.

Bob

User avatar
Ibanezjem
Posts: 33
Joined: Tue Mar 20, 2012 7:58 pm
Location: Stafford, UK

Re: Can't Start, Won't Start

Tue Sep 25, 2012 6:03 pm

Error: the disk drive is empty.
What is the distro you are using? The 22nd September did have an issue which caused the above. This has been addressed in the 24th September distro.
A link to this can be found on:
https://www.riscosopen.org/wiki/documen ... 20image%29
Even though it still refers to the 22 Sep version, it has been updated. It worked for me this afternoon.
File size should be approx 80.1Mb not 73.3Mb
Messages are no keyboard
Don't worry about this, I think it might be looking for a PS/2 keyboard found on other hardware.
Once it has initialised the USB stuff, it should find your keyboard as you discovered.
Should then boot straight into usable desktop.

calverb
Posts: 12
Joined: Wed Sep 12, 2012 9:32 am
Location: North Lancashire

Re: Can't Start, Won't Start

Tue Sep 25, 2012 6:54 pm

It was an older Distro - I've now downloaded the one you pointed to and dropped it onto a SD card - this boots fine with the network connected. I need to change toe overscan settings to stop the desktop spilling over the screen edge.

Many thanks

Bob

BadWolf1959
Posts: 23
Joined: Sat Sep 15, 2012 7:01 pm

Re: Can't Start, Won't Start

Mon Nov 05, 2012 10:09 pm

Im totally new to RISC OS and have run into a simmular issue. I keep getting the disk drive is empty error and I dont understand how it is that you fixed it??
Can you help me please??
If my former sig offended you I am sorry...it was a quote from Douglas Adams - HHGTTG

Joe Schmoe
Posts: 4277
Joined: Sun Jan 15, 2012 1:11 pm

Re: Can't Start, Won't Start

Mon Nov 05, 2012 10:41 pm

I think the "no keyboard" message is referring to something other than a USB keyboard (the only option for a keyboard on the Pi) - because the USB drivers aren't loaded at that point.

I'm guessing that it is looking for a serial connection. One of these days, once my serial hardware arrives, I'm going to try it with a serial hookup active - I'm guessing I won't get that message.
And some folks need to stop being fanboys and see the forest behind the trees.

(One of the best lines I've seen on this board lately)

theom
Posts: 73
Joined: Wed Jun 13, 2012 2:53 pm

Re: Can't Start, Won't Start

Mon Nov 05, 2012 10:56 pm

'No keyboard' is, I think, complaining about the lack of a PS/2 keyboard. Normally you can hold down shift on powerup to boot to a minimal environment as if you didn't have a disc at all. This is what various people (including BadWolf1959) are experiencing if there's a problem detecting their SD card (it's a bit like Windows Safe Mode, but more useful). It's complaining that there's no keyboard spotted by this point so it can't check if Shift is held down, so it's going to assume a normal boot - the USB keyboard is initialised later. The message is normal on USB-only machines, though I agree it's a bit confusing!

RISC OS' primary interface is via the GUI, so it doesn't have a serial terminal by default. There's ways of enabling this (BBC Micro users might remember *FX2 and *FX3... that still works - up to a fashion).

NigelJK
Posts: 65
Joined: Wed Sep 05, 2012 1:44 pm

Re: Can't Start, Won't Start

Tue Nov 06, 2012 2:48 pm

The original bootstrapper for the Archimedes and the RiscPc would look for a serial keyboard/mouse (this was non-standard until the RPC), but would then boot without if necessary (allowing for one of the earliest 'headless' machines) usually this would then boot into a custom application as opposed to the desktop. All of this is still possible of course.

cgozzarf
Posts: 2
Joined: Thu Nov 08, 2012 6:35 pm

Re: Can't Start, Won't Start

Thu Nov 08, 2012 6:59 pm

also getting the... "the disk drive is empty" error... any solutions out there?? Using windows 7

theom
Posts: 73
Joined: Wed Jun 13, 2012 2:53 pm

Re: Can't Start, Won't Start

Thu Nov 08, 2012 7:17 pm

'Disk drive is empty' means that the RISC OS partition on your SD card can't be detected. This either means you didn't write the SD card right, or RISC OS doesn't like your SD card, or you have power supply problems.

To see if RISC OS can at least find your SD card, press F12 and type
*SDIODevices

and see if anything is listed.

trevj
Posts: 65
Joined: Fri Oct 28, 2011 6:41 am
Location: Bristol, UK

Re: Can't Start, Won't Start

Fri Nov 09, 2012 12:49 pm

The recent distro thread for this is at "error on boot":
http://www.raspberrypi.org/phpBB3/viewt ... 55&t=22173

Return to “RISCOS”

Who is online

Users browsing this forum: No registered users and 2 guests