Page 1 of 1

Gentoo/pi newbie questions

Posted: Tue Jun 05, 2012 3:20 pm
by MrZammler
Hi all,

I've been using Gentoo exclusively for the last 10 years or so, but the rpi is my first non-x86 machine, so I have a couple of questions. I'd like to use Gentoo as the base OS and build from there.

1) How does the quake III/fuse zx emulator demoed on the pi work without X11? I assume they are patched to use opengl es instead of full opengl? Is that all that it takes + maybe use pi specific libraries?

2) If so, am I right to assume that something similar can be done for e.g. SDL, thus being able to run any SDL based apps right from the framebuffer without the need for X11 (via directfb maybe)? Do the Gentoo builds here support opengl es?

3) Has anyone tried to compile XBMC (the pi "version" with omx*) on Gentoo?

Thanks a lot!

Re: Gentoo/pi newbie questions

Posted: Mon Jun 11, 2012 9:01 am
by MrZammler
Replying to my own thread :-)

I've tried over the past days to setup my pi. I've installed the minimal image, setup a cross compiler, and installed the /opt/vc/ files. Tried the hello_* examples, all work fine.

I've then installed sdl with directfb backend. Some simple SDL apps run fine from the framebuffer (although slow, but ok).

The problem is with the fuse emulator. I'm trying to recreate what I saw in the demo ( but without luck. I compiled fuse and libspectrum both manually and via portage. Both tries result to seg faults, although it tries to start, and directfb opens a display.

Anyone have any clue why is that?

Re: Gentoo/pi newbie questions

Posted: Thu Jun 14, 2012 1:59 pm
by MrZammler
Fuse works now with fbcon SDL backend.

Re: Gentoo/pi newbie questions

Posted: Mon Jun 18, 2012 9:40 am
by MrZammler
I've been on it for the last couple days, and I'm surprised at what this thing can do!

Tried an Amstrad CPC emulator, as well as ScummVM and both run fantastic!

Re: Gentoo/pi newbie questions

Posted: Thu Jun 21, 2012 8:47 am
by emptybee
Hi MrZammler,

Would it be too much to ask how you got fuse running with SDL? I'm dying to get this working (with sound) on either arch or debian. On Debian I installed libsdl1.2-dev but when it came to ./configure --with-sdl (in fuse source folder) it throws up error:

checking for sdl-config... no
checking for SDL - version >= 1.2.4... no

Can't work out how to get around this and would really like to make a fully working (i.e. with sound) ZX Spectrum on the raspberrypi to put into my old ZX Spectrum 48k case as the board died years ago (dodgy ULA).

Any help on this would be much appreciated!



Re: Gentoo/pi newbie questions

Posted: Fri Jun 29, 2012 7:51 pm
by MrZammler
I've just emerged libsdl with fbcon backend. :-)

Check my log at my blog here: ... emulators/

let me know if you need any more help.

Re: Gentoo/pi newbie questions

Posted: Fri Jun 29, 2012 7:53 pm
by MrZammler
Ah, sorry, just re-read your post and saw debian.

So, not sure on that one... But it should find libsdl if you've installed it from your package manager (emerge is just that for gentoo). Sorry, I haven't really used debian much.