rwcooper
Posts: 41
Joined: Wed Dec 30, 2015 9:04 pm

Wrong default keyboard on boot - gentoo 64-bit

Thu Oct 03, 2019 11:33 pm

Hi,

I can't seem to get a "US" keyboard recognized as such at the login prompt. Once I'm logged in it is set up correctly. I though if I wrote keymap="us" in /etc/conf.d/keymaps and then rebooted this would work, but it doesn't. Any suggestions on how to fix this are greatly appreciated.

Thanks, Randy

User avatar
Pulsar33
Posts: 174
Joined: Sun Aug 25, 2019 4:06 pm
Location: Bordeaux France

Re: Wrong default keyboard on boot - gentoo 64-bit

Fri Oct 04, 2019 7:18 am

Hello,

Not sure it's the right way but you can edit /etc/default/keyboard ...

BR
Pulsar33
Pi 4 with 4Gb memory, DVB TV pHAT ------------------- Desktop : Core i5 Linux MINT 19.3

User avatar
DougieLawson
Posts: 39183
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Wrong default keyboard on boot - gentoo 64-bit

Fri Oct 04, 2019 8:50 am

Pulsar33 wrote:
Fri Oct 04, 2019 7:18 am
Not sure it's the right way but you can edit /etc/default/keyboard ...
The "official" DebIan way is sudo dpkg-reconfigure keyboard-configuration but with the original (July) release of Raspbian Buster that was so broken it was unusable. Haven't tried it on Raspbian 2019-09-26.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

geev03
Posts: 174
Joined: Thu Jun 07, 2012 12:40 pm
Location: London, UK

Re: Wrong default keyboard on boot - gentoo 64-bit

Fri Oct 04, 2019 10:10 am

rwcooper wrote:
Thu Oct 03, 2019 11:33 pm
Hi,

I can't seem to get a "US" keyboard recognized as such at the login prompt. Once I'm logged in it is set up correctly. I though if I wrote keymap="us" in /etc/conf.d/keymaps and then rebooted this would work, but it doesn't. Any suggestions on how to fix this are greatly appreciated.

Thanks, Randy
Please see the attached screenshot.
The system default is UK Keyboard. From 'Applications,, select 'settings' and then 'keyboard'. Untick the system default and proceed to select the desired keyboard (in any language etc.)
Attachments
gentoo_keyboard_selection.jpg
gentoo_keyboard_selection.jpg (139.15 KiB) Viewed 2736 times

rwcooper
Posts: 41
Joined: Wed Dec 30, 2015 9:04 pm

Re: Wrong default keyboard on boot - gentoo 64-bit

Fri Oct 04, 2019 1:11 pm

Thanks for the replies. I'm still stuck. When I boot up under gentoo I am auto logged into demouser. If I then do Applications Log Out Log Out I am presented with the Log in dialog box. There is where the problem occurs. If I have a password that contains characters where the same keys on my keyboard are interpreted differently for English UK and English US key maps I can't login. If I have a password that doesn't use any of those characters then I can login fine. Once I'm logged in the keys are mapped correctly...Randy

rwcooper
Posts: 41
Joined: Wed Dec 30, 2015 9:04 pm

Solved: Wrong default keyboard on boot - gentoo 64-bit

Fri Oct 04, 2019 2:11 pm

I had to change the XkbLayout option in /etc/X11/xorg.conf.d/00-keyboard.conf from "gb" to "us" in order to solve this.
BTW: Is there any way to mark a thread as SOLVED?

Return to “Gentoo”