rugar
Posts: 7
Joined: Fri Oct 05, 2012 12:40 pm

net.eth0 modules missing

Fri Oct 05, 2012 1:15 pm

hey,

i am about to setup my pi with gentoo. i've followed the articles in the gentoo wiki and elinux pi kernel compilation wiki but i can't figure out how to get my network to work. if i enter "/etc/init.d/net.eth0 start" it always fails with
* ERROR: interface eth0 does not exist
* Ensure that you have loaded the correct kernel module for your hardware
* ERROR: net.eth0 failed to start
i've used the config file provided from arch/arm/configs/bcmrpi_cutdown_defconfig as stated in the elinux wiki and haven't changed it.
you can see it here: https://github.com/raspberrypi/linux/bl ... _defconfig

i don't know how to figure out which module is needed. anyone having a working config? what modules do i need for networking?

IntelMiner
Posts: 22
Joined: Wed Jul 18, 2012 1:07 pm

Re: net.eth0 modules missing

Fri Oct 05, 2012 4:19 pm

Try cd /etc/udev/rules.d/

See if "70-persistent-net.rules" exists, and if so, remove it and reboot

That should solve your issue

rugar
Posts: 7
Joined: Fri Oct 05, 2012 12:40 pm

Re: net.eth0 modules missing

Fri Oct 05, 2012 5:44 pm

thanks for your reply. i've checked the directory and it was empty. the problem seems to be something else :(

rugar
Posts: 7
Joined: Fri Oct 05, 2012 12:40 pm

Re: net.eth0 modules missing

Fri Oct 05, 2012 5:52 pm

what should the output be in dmesg when networking is working? i can't find any output about networking related hardware in dmesg.

IntelMiner
Posts: 22
Joined: Wed Jul 18, 2012 1:07 pm

Re: net.eth0 modules missing

Sat Oct 06, 2012 5:54 am

http://bpaste.net/raw/49575/ Here's my dmesg, you should be able to compare them

rugar
Posts: 7
Joined: Fri Oct 05, 2012 12:40 pm

Re: net.eth0 modules missing

Mon Oct 08, 2012 3:05 pm

thanks allot for your help. i've figured out that i've compiled it wrong somehow. started from scratch again and it worked out nicely. :)

Return to “Gentoo”