Mplayer freezes after a few seconds

5 posts
by oliva » Sun Jun 17, 2012 1:53 pm
I have tried this with both mplayer and mplayer2, and playing an audio file causes mplayer to stop and not react to anything but ^C.
Using alsa as output, and no X.
Everything is from the default arch repos.

the output is (with error message at the end):
Code: Select all
MPlayer UNKNOWN-4.6.3 (C) 2000-2012 MPlayer Team
183 audio & 398 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/Music/Compilations - game/Stuart Chatwood/Prince of Persia Warrior Within Original/01 Welcome Within.mp3.
libavformat version 54.2.100 (internal)
Audio only file format detected.
Clip info:
 Title: Welcome Within
 Artist: Stuart Chatwood
 Album: Prince of Persia Warrior Withi
 Year: 2005
 Track: 1
 Genre: Other
Load subtitles in /mnt/Music/Compilations - game/Stuart Chatwood/Prince of Persia Warrior Within Original/
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 44100 Hz, 2 ch, s16le, 32.0 kbit/2.27% (ratio: 4000->176400)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.6 (00.5) of 203.0 (03:23.0)  5.7%

MPlayer interrupted by signal 2 in module: play_audio
[AO_ALSA] Write error: Operation not permitted
[AO_ALSA] Trying to reset soundcard.
[AO_ALSA] alsa-lib: pcm_hw.c:558:(snd_pcm_hw_prepare) SNDRV_PCM_IOCTL_PREPARE failed (-16): Device or resource busy
[AO_ALSA] pcm prepare error: Device or resource busy
A:   0.8 (00.7) of 203.0 (03:23.0)  5.9%

Exiting... (Quit)

After that, when I play a song again, it works, but only for a short time.
aplay and vlc work as supposed
Posts: 4
Joined: Thu May 31, 2012 7:23 pm
by dom » Thu Jun 21, 2012 1:12 pm
I've fixed a problem in ALSA driver. Please update and retest. ... g_firmware
Forum Moderator
Forum Moderator
Posts: 4448
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by oliva » Thu Jun 21, 2012 6:51 pm
dom wrote:I've fixed a problem in ALSA driver. Please update and retest. ... g_firmware

As you may not know, Arch has a raspberrypi-firmware package, so it updates without the need for any external script, but somehow the new firmware (2010617-1) or linux update (raspberrypi-3.1.9-22) broke my system, and because I have no backups I had to rollback both the firmware and kernel files to the stock (archlinuxarm 29-04-2012)
I have tried only updating the kernel or firmware, both, and also using the new debian testing (all stock from the images), but none of them booted, only answering that they are unable to find the root device.

I will retry again, as soon as a new update (which boots for me) is released.
Also, I have a 16GB class10 Samsung sdcard.
Posts: 4
Joined: Thu May 31, 2012 7:23 pm
by pepedog » Thu Jun 21, 2012 8:25 pm
Posts: 1012
Joined: Fri Oct 07, 2011 9:55 am
by oliva » Fri Jun 22, 2012 7:56 am
Running rpi-update after the latest Arch update solved my problem, and the playback works as expected.
Posts: 4
Joined: Thu May 31, 2012 7:23 pm