martinadams
Posts: 2
Joined: Tue Jun 12, 2012 5:19 pm

No HDMI output when powered?

Tue Jun 12, 2012 5:24 pm

I've just tried reimaging the archlinux distribution onto my SD card, but when I power it up, nothing appears on my monitor. The debian squeeze image worked fine.

I downloaded it earlier today and verified the embedded sha1 checksum from the zip.

Anyone else having a similar issue?

itimpi
Posts: 1076
Joined: Sun Sep 25, 2011 11:44 am
Location: Potters Bar, United Kingdom
Contact: Website

Re: No HDMI output when powered?

Tue Jun 12, 2012 5:55 pm

You might want to check if there is a config.txt file on the FAT partition. If so removing (or renaming) it may help. If that file is present and has settings incompatible with your system it can cause your symptoms.

chad
Posts: 2
Joined: Mon Jun 11, 2012 3:43 pm

Re: No HDMI output when powered?

Tue Jun 12, 2012 6:09 pm

I know I had to wipe the "config.txt" file before I got Arch to boot on my Pi. I could only get the AV to work until I did. Most people are having issues with these personalised settings in the default file it seems.

Check the Wiki for the configuration options for setting up HDMI to work perfectly. Best to wipe it and build your own settings up from scratch.

Kev
Posts: 2
Joined: Fri Jun 08, 2012 9:04 am

Re: No HDMI output when powered?

Tue Jun 12, 2012 10:34 pm

There is also an issue with some SDHC with the image of archlinuxarm. Just replace the relevant files with the actual ones from the repository or wait until there is an more up to date image for download.

I did a bug report on this today: https://github.com/archlinuxarm/PKGBUILDs/issues/174

pepedog
Posts: 1044
Joined: Fri Oct 07, 2011 9:55 am

Re: No HDMI output when powered?

Tue Jun 12, 2012 11:46 pm

Firmware rebuilt, update fixes.
I feel a new rootfs is due.

martinadams
Posts: 2
Joined: Tue Jun 12, 2012 5:19 pm

Re: No HDMI output when powered?

Wed Jun 13, 2012 9:20 am

Thanks for the help, renaming the config.txt on the SD card worked perfectly! Much appreciated.

Benedict White
Posts: 224
Joined: Sat Dec 24, 2011 12:24 am

Re: No HDMI output when powered?

Sat Jun 16, 2012 4:38 pm

Where is the page on the wiki which tells me what could or indeed should be in config.txt?

I don't get any HDMI output either, I suspect because the config.txt sets an HDMI mode that my monitor doesn't support.


Benedict White
Posts: 224
Joined: Sat Dec 24, 2011 12:24 am

Re: No HDMI output when powered?

Sat Jun 16, 2012 9:20 pm

Can you remove the HDMI mode line from config.txt and perhaps just have config.txt containing information on what can be set or a reference to an online manual?

All I did to actually boot was put # in front of all lines and that did work but should also work "out of the box" or else people will just use Debian.

Well done on getting it working though.

pepedog
Posts: 1044
Joined: Fri Oct 07, 2011 9:55 am

Re: No HDMI output when powered?

Sat Jun 16, 2012 10:18 pm

You read my mind, new rootfs in the wings last 2 days with this, should exist tonight on mirrors

Benedict White
Posts: 224
Joined: Sat Dec 24, 2011 12:24 am

Re: No HDMI output when powered?

Sat Jun 16, 2012 10:42 pm

Didn't take long... ;)

Cool! :)

User avatar
khisanth
Posts: 36
Joined: Thu Jan 19, 2012 11:49 pm
Location: Farnborough
Contact: Website

Re: No HDMI output when powered?

Thu Jun 21, 2012 5:31 pm

renaming the config.txt worked for me too! deleting didnt :D

Return to “Arch”

Who is online

Users browsing this forum: No registered users and 5 guests