gcsx
Posts: 18
Joined: Tue Apr 29, 2014 10:00 pm

Using HSO driver with Arch Linux

Mon May 05, 2014 5:09 pm

Hello,

I would like to use an old Option GlobeSurfer Icon 7.2 http://www.option.com/support/globesurfer-icon-7-2 to send and receive SMS from / to my Pi.

Here is what I have :
  • A Pi model B rev 2 running ArchLinux with 3.10.38-1-ARCH kernel.
  • Powered USB 2 hub with 2A power supply.
  • The HSO driver. I compiled it as a module from source on the Pi's kernel Git https://github.com/raspberrypi/linux.
  • (Obviously) An Option GlobeSurfer Icon 7.2
What I have done :
  • I installed the driver (modprobe) and it loads when I plug the Icon to the Pi.
  • I can see the 5 virtual serial ports (/dev/ttyHS*) of the HSO driver.
The problem :
I tried minicom and picocom to open the Application port (/dev/ttyHS1 or /dev/ttywapp0 wich is an alias).
minicom is disconnected immediately.
With picocom I get "Terminal ready", but when I type "ATI<return>", I get nothing. (I should get device infos from the Icon).

I tried on Windows with TeraTerm and it works, demonstrating that the problem is not the Icon.

There is no error messages in dmesg.

Did anyone make this driver to work on a Pi ?

Thanks.


EDIT
I finally made it work!

Actually, it was working from the start.
I said I was using the Application port (ttyHS1 or wapp0). I choose this port because it's the one I use under Windows and it always worked perfectly.

Under Linux, this port seems to be inactive. Today, I tried, just to see, the Modem port (ttyHS5 or wmodem0), and it works.

Problem solved.

Return to “Arch”