psgarcha92
Posts: 16
Joined: Fri Oct 12, 2012 5:19 am

Help! Cannot Change size of Console Font!!

Fri Apr 05, 2013 4:13 pm

Hey Guys

I am trying out ArchLinux for the first time, it sounds like fun...
But i run into a problem, that i am unable to find a solution for...

I am unable to change the size of fonts in the console, i.e, the startup terminal.

I have tried nano /etc/vconsole.conf
which now has
KEYMAP=us
FONT=lat2-terminus16 (changed from default)
FONT_MAP=8059-1_to_uni

and i have tried FONT=lat2-16
FONT=lat2-terminus16
and after both, showconsolefont.

Please dont point me to https://wiki.archlinux.org/index.php/Fonts
I am unable to use any info from that page whatsoever.

Please Help.
Regards

sdjf
Posts: 1395
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: Help! Cannot Change size of Console Font!!

Fri Apr 05, 2013 5:19 pm

Do you want to make the font bigger or smaller? Or is it the size of your monitor and margins that could be the issue?

After you change the /boot/config.txt or /etc/vconsole.conf files, you have to reboot to have the changes take effect.
FORUM TIP: To view someone's posting history, sign in, click on their user name, then on "Search User's Posts." || Running ArchLinuxArm on Model 2B and 512MB Model B

psgarcha92
Posts: 16
Joined: Fri Oct 12, 2012 5:19 am

Re: Help! Cannot Change size of Console Font!!

Fri Apr 05, 2013 5:25 pm

I want to make the font bigger,
my Overscan settings are totally fine, i used the same ones form Raspibian Wheezy config.txt

Ok, i rebooted and the font changed. I chenged the font to Terminus-16, but its still small.

I dont know how i could be so fooling not rebooting after these changes.
Thanks a lot sdjf,
Is there a font that supports larger sizes??

Regards

sdjf
Posts: 1395
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: Help! Cannot Change size of Console Font!!

Sun Apr 07, 2013 5:38 am

My pi is headless, hopefully someone else can answer your question about increasing font sizes. I would think that it is not the font but the resolution on your monitor that determines how big you can make the fonts, but really do not know.

I tried looking in the font files but didn't see anything obvious to help.
FORUM TIP: To view someone's posting history, sign in, click on their user name, then on "Search User's Posts." || Running ArchLinuxArm on Model 2B and 512MB Model B

av8r1
Posts: 20
Joined: Mon Jun 23, 2014 7:04 pm

Re: Help! Cannot Change size of Console Font!!

Mon Jun 23, 2014 10:38 pm

I've got a bit of a problem. I want to make my font bigger (In fact, that's an almost constant problem I've had with Linux), but there IS no /etc/vconsole.conf. What the heck am I supposed to do?

sdjf
Posts: 1395
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: Help! Cannot Change size of Console Font!!

Wed Jun 25, 2014 4:30 am

Welcome to Linux!!! What I always do if my system does not have a required configuration file, is create one!

I hunt the internet for one that looks like it is basic, and put a copy where it belongs.

In this case, you can copy the original poster's config file, or here is what is in mine:

rpi# cat /etc/vconsole.conf
KEYMAP=us
FONT=lat9w-16
FONT_MAP=8859-1_to_uni
rpi#

You might want to install some font packages to give yourself more choices, and the above may not work in this case if you have not run basic setup commands that I forget what they are, but you can certainly try it, nothing to lose.

Then, if you want to have other choices of fonts, the following command will show you what font packages are available to use in the ALARM repository:

pacman -Ss font

Actually, pacman -Ss is very cool, it will also show you what (if any) font packages are already installed on your system.
FORUM TIP: To view someone's posting history, sign in, click on their user name, then on "Search User's Posts." || Running ArchLinuxArm on Model 2B and 512MB Model B

mw0sec
Posts: 13
Joined: Thu Oct 25, 2018 2:31 pm

Re: Help! Cannot Change size of Console Font!!

Fri Nov 23, 2018 1:32 pm

If you are talking about the lxterminal on the PI, The font can be changed from small to really huge by selecting the edit tab at the top, preferences/style/terminal font. This brings up a selector for a great range of sizes. The great thing is that the system remembers this setting even after reboot. No need for any script-hacking.
Les.

Return to “Arch”