deanjm68
Posts: 3
Joined: Fri Nov 27, 2020 11:49 am

Re: Script for Argon one pi4 fan ???

Fri Nov 27, 2020 2:18 pm

That's great thanks. I noticed during the installation it was showing I2C was not enabled how do I enable it?

DarkElvenAngel
Posts: 1276
Joined: Tue Mar 20, 2018 9:53 pm

Re: Script for Argon one pi4 fan ???

Fri Nov 27, 2020 2:35 pm

deanjm68 wrote:
Fri Nov 27, 2020 2:18 pm
That's great thanks. I noticed during the installation it was showing I2C was not enabled how do I enable it?
You just have to reboot then it is enabled.

deanjm68
Posts: 3
Joined: Fri Nov 27, 2020 11:49 am

Re: Script for Argon one pi4 fan ???

Fri Nov 27, 2020 2:37 pm

Great, thanks

Shen Hsu
Posts: 2
Joined: Sun Nov 29, 2020 3:31 am

Re: Script for Argon one pi4 fan ???

Sun Nov 29, 2020 6:06 am

hectorkvs wrote:
Wed Apr 22, 2020 1:59 am
Here is the proper way to install script for Argon One case running on Manjaro ARM both KDE Plasma and XFCE:

git clone https://github.com/Elrondo46/argonone.git
cd argonone
sudo pacman -S base-devel (to install some missing packages)
makepkg -si
yay -S raspberrypi-userland-aarch64-git
sudo systemctl enable argononed.service
sudo reboot

Make sure you put this in config.txt on boot partition before rebooting :
dtparam=i2c_arm=on
dtparam=i2c-1=on
enable_uart=1

Also I forgot to mention that the ' enable_uart=1 ' in /boot/config.txt in conjunction with having ' kgdboc=ttyAMA0,115200 ' mentioned in /boot/cmdline does crash the kernel (kernel panic) so please check for this if you are planning on automatically add the uart-option to /boot/config.txt.I did fix this by removing ' kgdboc=ttyAMA0,115200 ' from my /boot/cmdline.
If you have a problem with shuting down when the power isn't cut as it should (power led still working, after pi shutdown), you need to change in ' /usr/lib/systemd/system-shutdown/argononed-poweroff.py ' the following:

Line 20
bus.write_byte_data(0x1a,0,0) to looks like this..

hope this help
I follow this guide, but the FAN and power button is not workable on my RPi4 with Manjaro KDE Plasma, any help appreciated!

Below is the I2C baudrate get from my RPi4, is it abnormal? (I have set the "dtparam=i2c_arm_baudrate=32000" and "dtparam=i2c_baudrate=32000" in the "boot/config.txt".)
[raspberrypi@raspberrypi ~]$ sudo cat /sys/module/i2c_bcm2708/parameters/baudrate
0
[raspberrypi@raspberrypi ~]$ sudo cat /sys/module/i2c_bcm2835/parameters/debug
0

Follow is my status of argononed.service, there's no any error...
By the way, I try to select the "FAN always ON" on the argonone-config, but the FAN is still not work.

[raspberrypi@RaspberryPi ~]$ sudo systemctl status argononed.service
[sudo] raspberrypi 的密碼:
● argononed.service - Argon One Fan and Button Service
Loaded: loaded (/usr/lib/systemd/system/argononed.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2020-11-29 13:46:42 CST; 14min ago
Main PID: 1428 (python3)
Tasks: 4 (limit: 9074)
CGroup: /system.slice/argononed.service
└─1428 /opt/argonone/bin/python3 /opt/argonone/bin/argononed.py

11月 29 13:46:42 RaspberryPi systemd[1]: Started Argon One Fan and Button Service.

DarkElvenAngel
Posts: 1276
Joined: Tue Mar 20, 2018 9:53 pm

Re: Script for Argon one pi4 fan ???

Sun Nov 29, 2020 12:55 pm

Shen Hsu wrote:
Sun Nov 29, 2020 6:06 am
hectorkvs wrote:
Wed Apr 22, 2020 1:59 am
Here is the proper way to install script for Argon One case running on Manjaro ARM both KDE Plasma and XFCE:

git clone https://github.com/Elrondo46/argonone.git
cd argonone
sudo pacman -S base-devel (to install some missing packages)
makepkg -si
yay -S raspberrypi-userland-aarch64-git
sudo systemctl enable argononed.service
sudo reboot

Make sure you put this in config.txt on boot partition before rebooting :
dtparam=i2c_arm=on
dtparam=i2c-1=on
enable_uart=1

Also I forgot to mention that the ' enable_uart=1 ' in /boot/config.txt in conjunction with having ' kgdboc=ttyAMA0,115200 ' mentioned in /boot/cmdline does crash the kernel (kernel panic) so please check for this if you are planning on automatically add the uart-option to /boot/config.txt.I did fix this by removing ' kgdboc=ttyAMA0,115200 ' from my /boot/cmdline.
If you have a problem with shuting down when the power isn't cut as it should (power led still working, after pi shutdown), you need to change in ' /usr/lib/systemd/system-shutdown/argononed-poweroff.py ' the following:

Line 20
bus.write_byte_data(0x1a,0,0) to looks like this..

hope this help
I follow this guide, but the FAN and power button is not workable on my RPi4 with Manjaro KDE Plasma, any help appreciated!

Below is the I2C baudrate get from my RPi4, is it abnormal? (I have set the "dtparam=i2c_arm_baudrate=32000" and "dtparam=i2c_baudrate=32000" in the "boot/config.txt".)
[raspberrypi@raspberrypi ~]$ sudo cat /sys/module/i2c_bcm2708/parameters/baudrate
0
[raspberrypi@raspberrypi ~]$ sudo cat /sys/module/i2c_bcm2835/parameters/debug
0

Follow is my status of argononed.service, there's no any error...
By the way, I try to select the "FAN always ON" on the argonone-config, but the FAN is still not work.

[raspberrypi@RaspberryPi ~]$ sudo systemctl status argononed.service
[sudo] raspberrypi 的密碼:
● argononed.service - Argon One Fan and Button Service
Loaded: loaded (/usr/lib/systemd/system/argononed.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2020-11-29 13:46:42 CST; 14min ago
Main PID: 1428 (python3)
Tasks: 4 (limit: 9074)
CGroup: /system.slice/argononed.service
└─1428 /opt/argonone/bin/python3 /opt/argonone/bin/argononed.py

11月 29 13:46:42 RaspberryPi systemd[1]: Started Argon One Fan and Button Service.
If these scripts are not working for you try the project I posted earlier it does work,
DarkElvenAngel wrote: If you want something that works for multiple platforms I have good coverage with my project https://gitlab.com/DarkElvenAngel/argononed

I use C and not Python so my project will run on more operating systems. There is a topic here viewtopic.php?f=29&t=275713 where you can learn more.
I remember that getting i2c bus working on some non raspberry Pi OS's was a bit trickier than just enabling the overlay. The installer handles all that.

If you had the button working at least I wouldn't have suggested my project, your best bet is to uninstall the scripts and try my project see if that works. Do you know if you fan and button worked before trying Arch?

Shen Hsu
Posts: 2
Joined: Sun Nov 29, 2020 3:31 am

Re: Script for Argon one pi4 fan ???

Mon Nov 30, 2020 3:23 am

DarkElvenAngel wrote:
Sun Nov 29, 2020 12:55 pm
Shen Hsu wrote:
Sun Nov 29, 2020 6:06 am
hectorkvs wrote:
Wed Apr 22, 2020 1:59 am
Here is the proper way to install script for Argon One case running on Manjaro ARM both KDE Plasma and XFCE:

git clone https://github.com/Elrondo46/argonone.git
cd argonone
sudo pacman -S base-devel (to install some missing packages)
makepkg -si
yay -S raspberrypi-userland-aarch64-git
sudo systemctl enable argononed.service
sudo reboot

Make sure you put this in config.txt on boot partition before rebooting :
dtparam=i2c_arm=on
dtparam=i2c-1=on
enable_uart=1

Also I forgot to mention that the ' enable_uart=1 ' in /boot/config.txt in conjunction with having ' kgdboc=ttyAMA0,115200 ' mentioned in /boot/cmdline does crash the kernel (kernel panic) so please check for this if you are planning on automatically add the uart-option to /boot/config.txt.I did fix this by removing ' kgdboc=ttyAMA0,115200 ' from my /boot/cmdline.
If you have a problem with shuting down when the power isn't cut as it should (power led still working, after pi shutdown), you need to change in ' /usr/lib/systemd/system-shutdown/argononed-poweroff.py ' the following:

Line 20
bus.write_byte_data(0x1a,0,0) to looks like this..

hope this help
I follow this guide, but the FAN and power button is not workable on my RPi4 with Manjaro KDE Plasma, any help appreciated!

Below is the I2C baudrate get from my RPi4, is it abnormal? (I have set the "dtparam=i2c_arm_baudrate=32000" and "dtparam=i2c_baudrate=32000" in the "boot/config.txt".)
[raspberrypi@raspberrypi ~]$ sudo cat /sys/module/i2c_bcm2708/parameters/baudrate
0
[raspberrypi@raspberrypi ~]$ sudo cat /sys/module/i2c_bcm2835/parameters/debug
0

Follow is my status of argononed.service, there's no any error...
By the way, I try to select the "FAN always ON" on the argonone-config, but the FAN is still not work.

[raspberrypi@RaspberryPi ~]$ sudo systemctl status argononed.service
[sudo] raspberrypi 的密碼:
● argononed.service - Argon One Fan and Button Service
Loaded: loaded (/usr/lib/systemd/system/argononed.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2020-11-29 13:46:42 CST; 14min ago
Main PID: 1428 (python3)
Tasks: 4 (limit: 9074)
CGroup: /system.slice/argononed.service
└─1428 /opt/argonone/bin/python3 /opt/argonone/bin/argononed.py

11月 29 13:46:42 RaspberryPi systemd[1]: Started Argon One Fan and Button Service.
If these scripts are not working for you try the project I posted earlier it does work,
DarkElvenAngel wrote: If you want something that works for multiple platforms I have good coverage with my project https://gitlab.com/DarkElvenAngel/argononed

I use C and not Python so my project will run on more operating systems. There is a topic here viewtopic.php?f=29&t=275713 where you can learn more.
I remember that getting i2c bus working on some non raspberry Pi OS's was a bit trickier than just enabling the overlay. The installer handles all that.

If you had the button working at least I wouldn't have suggested my project, your best bet is to uninstall the scripts and try my project see if that works. Do you know if you fan and button worked before trying Arch?
YES! The Fan is worked on Ubuntu Mate v20.10 with the formal guide(curl https://download.argon40.com/argon1.sh | bash), but not worked on Manjaro OS.

After I try your project https://gitlab.com/DarkElvenAngel/argononed,
the Fan and Power Button are all worked as expected on my RPi4 with Manjaro KDE Plasma v20.10, and it's so easy to install.
Great project! Thank you very much!!!

Return to “Arch”