User avatar
cpcnw
Posts: 62
Joined: Thu Jan 05, 2012 5:36 pm
Location: NW UK
Contact: Website

Static IP stopped following update

Fri Jul 07, 2017 3:43 pm

Hi All,

Just noticed after a long period of uptime and a reboot that my static IP set in /etc/netctl/eth0 is now being completely ignored.

Been working fine for a few years. Don't know whats been changed but for life of me cannot get my pi to stop using dhcp?

[and a different IP than what I need]

Any tips?

Thanks
If you don't know what you want, you end up with a lot you don't!

User avatar
cpcnw
Posts: 62
Joined: Thu Jan 05, 2012 5:36 pm
Location: NW UK
Contact: Website

Re: Static IP stopped following update

Fri Jul 07, 2017 4:10 pm

Noticed with use of

Code: Select all

systemctl list-unit-files
that 'systemd-networkd.service' was enabled. In the following wiki page

https://wiki.archlinux.org/index.php/sy ... _static_IP

it states that ;

Tip: Before you start to configure your container network, it is useful to:
disable all your netctl services. This will avoid any potential conflicts with systemd-networkd and make all your configurations easier to test. Furthermore, odds are high you will end with few or even no netctl activated profiles. The netctl list command will output a list of all your profiles, with the activated one being starred.


As netctl had been working fine for me I tried;

Code: Select all

# systemctl stop systemd-networkd.service
# systemctl disable systemd-networkd.service
then rebooted and I am back with my original setup. All's well that ends well. Pity a system upgrade can lose you hours of head scratching...
If you don't know what you want, you end up with a lot you don't!

Return to “Arch”

Who is online

Users browsing this forum: cjan and 4 guests