Posts: 2
Joined: Wed Dec 18, 2013 9:21 pm

Pidora Repo

Wed Dec 18, 2013 9:25 pm


Forum newbie here :)

Quick question, is the Pidora repo down for anyone else?

Running any yum command is giving me:

Code: Select all [Errno 14] HTTP Error 404 - Not Found :
Trying other mirror. [Errno 14] HTTP Error 403 - Forbidden :
Trying other mirror.
Error: failure: repodata/repomd.xml from pidora-rpfr-updates: [Errno 256] No more mirrors to try. [Errno 14] HTTP Error 404 - Not Found : [Errno 14] HTTP Error 403 - Forbidden :
I've tried browsing the site in my browser, however, the links are indeed 404.


Posts: 1
Joined: Thu Dec 19, 2013 8:05 am

Re: Pidora Repo

Thu Dec 19, 2013 8:12 am

Same for me...
I could really use yum on my Pi right now :-(


Posts: 2
Joined: Thu Dec 19, 2013 4:39 pm

Re: Pidora Repo

Thu Dec 19, 2013 7:09 pm

Success! I got yum to work. I think the issue with yum not being able to connect to the repository is because SELinux is disabled and has to be set to enforcing to work. I'm not entirely sure if this is the case but after making that SELinux change. I ran "yum update" and it started downloading the .rpm files.

to check the status SELinux policy run:

Code: Select all

sudo getenforce
If output shows disabled you will need to set the policy to enforcing. I have not tried to set it to permissive, but i think the results should be the same.

To set to enforcing for SELinux, as root

edit the /etc/selinux/config

# This file controls the state of SELinux on the system.
# SELINUX=disabled
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - No SELinux policy is loaded.
# SELINUXTYPE= can take one of these two values:
# targeted - Targeted processes are protected,
# minimum - Modification of targeted policy. Only selected processes are pro
# mls - Multi Level Security protection.

save the file and reboot the system

When Pidora reboots it will stay on the GUI boot screen for a very long time. DONT PANIC! SELinux policy is being written to the filesystem which can take a long time. Once it boot to the GUI then open up the terminal and run

Code: Select all

yum -y update
you are good to go. Please reply if this is successful or if problem persists

Try to run the updater while the system is in runlevel 3 instead of 5, because the GUI does take alot of cpu resources, even in runlevel 3 its quite slow

Posts: 151
Joined: Wed Dec 19, 2012 7:32 pm
Location: Planet Gaia
Contact: Website Yahoo Messenger

Re: Pidora Repo

Thu Dec 19, 2013 9:54 pm

kernel_cougar wrote: ...

as written in other thread : major Mirror directer DISABLED PIDORA mirror list page .
sofar .. PIdora is GONE :-) till fixed.

@Cougar you probably need to talk to RPI owners...

Return to “Pidora / Fedora”