frp
Posts: 5
Joined: Sat Feb 09, 2013 3:00 pm

pidora keyboard layout

Fri Aug 02, 2013 9:33 am

Hello,

I just installed Pidora and I have a problem with the keyboard configuration : during the firstboot stage, I chose french keyboard (and boot without graphical interface).

I checked the /etc/sysconfig/keyboard file

Code: Select all

KEYTABLE="fr-pc"
MODEL="pc105"
LAYOUT="fr"
Though, the keyboard is still qwerty !

What should I do ?

Thank you

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: pidora keyboard layout

Wed Aug 21, 2013 2:03 am

I reported this as a bug ages ago, but no-one's even commented on it http://trac.proximity.on.ca/projects/rpfr/ticket/371
It seems if you run the 'Administration > Keyboard' program again you can then change the keyboard, but you need to do this after every single bootup :(

frp
Posts: 5
Joined: Sat Feb 09, 2013 3:00 pm

Re: pidora keyboard layout

Wed Aug 21, 2013 7:11 am

Thank you for your reply. I hope that this bug will be fixed.

I solved the problem by switching back to Raspbian ;)

smudger
Posts: 4
Joined: Mon Oct 14, 2013 8:55 am

Re: pidora keyboard layout

Mon Oct 14, 2013 9:19 am

SOLUTION - workaround

i had a similar problem. would not apply uk layout.

solution: Delete US keyboard in Settings/Keyboard/|Layout/ (Maybe US layout seems to want to take over everything in this distro - spooky :lol: )

Alt Solution : only have the Keyboard layout you want in the Settings/Keyboard/Layout - Delete any other keyboard except the one you want

Check /etc/sysconfig/keyboard file that system keyboard is indeed the one you specified.It should persist after reboot since the US keyboard cannot now take over since you have deleted it!

Vive la Difference! 8-)

.

Return to “Pidora / Fedora”

Who is online

Users browsing this forum: No registered users and 3 guests