Posts: 4
Joined: Wed Jan 04, 2017 3:59 pm

Install Kodi on Fedberry on rpi2

Thu Nov 16, 2017 7:44 pm

I've a working rpi2 with a FedBerry image, upgraded to Fedora/FedBerry 26. I'm looking for a way to install Kodi on that system. Unfortunately there is no Kodi package on rpm fusion for the armv7hl architecture.

I tried to go the buildroot route, downloaded from: When building that on rip2, I get error message like

make[1]: Entering directory
/usr/bin/sed: error while loading shared libraries:
cannot create shared object descriptor: Cannot allocate memory
/bin/sh: fork: Cannot allocate memory /usr/bin/make: error while
loading shared libraries: failed to map segment from
shared object even though the file /usr/lib/ exists.

When trying several times, I got different messages, including segmentation fault and out of memory.

I've also tried to compile Kodi with cmake, but got errors like:

CheckSymbolExists.c:(.text+0x1c): undefined reference to

Any ideas on how to get Kodi up and running on the system?


Return to “Pidora / Fedora”