renePi
Posts: 4
Joined: Wed Apr 08, 2015 12:34 pm

X11VNC

Wed Apr 08, 2015 1:27 pm

While on raspbian I have X11vnc running with no issues, of Pidora 21 I can't get it to work, despite the many google sessions.
(I decided to switch to Pidora mainly because for some strange reason HRTimers on Pi model B reports 1 ns res, but on RpI2 10ms! - On raspbarry I get the 1 ns resolution. - not that you can time 1 ns off course:))

When I start X11VNC -display :0 -auth guess I get
08/04/2015 14:58:06 x11vnc version: 0.9.13 lastmod: 2011-08-10 pid: 2258
08/04/2015 14:58:16 -auth guess: failed for display=':0'
08/04/2015 14:58:16 -auth guess: since we are root, retrying with FD_XDM=1
08/04/2015 14:58:23 -auth guess: failed for display=':0'
There is a .vnc/passwd file, a .Xauthority file (Not sure if the content is OK, I can't remember that I had to create one for raspbian)
I tried various other (commandline) options, but I think I miss something obvious here....
Oh - just in case, I start x11vnc form an SSH session, there is a HDMI to VGA converter plugged into the Pi, but no monitor connected. However, in some of my earlier experiments, I have tried to start x11vnc from a terminall session from the console.
The error message was different though. I hop to try again later and add to the post.
As I have seen many people being successful (But not sure if they all had pidora 21) their config info would be helpfull. Thanks a lot.
René
My ultimate goal is to

Return to “Pidora / Fedora”