jiggerat
Posts: 1
Joined: Sun Dec 01, 2013 9:15 pm

apt-get update fails

Sun Dec 01, 2013 9:50 pm

Hi,
To install Raspberry Pwn by Pwnie Express it says you have to use the Debian Wheezy soft-floating point image. I eventually found what seems to be the latest image for this at :

ftp.mirrorservice.org/sites/downloads.raspberrypi.org/images/debian/7/2013-05-29-wheezy-armel/

It has been removed from the normal downloads page.

I installed the image in the normal way and have expanded the "/" partition to the full card size of 8GB with "raspi-config".

However after rebooting and trying to run "apt-get update" you get the following:

root@raspberrypi:~# apt-get update
Hit http://archive.raspberrypi.org wheezy Release.gpg
Hit http://archive.raspberrypi.org wheezy Release
Hit http://archive.raspberrypi.org wheezy/main armel Packages
Hit http://http.debian.net wheezy Release.gpg
Hit http://http.debian.net wheezy Release
Ign http://archive.raspberrypi.org wheezy/main Translation-en_GB
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Hit http://http.debian.net wheezy/main armel Packages
Hit http://http.debian.net wheezy/contrib armel Packages
Hit http://http.debian.net wheezy/non-free armel Packages
Hit http://http.debian.net wheezy/contrib Translation-en
Hit http://http.debian.net wheezy/main Translation-en
Hit http://http.debian.net wheezy/non-free Translation-en
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.
root@raspberrypi:~#

Does anyone know how to fix this?

User avatar
DougieLawson
Posts: 39191
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: apt-get update fails

Mon Dec 02, 2013 12:14 am

You could remove the offending repo from your /etc/apt/sources.list or /etc/apt/sources.list.d/*.list then retry.

If you don't have any non-free translation packages installed it won't cause a problem.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

Return to “Debian”