eeyore.t.mule
Posts: 10
Joined: Mon Jun 25, 2012 4:40 pm
Location: Stockport or Barrow

Huawei E323 3G Dongle (3 network)

Tue Jun 26, 2012 5:19 pm

Evening all, I've just spotted one of these cheap in tesco and it got me wondering has any one tried it will the pi :?:
A quick in shop google indicates that it can work with Linux mint (Ubuntu and thus debien based) so I'm wondering if anyone has tried it.
If not I might have a go :lol: :D
Donkeys like Pi

gordonendersby
Posts: 34
Joined: Fri Jun 22, 2012 4:04 pm
Location: Croydon, Surrey

Re: Huawei E323 3G Dongle (3 network)

Tue Jun 26, 2012 7:02 pm

Ive got the Huawaei board version in my netbook and its supported under ubunbtu based on debian.
It shows up as a usb device just like the dongle.
I dont think you will have any trouble, lots of howto's on the net to getting it working.

The gotcha is usually the cost of the data plan. I had run mine on a regular sim with a data plan but the provider clamped down on it and barred it from use in dongles or netbooks.

Gordon

eeyore.t.mule
Posts: 10
Joined: Mon Jun 25, 2012 4:40 pm
Location: Stockport or Barrow

Re: Huawei E323 3G Dongle (3 network)

Tue Jun 26, 2012 8:04 pm

Hopefully I'll be ok :lol:

Mine was ment for an iPhone but works in my iPad too.
I asked about using it in other stuff apart from my iPhone and was told it was ok... I think as long as you don't extract the urine generally you should be ok... I hope :lol:
Donkeys like Pi

eeyore.t.mule
Posts: 10
Joined: Mon Jun 25, 2012 4:40 pm
Location: Stockport or Barrow

Re: Huawei E323 3G Dongle (3 network)

Tue Jun 26, 2012 8:04 pm

Failing that just thinking about it I could use the iPad as a router... ;) :oops: :P
Donkeys like Pi

User avatar
edent
Posts: 25
Joined: Thu Sep 08, 2011 3:41 pm
Contact: Website

Re: Huawei E323 3G Dongle (3 network)

Fri Jul 13, 2012 12:26 pm

I've managed to get the E220 working to connect to the net. Try using Sakis http://www.sakis3g.org/

Here's the full details of how I did it
http://shkspr.mobi/blog/index.php/2012/ ... i-success/

decibyte
Posts: 2
Joined: Mon Jul 23, 2012 6:17 pm
Location: Copenhagen, Denmark

Re: Huawei E323 3G Dongle (3 network)

Wed Aug 01, 2012 9:31 pm

edent wrote:Try using Sakis
Wow! I thought I should be fiddling around at least a couple of evenings to get a working 3G connection. Now I made it in about an hour. Thanks a lot :)

jets
Posts: 58
Joined: Mon May 06, 2013 9:40 am

Re: Huawei E323 3G Dongle (3 network)

Fri May 10, 2013 7:25 pm

Well, I thought it is useful for others to share my experiences with Rpi and Huawei E353.

I struggled for a while with the dongle and latest wheezy. To get it working, what I did was basically just:
-Install usb modeswitch (sudo apt-get install usb-modeswitch)
-Edit /etc/network/interfaces and add this line: "iface eth1 inet dhcp"
-Reboot

Then the eth1 (if you only had eth0 before), will have IP-address, probably 192.168.1.100 or 192.168.1.1 or something similar. Check it with "ifconfig". Then simply add default gateway "sudo /sbin/route add default gw 192.168.1.100 eth1".

To share the Internet connection, do similar script (and execute it):
#!/bin/bash
rm /etc/iptables.sav
sudo iptables -A FORWARD -i eth0 -o eth1 -s 192.168.0.0/24 -m conntrack --ctstat
e NEW -j ACCEPT
sudo iptables -A FORWARD -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
sudo iptables -A POSTROUTING -t nat -j MASQUERADE
/sbin/iptables-save > /etc/iptables.sav
sh -c "echo 1 > /proc/sys/net/ipv4/ip_forward"

I now have a camera surveillance system with controlled camera electricity outlets (via gpio and standard remote controlled outlets). System has much lower power consumption than the previous system.

All is solar powered :)

Chandy
Posts: 1
Joined: Tue Jun 25, 2013 2:54 pm

Re: Huawei E323 3G Dongle (3 network)

Tue Jun 25, 2013 2:59 pm

I am trying to connect huawei e1820 wireless mobile broad band usb modem . But it restarting at the time of connecting.I tried higher current rated (800ma)power supply,but not working somebody please help me

Return to “Recommended peripherals”

Who is online

Users browsing this forum: No registered users and 3 guests