aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

TP-LINK TP-WN725N Wi-fi

Sat Sep 07, 2013 7:34 pm

Hi

I am a newbie in these things despite my fifty-odd years.
Have long use Ubuntu but only as a user and know little programming.
I have a TP-LINK TP-725N.
In the metallic is written IC: 8853A-WN725N

1 - The command lsusb
Bus 001 Device 004: ID 0bda: 8179 Realtek Semiconductor Corp..
This is the V1 or V2??
In the forum there is no unanimity in this response.

2 - The command ifconfig

eth0 Link encap:Ethernet HWaddr b8:27:eb:51:97:ec
inet addr:192.168.1.180 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:148 errors:0 dropped:0 overruns:0 frame:0
TX packets:79 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14307 (13.9 KiB) TX bytes:11209 (10.9 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

3 - The command iwconfig

wlan0 unassociated Nickname:"<[email protected]>"
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

The Command sudo ifdown wlan0

Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.1.254 port 67

4 - The command sudo ifup wlan0

wpa_supplicant: wpa-roam can only be used with the "manual" inet METHOD
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
wpa_supplicant: wpa-roam can only be used with the "manual" inet METHOD
run-parts: /etc/network/if-up.d/wpasupplicant exited with return code 1

I followed several post here and other forums but without success. :( :( :( :(
I can not connect to my home network.v :oops:
Can you help me with a "a good Complete how to"
? :D :) ;)

5 - More information: My wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="MY SSID" Confirmed dozens of times
psk="My PWD" Confirmed dozens of times
proto=RSN WPA
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
auth_alg=OPEN
group=CCMP TKIP
psk=e53bb7df43156b8a6ad5d3ea5bb4078fada2531e2d5d5208c3bc1a17c3278220
}
-
6 - My interfaces files

sudo nano /etc/network/interfaces

GNU nano 2.2.6 File: /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
#wpa-ssid ""
#wpa-psk ""
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Dutch_Master
Posts: 360
Joined: Sat Jul 27, 2013 11:36 am

Re: TP-LINK TP-WN725N Wi-fi

Sat Sep 07, 2013 7:54 pm

What else makes up your wireless connection? What brand and type of router do you have? Are the drivers loaded by the kernel?

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Sat Sep 07, 2013 8:11 pm

aabento wrote:Hi

I have a TP-LINK TP-725N.
In the metallic is written IC: 8853A-WN725N

1 - The command lsusb
Bus 001 Device 004: ID 0bda: 8179 Realtek Semiconductor Corp..
This is the V1 or V2??
In the forum there is no unanimity in this response.
ID 0bda: 8179 Realtek Semiconductor Corp indicates version V2 and requires the 8188eu driver.
aabento wrote:4 - The command sudo ifup wlan0

wpa_supplicant: wpa-roam can only be used with the "manual" inet METHOD
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1


6 - My interfaces files

sudo nano /etc/network/interfaces

GNU nano 2.2.6 File: /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
#wpa-ssid ""
#wpa-psk ""
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
Note the error from sudo ifup wlan0. Edit file /etc/network/interfaces and change iface wlan0 inet dhcp to iface wlan0 inet manual will correct that. Whether it will get your wifi working is another matter. I prefer to only use /etc/network/interfaces and avoid wpa_supplicant when possible.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Sat Sep 07, 2013 10:14 pm

Thank you MrEngman
I followed the tips but still without wi-fi connection :cry: :cry:

More tips? :idea:

My interfaces file

[email protected] ~ $ sudo nano /etc/network/interfaces
GNU nano 2.2.6 File: /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-ssid "MYSSID"
wpa-psk "MYPWD"
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp
iface wlan0 inet manual


Sudo ifup wlan0

ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
[email protected] ~ $

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Sat Sep 07, 2013 11:41 pm

I would suggest either

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "MYSSID"
wpa-psk "MYPWD"
or if you want to use wpa_supplicant then

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
So far I've seen various mixtures of both ;) and this may confuse the networking code. Also no need to use both auto wlan0 and allow-hotplug wlan0. One or other is usually sufficient. I normally use allow-hotplug wlan0.

Also does your wireless access point transmit it's network name (ssid)? If it doesn't this can cause problems connecting. You will probably need to use wpa_supplicant and add the line scan_ssid=1 in to the network configuration settings. Otherwise set the access point to transmit it's ssid.

I have also sometimes found it necessary to use sudo ifdown wlan0 and sudo ifup wlan0 multiple times to get a connection working or even power off the Pi completely and then power back on.

Can you see your network if you use command sudo iwlist wlan0 scan?


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Dutch_Master
Posts: 360
Joined: Sat Jul 27, 2013 11:36 am

Re: TP-LINK TP-WN725N Wi-fi

Sun Sep 08, 2013 12:57 am

What response does this code give you?

Code: Select all

sudo lsmod -a | grep 8188
If nothing, try this

Code: Select all

sudo insmod 8188eu
sudo ifup wlan0
If the above gives you a connection, you need to add the 8188eu module to /etc/modules:

Code: Select all

sudo echo "8188eu" >> /etc/modules

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Sun Sep 08, 2013 9:45 am

Again following the tips: :D

Any other tips? :roll:

Thanks in advance. :arrow:


sudo iwlist wlan0 scan

wlan0 Scan completed :
Cell 01 - Address: 00:26:44:9C:C0:CB
ESSID:"Optimus9CC0CB" <------------ My SSID
Protocol:IEEE 802.11bgn
Mode:Master
Frequency:2.437 GHz (Channel 6)
Encryption key:on
Bit Rates:130 Mb/s
Extra:wpa_ie=dd160050f20101000050f20201000050f20201000050f202
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Extra:rsn_ie=30140100000fac020100000fac040100000fac020c00
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP

[email protected] ~ $ sudo lsmod -a | grep 8188
Usage: lsmod
[email protected] ~ $ sudo insmod 8188eu
Error: could not load module 8188eu: No such file or directory
[email protected] ~ $ sudo ifup wlan0
ifup: interface wlan0 already configured
[email protected] ~ $

[email protected] ~ $ sudo nano /etc/modules
GNU nano 2.2.6 File: /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

snd-bcm2835
8188eu

[email protected] ~ $ sudo nano /etc/network/interfaces
GNU nano 2.2.6 File: /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
###auto wlan0
iface wlan0 inet dhcp
wpa-ssid "OPTIMUS9CC0CB"
wpa-psk "MyPWD"
###wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
####iface default inet dhcp
iface wlan0 inet manual

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Sun Sep 08, 2013 9:58 am

aabento wrote:Again following the tips: :D

Any other tips? :roll:

[email protected] ~ $ sudo nano /etc/network/interfaces
GNU nano 2.2.6 File: /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
###auto wlan0
iface wlan0 inet dhcp
wpa-ssid "OPTIMUS9CC0CB"
wpa-psk "MyPWD"
###wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
####iface default inet dhcp
iface wlan0 inet manual
Remove/comment out the last line iface wlan0 inet manual


MrEngman
Last edited by MrEngman on Sun Sep 08, 2013 10:26 am, edited 1 time in total.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Sun Sep 08, 2013 10:22 am

To check the driver is loaded the simplest way is to just use command lsmod. This will print a list of all the modules loaded. The driver for the TP-WN725N is 8188eu.

As you can do a scan and it shows your network the driver is loaded OK. You just need to get the configuration correct.

If you want to check where the driver is you can use the command sudo find / -name 8188eu.ko


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Sun Sep 08, 2013 1:00 pm

Well, let´s look another try. :D :D
I have to thank you for your patience and all the knowledge in these matters. ;) ;) ;)

[email protected] ~ $ lsmod

Module Size Used by
snd_bcm2835 16304 0
snd_pcm 77560 1 snd_bcm2835
snd_page_alloc 5145 1 snd_pcm
snd_seq 53329 0
snd_seq_device 6438 1 snd_seq
snd_timer 19998 2 snd_pcm,snd_seq
snd 58447 5 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
8188eu 576997 0
evdev 9426 2
joydev 9316 0
leds_gpio 2235 0
led_class 3562 1 leds_gpio
[email protected] ~ $

[email protected] ~ $ sudo find / -name 8188eu.ko

/lib/modules/3.6.11+/kernel/net/wireless/8188eu.ko
/lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
/home/pi/8188eu.ko
[email protected] ~

After Reboot

login as: pi
[email protected]'s password:
Linux raspberrypiCAM 3.6.11+ #474 PREEMPT Thu Jun 13 17:14:42 BST 2013 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Sep 8 10:14:11 2013 from aabento008.lan
[email protected] ~ $ ifconfig

eth0 Link encap:Ethernet HWaddr b8:27:eb:51:97:ec
inet addr:192.168.1.180 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:209 errors:0 dropped:0 overruns:0 frame:0
TX packets:83 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:17036 (16.6 KiB) TX bytes:11577 (11.3 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr a0:f3:c1:15:41:d6
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

[email protected] ~ $ iwconfig

wlan0 unassociated Nickname:"<[email protected]>"
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

[email protected] ~ $ ifconfig

eth0 Link encap:Ethernet HWaddr b8:27:eb:51:97:ec
inet addr:192.168.1.180 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:288 errors:0 dropped:0 overruns:0 frame:0
TX packets:131 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:22218 (21.6 KiB) TX bytes:19405 (18.9 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr a0:f3:c1:15:41:d6
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

[email protected] ~ $


sudo ifdown wlan0

Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.1.254 port 67

[email protected] ~ $ sudo ifup wlan0

ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on LPF/wlan0/a0:f3:c1:15:41:d6
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
[email protected] ~ $



[email protected] ~ $ sudo nano /etc/network/interfaces
GNU nano 2.2.6 File: /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
###auto wlan0
iface wlan0 inet dhcp
wpa-ssid "OPTIMUS9CC0CB"
wpa-psk "MyPWD"
###wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
####iface default inet dhcp
###iface wlan0 inet manual

Dutch_Master
Posts: 360
Joined: Sat Jul 27, 2013 11:36 am

Re: TP-LINK TP-WN725N Wi-fi

Sun Sep 08, 2013 1:14 pm

OK, driver is loaded, the scan shows you have a Wifi network available, but it also shows that encryption is on. Log in to your router and switch the encryption off (for now). Try to connect again. However, the scan also shows you need to use channel 6 (out of 11), so you may want to check your adapter is actually trying to communicate on that channel to the AP.

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Sun Sep 08, 2013 2:42 pm

Dutch_Master wrote:OK, driver is loaded, the scan shows you have a Wifi network available, but it also shows that encryption is on. Log in to your router and switch the encryption off (for now). Try to connect again. However, the scan also shows you need to use channel 6 (out of 11), so you may want to check your adapter is actually trying to communicate on that channel to the AP.
Hi,

If encryption is turned off then the network-name and network-password settings in /etc/network/interfaces file will need modifying accordingly.

Code: Select all

For WPA/WPA2 use (current setting)

wpa-ssid "wifi-name"
wpa-psk "wifi-password"


For WEP use

wireless-essid wifi-name
wireless-key wifi-password


For unsecured network (no encryption/password) use just

wireless-essid wifi-name
The wifi adapter should have no problem deciding which channel it needs to use. It is showing the network details when it does a scan so it is able to communicate with the wireless access point using the right channel.


MrEngman


Hi aabento,

Should have noticed this earlier. When you ran the command sudo iwlist wlan0 scan the network name shows as ESSID:"Optimus9CC0CB".

In your /etc/network/interfaces file you have the line wpa-ssid "OPTIMUS9CC0CB". You need to change it to wpa-ssid "Optimus9CC0CB". The name and password are case sensitive. Make sure your password is also using correct upper and lower case letters.

I think this is why you cannot get a connection - the names do not match. :o


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi (SOLVED)

Sun Sep 08, 2013 3:16 pm

MrEngman and Dutch_Master
Thank you so much.

So complicated and so simple after all.
You you hit the target. :D :D :D :D
The password has all the letters in capital letter. It was stupid on my side that the SSID would be the same way. :oops: :oops:

If encryption is turned off then the network-name and network-password settings in /etc/network/interfaces file will need modifying accordingly.

This was the trick.

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Wed Sep 11, 2013 5:25 pm

Hi
After sudo apt-get update && sudo apt-get upgrade I have again no wireless
Check What I did:
The driver is not loaded. How do I reset the driver?

[email protected] ~ $ sudo lsmod -a | grep 8188
Usage: lsmod

[email protected] ~ $ sudo depmod -a

[email protected] ~ $ sudo modprobe 8188eu
ERROR: could not insert '8188eu': Exec format error

[email protected] ~ $ sudo lsmod

Module Size Used by
snd_bcm2835 16432 0
snd_pcm 77728 1 snd_bcm2835
snd_page_alloc 5169 1 snd_pcm
snd_seq 53482 0
snd_seq_device 6462 1 snd_seq
snd_timer 20110 2 snd_pcm,snd_seq
snd 58744 5 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
joydev 9356 0
evdev 9450 2
leds_gpio 2243 0
led_class 3570 1 leds_gpio

[email protected] ~ $ ifconfig

eth0 Link encap:Ethernet HWaddr b8:27:eb:51:97:ec
inet addr:192.168.1.180 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7272 errors:0 dropped:0 overruns:0 frame:0
TX packets:1784 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7867763 (7.5 MiB) TX bytes:186777 (182.3 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

[email protected] ~ $ sudo ifup wlan0

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Cannot find device "wlan0"
Bind socket to interface: No such device
Failed to bring up wlan0.
[email protected] ~ $

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Wed Sep 11, 2013 6:24 pm

Hi aabento,

You need to update the driver. You can do this by running the following commands

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20130830.tar.gz
tar -zxvf 8188eu-20130830.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a
I am assuming that if you run command uname -a it shows

Code: Select all

Linux raspberrypi 3.6.11+ #538 PREEMPT Fri Aug 30 20:42:08 BST 2013 armv6l GNU/Linux
or

Code: Select all

Linux raspberrypi 3.6.11+ #541 PREEMPT Sat Sep 7 19:46:21 BST 2013 armv6l GNU/Linux

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Wed Sep 11, 2013 7:09 pm

MrEngman
You are the best and my hero :D :D :D :D

Its Working like a charm

Thank you so much.

This long post it´s a good "How To" ;)

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Wed Sep 11, 2013 7:28 pm

aabento wrote:MrEngman
You are the best and my hero :D :D :D :D

Its Working like a charm

Thank you so much.

This long post it´s a good "How To" ;)
No problem, glad to be able to help


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

kimfr
Posts: 2
Joined: Thu Sep 12, 2013 3:03 pm

Re: TP-LINK TP-WN725N Wi-fi

Thu Sep 12, 2013 3:23 pm

Hello,

I had my Raspberry Pi runing using Raspbian and the TP-LINK TP-WN725N V2 without any noticeable problems. I did however notice the other day that I was having lots of "dropped" packets on the WiFi interface. I then ran a apt-get update/upgrade to get the latest Raspbian. This left me without any WiFi connection as the driver wouldn't load. I then found this thread and updated the driver to 8188eu-20130830.tar.gz.

Well, now at least the driver loads but I can get the WiFi stick to connect to my Fritz!Box (using WPA2 - this used to work).

The following lines just keeps repeating in /var/log/messages:
Sep 12 15:18:10 raspberrypi kernel: [33058.597111] RTL8188: ERROR indicate disassoc
Sep 12 15:18:19 raspberrypi kernel: [33067.891457] RTL8188: ERROR assoc success
Sep 12 15:18:23 raspberrypi kernel: [33071.887673] RTL8188: ERROR sta recv deauth reason code(1) sta:00:15:0c:6b:ab:74
Sep 12 15:18:23 raspberrypi kernel: [33071.903461] RTL8188: ERROR indicate disassoc

This just keeps going and going until I do a ifdown wlan0

In the system log of the Fritz!Box I get a messages that authorization has failed for MAC Address of the Pi.

The strange thing is that I have not changed any WiFi settings and/or pre-shared keys. I have also checked the wpa_supplicant.conf - it still looks ok.

Any ideas?

Cheers
Kim

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Thu Sep 12, 2013 6:50 pm

Not sure what's happening. I see the message

Code: Select all

[   21.595019] RTL8188: ERROR assoc success
but none of the others and my RPi and wifi works fine with the identical driver. I think in this case ERROR should be changed to DEBUG or something similar.

The older code produced lots of dropped packets, similar to the rtl8188cus driver used with the EW-7811Un, so I now use different source code for this newer version and it produces almost no dropped packets.

After running sudo ifdown wlan0 have you tried sudo ifup wlan0 to see what happens? Alternatively you could try sudo ifdown --force wlan0 and sudo ifup --force wlan0 which I believe are a bit more aggressive.

I usually do not use wpa_supplicant and just configure my wifi using /etc/network/interfaces but for a test to help someone else I generated a new image and updated with apt-get and rpi-update and then ran the Wifi Config GUI to check it worked OK, which it does, and so my current image is set up using wpa_supplicant.conf.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 3711
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TP-LINK TP-WN725N Wi-fi

Thu Sep 12, 2013 8:40 pm

kimfr wrote: In the system log of the Fritz!Box I get a messages that authorization has failed for MAC Address of the Pi.

The strange thing is that I have not changed any WiFi settings and/or pre-shared keys. I have also checked the wpa_supplicant.conf - it still looks ok.

Any ideas?

Cheers
Kim
Came across this. Don't know if it will help http://www.raspberrypi.org/phpBB3/viewt ... 62#p420762


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

kimfr
Posts: 2
Joined: Thu Sep 12, 2013 3:03 pm

Re: TP-LINK TP-WN725N Wi-fi

Thu Sep 12, 2013 9:17 pm

I decided to do a complete re-installed. I started with 2013-05-25-wheezy-raspbian.zip, ran a full update - I did NOT install and run rpi-update. After this a uname -a says I'm running #538. I then installed according to the steps mentioned earlier, wget ... 8188eu-20130830.tar.gz and so on.

I tried both setups with regards to WiFi config (ie. network/interface or wpa_supplicant) - same result. I also re-configured the router to allow WPA/WPA2 instead of just WPA2 - all of this however made no change. The error messages are the same.

If I issue a sudo ifdown wlan0, the WiFi stick is stopped as both the messages in /var/log/messages stops as does the authentication errors in my routers log file.

I also noticed that if I keep issue "iwconfig" manually all the time, the output is:
wlan0 IEEE 802.11bg ESSID:"Kims-HomeNet" Nickname:"<[email protected]>"
Mode:Managed Frequency:2.412 GHz Access Point: 00:15:0C:6B:AB:74
Bit Rate:54 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=98/100 Signal level=62/100 Noise level=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

or

wlan0 unassociated Nickname:"<[email protected]>"
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

As a last resort, I ran rpi-update and rebooted - didn't make any difference.

I have been removing all the settings 1 by 1 from the wpa_supplicant.conf file, leaving only the following:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="my-ssid"
psk="password"

# Protocol type can be: RSN (for WP2) and WPA (for WPA1)

}

Any ideas?
Kim

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Sat Sep 14, 2013 9:27 pm

Whenever I shutdown or reboot my TP-Link WN-725N crashes.
I have to run in a terminal:

sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko

sudo depmod -a

After that already have active wlan0.

eth0 Link encap:Ethernet HWaddr b8:27:eb:51:97:ec
inet addr:192.168.1.180 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:249 errors:0 dropped:0 overruns:0 frame:0
TX packets:188 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21149 (20.6 KiB) TX bytes:28823 (28.1 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr a0:f3:c1:15:41:d6
inet addr:192.168.1.175 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:19 errors:0 dropped:8 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3405 (3.3 KiB) TX bytes:1098 (1.0 Ki

If I disconnect the LAN cable I still able to access my home network via wireless but do not have internet access. :oops:

Whats happen here? :? :?


[email protected] ~ $ ping http://www.google.com
connect: Network is unreachable

[email protected] ~ $ ping 192.168.1.86 my network
PING 192.168.1.86 (192.168.1.86) 56(84) bytes of data.
64 bytes from 192.168.1.86: icmp_req=1 ttl=64 time=84.6 ms
64 bytes from 192.168.1.86: icmp_req=2 ttl=64 time=6.03 ms
64 bytes from 192.168.1.86: icmp_req=3 ttl=64 time=3.76 ms
C64 bytes from 192.168.1.86: icmp_req=4 ttl=64 time=2.26 ms
64 bytes from 192.168.1.86: icmp_req=5 ttl=64 time=1.97 ms
64 bytes from 192.168.1.86: icmp_req=6 ttl=64 time=47.3 ms
^C
--- 192.168.1.86 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5007ms
rtt min/avg/max/mdev = 1.977/24.325/84.608/31.372 ms

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Fri Sep 20, 2013 5:33 pm

Hi

Can any one to teach me how put at startup the wlan0? :?: :?: :?: :?:

As you can see in previous post this doesn´t happen. :(

Thanks.

aabento
Posts: 30
Joined: Sat Dec 29, 2012 3:09 pm

Re: TP-LINK TP-WN725N Wi-fi

Tue Oct 08, 2013 9:43 pm

Hi

Fresh installation solved the problem. :D

di11on
Posts: 7
Joined: Sun Dec 29, 2013 10:47 am

Re: TP-LINK TP-WN725N Wi-fi

Sun Dec 29, 2013 10:59 am

Hi all,

I'm running PiMAME and can't get this adapter to work. I have a powered USB hub. I've tried all the precompiled 8188eu binaries, none of them work - I get the "ERROR: could not insert '8188eu': Exec format error" every time I try. I've tried compiling it myself but get errors.

uname -a returns:
Linux raspberrypi 3.6.11 #1 PREEMPT Fri Oct 11 11:20:25 UTC 2013 armv6l

My wife would appreciate your help enormously as that would mean getting rid of the big ugly ethernet cable running half way across the house to my arcade cabinet :-)

Return to “General discussion”

Who is online

Users browsing this forum: No registered users and 43 guests