Status of SD card compatibility - What should I buy?

107 posts   Page 4 of 5   1, 2, 3, 4, 5
by dom » Fri May 25, 2012 11:15 pm
Are you running latest kernel? (from GitHub or Hexxeh's firmware updater tool?)

If you are, and have failing cards, then head on over to:
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5070
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by mike632t » Sat May 26, 2012 10:06 pm
Downloaded 2 days ago - one of the class 6 cards worked perfectly, but my celebrations were short lived as it only worked once - it now hangs everytime just after displaying the Raspberry logo. I'm currently in the process of reflashing the card from a known good image to allow me to update the kernel again.

Will try to get Misco to exchange them for the class 4 card I ordered before I give up and send one of them off...

User avatar
Posts: 66
Joined: Sat May 19, 2012 7:56 pm
Location: UK
by mike632t » Sun May 27, 2012 8:48 pm
Looks like /boot got corrupted (config.txt was 'missing') - reimaged the card, and so far it looks like the newer kernel works a treat.

A big thank you to who ever it was fixed that one.

User avatar
Posts: 66
Joined: Sat May 19, 2012 7:56 pm
Location: UK
by Airstream » Mon May 28, 2012 3:55 pm
We are having continued success with Kingston 8 GB SD class 4 cards in many RPi with Debian Squeeze in a resized partition. It looks as if RS are having shortages at ordering time - and they are a bit pricey. There are a few suppliers on eBay for example ... 19d15f3caa
Good Luck
Posts: 12
Joined: Fri May 04, 2012 7:05 am
by misox12 » Wed May 30, 2012 5:13 pm
Card: SanDisk SDHC 16GB Ultra Class 10
Product ID: SDSDU-016G-U46
Product seller: ... B007BJHETS


Tryed with latest debian and worked without problems. (debian6-19-04-2012)
Posts: 13
Joined: Wed May 23, 2012 12:20 pm
by smuggly » Sat Jun 02, 2012 12:49 pm
I'm using this. With openelec works great and snappy fast! ... 0601181236
Posts: 112
Joined: Fri Feb 03, 2012 6:09 pm
by WPsites » Sun Jun 10, 2012 11:44 am
I was a little worried at first when trying to source a decent SD card and since I needed a new card for my camera I thought I would hedge my bets and get a class 6 from somewhere and a class 10 from somewhere else. I'll put the info here, maybe it will help someone else making their decision.

8GB SDHC Class 10 from 7 Day Shop ... _id=111472

8GB SDHC Class 6 from Amazon ... B000P9ZBFA

Each coming in at under £6 including delivery, delivered pretty quickly considering it was over the recent bank holiday weekend.

Both work pretty well on my pi running the current Debian image with no modifications. The class 10 card runs quicker with read speeds of 4.46 MB/sec with the class 6 achieving 4.24 MB/sec (checked by running hdparm -t /dev/yoursdcard). Boot up time with no ethernet connected or peripherals other than USB keyboard and composite video was 24.2 sec on the class 10 and 28.3 sec on the class 6.

So not that much in it really but I'm keeping the class 10 in there.
Posts: 17
Joined: Sun Jun 10, 2012 11:05 am
Location: Southport, Merseyside, UK
by MiiCK » Tue Jun 12, 2012 1:26 pm
Thanks a lot for the information WPsites.

I'm actually using a class 4 samsung micro sd card in an adapter but looking to upgrade to a class 10 card so will be updating later on once purchased to let you know if it works.
Posts: 2
Joined: Sat Jun 02, 2012 5:44 pm
by Daz555 » Wed Jun 13, 2012 8:35 pm
After looking at the list here:

I went out and bought the Mushkin 32GB SDHC Class 10 (MKNSDHCC10-32GB)

Works fine with debian6-19-04-2012 - boots without error.

However I cannot get it to work with any OpenELEC builds - which I have working fine with a crappy old unbranded 2GB SD card from my old camera. Same error every time:

*** Error in mount_disks: mount_common: Could not mount /dev/mmcblk0p1 ***
[ 16.684190] System halted.

Any ideas or solutions for this? Very frustrating.
Posts: 24
Joined: Tue Jun 12, 2012 2:53 pm
by Daz555 » Wed Jun 13, 2012 9:50 pm
OK looks like I might not be alone with the OpenELEC problem:
Posts: 24
Joined: Tue Jun 12, 2012 2:53 pm
by Daz555 » Fri Jun 15, 2012 10:21 am
Daz555 wrote:OK looks like I might not be alone with the OpenELEC problem:

Now resolved in the latest builds. See link above for details.
Posts: 24
Joined: Tue Jun 12, 2012 2:53 pm
by grumpyoldgit » Fri Jun 15, 2012 10:29 am
Can I continue to put in a word for the Sandisk 8GB Class 4. Works with everything and comes in at under £5 from Amazon and Play. If you want more space whack in a memory stick and move the FS. These faster, larger cards can get really expensive and the initial setup seems to be fraught with issues.
At least with your first card go with something cheap and cheerful!
User avatar
Posts: 1454
Joined: Thu Jan 05, 2012 12:20 pm
by piglet » Fri Jun 15, 2012 11:15 am
Daz555 wrote:Now resolved in the latest builds. See link above for details.

I'm currently listening to music from a 16GB Sandisk class 10 microsd card in its adapter using the latest build OpenELEC on my pi. £10.10 - but it took a couple of weeks to come from Malaysia/South Korea....
User avatar
Posts: 738
Joined: Sat Aug 27, 2011 1:16 pm
by Daz555 » Tue Jun 19, 2012 3:11 pm
Word of warning with the Mushkin 32GB SDHC Class 10 (MKNSDHCC10-32GB)

After initially having no problems with the Debian and having a small, solvable, problem with OpenELEC, the Mushkin 32GB does not boot at all with the RPi any longer.

It was working fine. Rebooted my Pi....and nothing. Pi still works fine, and the 32GB card works fine on my PC and camera, but the Pi no longer even attempts to boot from it even after a complete wipe of the card and re-image.

Very very odd.
Posts: 24
Joined: Tue Jun 12, 2012 2:53 pm
by Mortimer » Tue Jun 19, 2012 6:30 pm
I am finding this frustrating too.

When I ordered my RPi I ordered a couple of Sandisk Extreme 4GB SDHC Class 10 cards. This was before I discovered the compatibility issue. I have tended to buy Sandisk or Kingston cards anyway, so I stuck with what I knew and it bit me.

The Sandisk Extreme cards wouldn't work at all, with the red light and no green light symptom.

So I borrowed a Kingston 2GB SD-Card, which works fine, but is very tight on space, naturally.

So having discovered the compatibility list, I tried a pair of 16GB Sandisk Ultra Class 6 SDHC cards from my camera set. These are in the "working" list although qualified, but they don't work either, just giving me a stream of "MMC0: Timeout waiting for hardware interrupt" messages.

I happen to have one odd card an InoV8 16GB Class 6 SDHC card, which again I have borrowed from my camera set. That gives me a load of "MMC0: error -110 whilst initialising SD card" messages, but eventually boots and seems to work, but hardly confidence inspiring.

So I am now contemplating which cards to buy now. I am not confident in the compatibility list, as I have tried that already, so it seems to be simply hit-or-miss. Luckily the cards I have tried I already had lying around, but I could have spent as almost as much on non-working SD cards as the RPi cost in the first place. This could become a significant cost to anyone looking to buy into this platform, especially novices, which lets face it is the intended audience.

One of the problems with the compatibility list is that it doesn't clearly identify working cards in my opinion.

For example, the Sandisk Class-10 cards I bought appear to be in both the working and the problem list.

From the working list:
4GB SDHC Class 10 Extreme (BH10297143382G)

From the problem list:
4GB SDHC Class 10 Extreme (30 MB/s HD Video) (Doesn't boot) - Works with new kernel.img and start.elf [15]

The [15] link leads to some patches which supposedly may fix things, but I haven't been successful with this yet, although I note they have been updated in the last couple of days, so may try again.

Another example my 16GB Sandisk Class 6 SDHC cards...
From the working list:
16GB SDHC Class 6 Ultra (30MB/s) (BL1133921933G) - Work with OpenELEC r11324

From the problem list:
16GB SDHC Class 6 Ultra (BL1202021933G)

I appreciate that the content of the list is largely uncontrolled, but there is a danger that this sort of issue has negative connotations. Is there anyway that some sort of more formal vetting or control be introduced?

Also, why is this turning out to be such an issue? You don't see these sorts of problems with cameras and the like, so why is it happening here? Is it going to be possible to fix this? Or are people going to have to be forever careful about which cards they choose?
User avatar
Posts: 771
Joined: Sun Jun 10, 2012 3:57 pm
by selsinork » Tue Jun 19, 2012 7:00 pm
Mortimer wrote:Also, why is this turning out to be such an issue? You don't see these sorts of problems with cameras and the like, so why is it happening here? Is it going to be possible to fix this? Or are people going to have to be forever careful about which cards they choose?

Things are still developing, there's a lot of interesting stuff been done to the sd card driver very recently which improves things for most people and most cards.

Have you tried the new debian image from ? I'd suggest giving it a try with your problem cards, you might be surprised.

The thing with the list on the wiki is that it's not keeping up with new developments. Cards that now work are still in the 'problem' list and likely will be until the original reporter gets round to testing with the new kernel/firmware and then updates the wiki. You can help by testing and reporting your findings :)
Posts: 151
Joined: Mon Apr 16, 2012 8:31 am
by lb » Tue Jun 19, 2012 7:11 pm
There are several reasons why SD compatibility is so problematic. The initial Linux SDHCI driver wasn't very good (it still isn't, but it's a lot better now), the SD interface seems to be somewhat buggy on a hardware level, there's no proper documentation on the hardware, and the bootloader also has its own set of issues.

That said, you should really try again with newest firmware and kernel (the new Wheezy debian ships those out of the box).
Posts: 232
Joined: Sat Jan 28, 2012 8:07 pm
by Mortimer » Tue Jun 19, 2012 10:09 pm
I have just tried Wheezy on one of the 16GB Sandisk Ultra Class 6 cards. Booted first time and seems problem free at the moment. Well done chaps! I'll give one of the Class 10 cards a whirl now! Is that tempting fate or what!!?
User avatar
Posts: 771
Joined: Sun Jun 10, 2012 3:57 pm
by Mortimer » Tue Jun 19, 2012 11:35 pm
Very pleased with this, Wheezy on the 16GB Class-6 Sandisk Ultra card is my main build now.
User avatar
Posts: 771
Joined: Sun Jun 10, 2012 3:57 pm
by pjc123 » Wed Jun 20, 2012 11:44 am
I received my remaining pi parts last night, plugged everything in and it worked perfectly the first time I booted. Based on several good reviews I bought a Transcend TS16GSDHC6 and it works fine. My speed on the pi is only 4.40 MB/s but with the card reader is 16 MB/s. This is a common problem and I will be updating either the kernel or try Wheezy beta which is supposed to fix that issue.
My Raspberry Pi Project Page:
Posts: 911
Joined: Thu Mar 29, 2012 3:37 pm
by zardoz99 » Wed Jun 20, 2012 12:35 pm
I'm using these in my Raspis. No detectable problem so far. Swap is enabled running Fedora 17. ... 49957.aspx


Posts: 158
Joined: Fri Jan 13, 2012 2:25 pm
by ssb » Mon Jul 30, 2012 9:16 am
I successfully have installed Raspian Wheezy onto a "YourMemoryCard 64GB SDXC Class 10 Professional" (bought via Amazon for about 32 Euro).
Also enlarging the Root-Volume to span the whole SD card worked, but resizing took a very long time.
Posts: 2
Joined: Mon Jul 30, 2012 9:14 am
by spoeken » Wed Sep 05, 2012 1:25 pm
Hi, anyone know if 32GB SDHC Class 4 (SD4/32GB) Will work?
16GB SDHC Class 4 (SD4/16GB) Is on the list of working.

32GB SDHC Class 4 (SD4/32GB) Has SDHC/Secure Digital versjon 2.0, does RPi have support for this?
Posts: 6
Joined: Wed Sep 05, 2012 1:19 pm
by Licaon_Kter » Wed Sep 05, 2012 1:53 pm
My results: Sandisk Ultra 8Gb Class10 30mb/s (SDSDU-008G-U46)
CrystalDiskMark 3.0.1 x64 (C) 2007-2010 hiyohiyo
Crystal Dew World :
* MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

Sequential Read : 20.869 MB/s
Sequential Write : 20.437 MB/s
Random Read 512KB : 20.470 MB/s
Random Write 512KB : 4.307 MB/s
Random Read 4KB (QD=1) : 4.082 MB/s [ 996.6 IOPS]
Random Write 4KB (QD=1) : 1.030 MB/s [ 251.4 IOPS]
Random Read 4KB (QD=32) : 3.849 MB/s [ 939.7 IOPS]
Random Write 4KB (QD=32) : 1.016 MB/s [ 248.0 IOPS]

Test : 50 MB [F: 0.0% (0.0/7572.0 MB)] (x5)
Date : 2012/07/27 15:23:20
OS : Windows 7 Home Premium Edition SP1 [6.1 Build 7601] (x64)


H2testw v1.4
Warning: Only 500 of 7572 MByte tested.
Test finished without errors.
You can now delete the test files *.h2w or verify them again.
Writing speed: 17.3 MByte/s
Reading speed: 19.2 MByte/s
sd-sdsdu-008g.jpg (12.87 KiB) Viewed 11704 times
BFQ+BFS or RT on a RPi? 4'real: (source and compiled!)
User avatar
Posts: 240
Joined: Wed Sep 05, 2012 10:12 am
Location: Between the keyboard and the chair.
by ahlidap » Sun Sep 09, 2012 10:38 am
EMTEC Micro SDHC (with adapter to SD) 8GB working flawlessly.


No problem at all, with Model B Rev1.
Posts: 6
Joined: Wed Sep 05, 2012 9:02 am