handfish
Posts: 12
Joined: Fri Apr 14, 2017 5:54 am

Problem with rtl sdr

Sun May 14, 2017 7:22 am

I have been running piaware using an original Pi B and an rtl-sdr (RTL28323U R820T2). Recently, though, the installation stopped working with the rtl-sdr not showing under lsusb. I've updated and upgraded, rebooted, and checked that the rtl-sdr works by connecting to a Mac and running gqrx to ensure it gets some signal. Any ideas what I should do to fault find next? It just seems odd that the installation ran for a few weeks and then stopped.

uname -a:
Linux specchio 4.9.24+ #993 Wed Apr 26 17:56:54 BST 2017 armv6l GNU/Linux

lsusb:
Bus 001 Device 005: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500 Ethernet 10/100 Adapter / SMSC9512/9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -t:
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/3p, 480M
|__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
|__ Port 3: Dev 5, If 0, Class=Vendor Specific Class, Driver=rt2800usb, 480M

dmesg (post clear and replugging in rtl-sdr:
[631889.363584] usb 1-1.2: new high-speed USB device number 91 using dwc_otg
[631909.844152] usb 1-1.2: new high-speed USB device number 47 using dwc_otg
[631962.325538] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[632052.437774] usb 1-1.2: new high-speed USB device number 109 using dwc_otg
[632109.779232] usb 1-1.2: new high-speed USB device number 85 using dwc_otg
[632159.700444] usb 1-1.2: new high-speed USB device number 32 using dwc_otg
[632163.030571] usb 1-1.2: new high-speed USB device number 44 using dwc_otg
[632190.421214] usb 1-1.2: new high-speed USB device number 27 using dwc_otg
[632219.091974] usb 1-1.2: new high-speed USB device number 15 using dwc_otg
[632345.305224] usb 1-1.2: new high-speed USB device number 14 using dwc_otg
[632419.797021] usb 1-1.2: new high-speed USB device number 58 using dwc_otg
[632430.037254] usb 1-1.2: new high-speed USB device number 97 using dwc_otg
[632462.038086] usb 1-1.2: new high-speed USB device number 98 using dwc_otg
[632500.949073] usb 1-1.2: new high-speed USB device number 126 using dwc_otg
[632559.060462] usb 1-1.2: new high-speed USB device number 106 using dwc_otg

fdufnews
Posts: 276
Joined: Fri Oct 07, 2011 5:37 pm

Re: Problem with rtl sdr

Fri May 19, 2017 11:18 am

RTL-SDR are quite power hungry and lsusb shows that you also have a Wifi dongle connected to your board. Are you sure you don't have a power issue?

handfish
Posts: 12
Joined: Fri Apr 14, 2017 5:54 am

Re: Problem with rtl sdr

Sat May 20, 2017 5:05 am

fdufnews wrote:RTL-SDR are quite power hungry and lsusb shows that you also have a Wifi dongle connected to your board. Are you sure you don't have a power issue?
Not sure no. What's the best way of checking? I have an official rpi power plug which I can try, or should I be checking voltage somewhere?

The only thing I'm going on is that the pi was working for a few weeks and then stopped working.
Last edited by handfish on Sat May 20, 2017 5:18 am, edited 1 time in total.

handfish
Posts: 12
Joined: Fri Apr 14, 2017 5:54 am

Re: Problem with rtl sdr

Sat May 20, 2017 5:05 am

fdufnews wrote:RTL-SDR are quite power hungry and lsusb shows that you also have a Wifi dongle connected to your board. Are you sure you don't have a power issue?
Not sure no. What's the best way of checking? I have an official rpi power plug which I can try, or should I be checking voltage somewhere?

The only thing I'm going on is that the pi was working for a few weeks and then stopped working.

handfish
Posts: 12
Joined: Fri Apr 14, 2017 5:54 am

Re: Problem with rtl sdr

Sat May 20, 2017 5:05 am

fdufnews wrote:RTL-SDR are quite power hungry and lsusb shows that you also have a Wifi dongle connected to your board. Are you sure you don't have a power issue?
Not sure no. What's the best way of checking? I have an official rpi power plug which I can try, or should I be checking voltage somewhere?

The only thing I'm going on is that the pi was working for a few weeks and then stopped working.

handfish
Posts: 12
Joined: Fri Apr 14, 2017 5:54 am

Re: Problem with rtl sdr

Sat May 20, 2017 7:46 am

fdufnews wrote:RTL-SDR are quite power hungry and lsusb shows that you also have a Wifi dongle connected to your board. Are you sure you don't have a power issue?
I've switched in the rpi power brick, and the RTL-SDR is now working for piaware. Having said that, it is not registering properly.

piaware-status:

PiAware master process (piaware) is running with pid 519.
PiAware ADS-B client (faup1090) is running with pid 856.
PiAware mlat client (fa-mlat-client) is running with pid 969.
Local ADS-B receiver (dump1090-fa) is running with pid 500.

dump1090-fa (pid 500) is listening for connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.

dump1090 is producing data on localhost:30005.


lsusb is:

Bus 001 Device 005: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500 Ethernet 10/100 Adapter / SMSC9512/9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg is getting:

[ 239.574379] usb 1-1.2: new high-speed USB device number 92 using dwc_otg
[ 240.494360] usb 1-1.2: new high-speed USB device number 95 using dwc_otg
[ 242.804467] usb 1-1.2: new high-speed USB device number 103 using dwc_otg
[ 243.134460] usb 1-1.2: new high-speed USB device number 104 using dwc_otg
[ 243.824487] usb 1-1.2: new high-speed USB device number 106 using dwc_otg
[ 244.154485] usb 1-1.2: new high-speed USB device number 107 using dwc_otg
[ 244.854523] usb 1-1.2: new high-speed USB device number 109 using dwc_otg
[ 245.874524] usb 1-1.2: new high-speed USB device number 112 using dwc_otg
[ 246.234600] usb 1-1.2: new high-speed USB device number 113 using dwc_otg
[ 246.894764] usb 1-1.2: new high-speed USB device number 115 using dwc_otg

So it is working, but not settling on a device number...?

linux_author
Posts: 240
Joined: Sat Apr 02, 2016 7:04 pm
Location: Gulf of Mexico
Contact: Website

Re: Problem with rtl sdr

Sat Jul 08, 2017 7:29 pm

i would love to see a working implementation of rtl-sdr software under the RPi3 - none of the software packages i have tried so far have worked...

this is kind of a missing element to full enjoyment of the RPi platform as a media do-it-all box... if a solution is found, this means that the RPi3 can host internet streaming, play videos, music, and do sdr radio!

alas, gqrx does not work... (but it does quite well on x86 and OS X [which is also x86])

willie
on the easy-listening Gulf of Mexico

Return to “Recommended peripherals”

Who is online

Users browsing this forum: No registered users and 3 guests