MichaelAbode
Posts: 1
Joined: Fri Apr 05, 2013 11:56 pm

Hard Drive Corruption On Reboot

Sat Apr 06, 2013 12:45 am

Hello all,

As the topic states, my hdd gets corrupted every time I reboot. I'm forced to reformat it. It becomes NTFS. I'm using a Western Digital 500 GB from an old laptop, 2.5 NexStar TX SATA enclosure. I need use an external power source through the y cable to power it and get it working. I've been able to successfully mount it several times using 5v 1A. I can also transfer files. The problem is every time I reboot the files are gone and when I try to remount I get this message

ntfs_mst_post_read_fixup_warn: magic: 0x00000090 size: 1024 usa_ofs: 88 usa_count: 65535: Invalid argument
Record 6 has no FILE magic (0x90)
Failed to open inode FILE_Bitmap: Input/output error
Failed to mount '/dev/sda1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

When I connect it back to my computer I get The disk structure is corrupted and unreadable message when I try to open it.

I want to use it as my backup but obviously can't because of continued corruption.

I'm running Raspbian “wheezy”.

Thank you for your assistance.

klricks
Posts: 6777
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Hard Drive Corruption On Reboot

Sun Apr 07, 2013 3:12 pm

If you manually mount a drive then it needs to be manually unmounted before rebooting.
I don't understand your power supply setup 'Y" cable?
If your are trying to power the RPi and the drive with a 5V 1A then I don't think 1A is enough.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

jfsmith89
Posts: 1
Joined: Thu Apr 25, 2013 2:42 pm

Re: Hard Drive Corruption On Reboot

Thu Apr 25, 2013 2:50 pm

I also had this problem with the NexStar TX SATA enclosure. If you look at the reviews on amazon many people have reported issues with corruption when connecting drives using these enclosures to Linux machines so I would assume that the problem is not with the pi. I have tried using other external drives and enclosures and they have all worked fine so far.

Return to “HATs and other add-ons”