Posts: 4
Joined: Thu Feb 14, 2013 11:28 am

TSOP4838 IR stopped working?

Thu Feb 14, 2013 12:47 pm

Hi guys, last week I managed to get a TSOP4838 IR receiver working with my raspberry pi on Raspbmc, following the examples others have done to set up lirc and get the remote codes config file in place. After a few days of fiddling everything was working great.

Last night I decided to shut down my pi (cleanly), disconnect everything, back up the SD image just in case (it already corrupted on me once, so I'm trying to be extra safe now), and then move it into my cabinet and reconnect everything. I think this was maybe also my first shutdown/reboot since I got the IR working. When it all came back up, everything else was fine, but I had no success at all getting the IR to work again. I tried the whole procedure I had to go through before, of exiting XBMC, going into the command line, disabling lirc, and then running it in direct mode (with mode2 -d /dev/lirc0) to see if it was picking up anything at all - and now (unlike before), it doesn't even seem to receive the raw codes from the remote at all. I tried shutting down and rebooting a few times, disconnecting and reconnecting all the wires, and nothing seems to help. I'm stuck now, not sure what to do.

Is it possible I have broken my TSOP4838 IR receiver already? Is the thing that delicate? I had it taped to the top of my cabinet with a piece of electrical tape before, and all I've done now is simply move it and re-tape it - so I wasn't particularly rough with it or anything, but maybe just in moving it I've broken it? I really have no idea.

Sorry if these are very basic questions, I'm by no means an expert in rasp pi or in linux in general. So back to basics, what are the basic steps I can do to just make sure I haven't broken my IR receiver? Am I right in thinking I should go back to running ( mode2 -d /dev/lirc0 ) and seeing if it receives anything? I recall last week when I did this, just by shutting down lirc, and then running that command, I was able to see all the incoming control codes when I started pressing buttons on the remote - so that's how I knew I had at least connected it properly with the 3 wires, and that it was working properly. From there, getting lirc configured and working with XBMC was very straightforward.

Am I missing something or can anyone give me some basic steps to go through, just to check that the IR receiver is not broken?


Posts: 283
Joined: Wed May 23, 2012 6:48 pm

Re: TSOP4838 IR stopped working?

Thu Feb 14, 2013 8:05 pm

Did you turn on gpio remote in Raspbmc settings? Is the lirc_rpi kernel module loaded? Try running "lsmod" and see if the module shows.

Posts: 4
Joined: Thu Feb 14, 2013 11:28 am

Re: TSOP4838 IR stopped working?

Sat Feb 16, 2013 4:55 pm

Thanks for your reply.

Yes, in the XBMC Raspbmc settings I have ticked the boxes for "Enable Repeat Filter", "Enable GPIO TSOP IR Receiver", and "GPIO IR Remote Profile: Original XBOX DVD Playback Remote". This was all working fine a few days ago before I decided to shut it down and disconnect it.

FYI in case this makes any difference, I'm using my OneForAll remote which was already configured with the old XBOX setup, so that's why it just worked with "Original XBOX DVD Playback Remote" I presume. That is also the same setup I used for the lircd.conf I downloaded and copied over, and it all started working after I had done that initially. I've gone back over all those configs again and again, and I'm pretty sure they are the same as what they were when I got this working - and I haven't changed anything as far as I know.

I have tried rebooting back into XBMC many times, and it still doesn't work. I've tried exiting out, stopping the service, and running the mode2 command to pick up codes manually, and that also doesn't work at all.

When I run lsmod, among other modules I can see lirc_rpi (which says "used by: 3") and lirc_dev (which says "used by: 1 lirc_rpi"). When I run the init.d/lirc stop command (the first time) it works and is green; the next time, it fails and is red, presumably because I've already stopped it. So since it is green the first time I stop it (and if I start it again), I assume that it was successfully loaded and started in the first place, right?

Does that all sound right? Anything else I can check? I've gone back through all the .conf files and checked everything again, and I'm pretty sure it all looks right.

I've ordered another TSOP4838, and it has the same result - so I guess it's not a problem with my IR receiver itself. So now I'm convinced this is down to either (1) the wiring of the IR receiver to the GPIO port (which I've disconnected and reconnected a number of times to be sure); or (2) the GPIO port itself being broken - is this possible? Or (3) still some bad software configuration.

Any other ideas?

Posts: 1
Joined: Tue Oct 08, 2013 11:11 am

Re: TSOP4838 IR stopped working?

Tue Oct 08, 2013 11:22 am


Did you find cause of your problem? I have the same situation with TSOP4838. It was working without problems with lircd and now it is silent.

Posts: 61
Joined: Sat May 04, 2013 12:20 am

Re: TSOP4838 IR stopped working?

Fri Nov 01, 2013 6:11 pm

I have bought a few TSOP4838 and none of them are working, so not sure what the issue is. In mode2 they show nothing is being picked up. When I touched the thing, sometimes I would see some pulses in mode2. I was hoping to replace a different TSOP that is still working when I hook it up. I tried different jumper wires and no change. I'm not sure if there is something wrong with the whole batch of TSOP4838 or there is something else wrong.

In XBMC, I get no response.

When I test from command line I perform:
/etc/init.d/lirc stop
mode2 -d /dev/lirc0

At this point I should be seeing pulse etc commands when I press keys on the remote, but I see nothing.

Seems to be detected and everything:

[email protected]:/home/pi# dmesg | grep irc
lirc_dev: IR Remote Control driver registered, major 251
lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
lirc_rpi lirc_rpi.0: lirc_dev: driver lirc_rpi registered at minor = 0
lirc_rpi: driver registered!
input: lircd as /devices/virtual/input/input2
lirc_rpi: auto-detected active low receiver on GPIO pin 18

Posts: 3
Joined: Sat Nov 16, 2013 11:40 am

Re: TSOP4838 IR stopped working?

Sat Nov 16, 2013 11:45 am


I have the same Problem. Does anyone have a solution for this problem :idea: ?


Return to “HATs and other add-ons”