Wireless Data for you Raspberry Pi via FreedomPop

8 posts
by r01r02i03i04 » Sun Dec 30, 2012 9:44 pm
Quick note, I do not work for FreedomPop, I am just posting my results and my observations with their device and service from South Florida, USA.

Via wikipedia, "FreedomPop is a freemium Internet service provider based in the US. Founded in 2011"

Review of FreedomPop devices by PCmag
http://www.pcmag.com/slideshow_viewer/0 ... o=1,00.asp

Service & Costs:
The service is WiMax, provided by Clear / Clearwire, running on Sprints 2500 MHz service and towers. Since Clear plans to move to Sprint's LTE service, FreedomPop, also plans to do this.

Service Plans:
500 MB a month ($0.02 per 1MB over) for Free / month
2 GB a month ($0.01 per 1MB over) for $17.99 / month
4 GB a month ($0.01 per 1MB over) for $28.99 / month
They offer a "FreedomPop Speed Plus" service for $3.99/month which states:
"Get up to 50% faster speeds - Browse the web & watch videos without delay"
-Guaranteed fastest upload speeds all day, every day!
-No speed caps regardless of data usage
-No throttling regardless of data usage
-Download speeds up to 12Mpbs
-Upload speeds up to 1.5 Mbps

But I'm not sure what that plan is, I suspect it is an additional $3.99/month.

Freedom Stick - Bolt usb modem is "Free" with a $49.00 refundable security deposit
Image Image Image
Freedom Spot - Photon hotspot is "Free" with a $99.00 refundable security deposit
Image Image Image Image
Freedom Sleeve Rocket - 4G hotspot for iPod Touch is "only $99 (100% fully refundable)"
Image Image Image Image

They are currently running a promotion where they will wave the security deposit for the Freedom Stick - Bolt and give a month of the 2GB plan for free.
With this promotion, the charges are
Device: $0
Security Deposit: $0
Shipping & Handling: $15
Total: $15.

Normally Shipping and Handling is $6.99, so they are bumping up the price a little, although still not covering the security deposit. And you'll want to drop the 2GB plan and change to the 500MB plan if you wish to keep it cheap.

Currently, I am using the FreedomPop Bolt, also called Freedom Stick Bolt 4G.

It is the same device as the Clear / Clearwire Stick Atlas

The FreedomPop Bolt is a WiMax device, model: pxu1964, which uses the Sprint's 2500 MHz frequency WiMax service.
The FreedomPop Bolt, and Clear Stick Atlas are manufactured by Ubee Interactive.

From my experience, using a 1st gen model B raspberry pi, os: 2012-12-16-wheezy-raspbian, kernel: 3.2.27+, and a powered usb hub, the FreedomPop Bolt was recognized and got an IP. There was a bit of troubleshooting at first, but I suspect that was my own fault, as I'm very new to linux and may have messed up some of the raspbian settings. But on a clean raspian install and an out of the box FreedomPop Bolt, I suspect it should work right away.

Connection Speeds:
Using Speedtest.net
From inside my house:
Reception: rssi -81 (2 bars on device)
Download: 1.69 Mb/s
Upload: 0.09 Mb/s
Ping: 110 ms

I stepped house side my door:
Reception: rssi -74 (3 bars on device)
Download: 3.99 Mb/s
Upload: 0.89 Mb/s
Ping: 78 ms

I plan to search for better reception and report back my findings.

The bolt features two TS-9 external antenna connectors which I plan to purchase an antenna for and see what I can get.

This setup is definitely not going to win any speed test awards, but considering you can get the device for $49+$7 S&H (or $0+$16 S&H with holiday promotion), 500 MB of data a month for free, and use with the Rasberry Pi is plug-and-play, I am very happy with it. I plan to go back and re-read their Terms and Privacy statement just to make sure I have understood everything. But as far as privacy is concerned, I plan to setup a VPN and tunnel everything through it while on the FreedomPop service.
Complete linux newbie.
Posts: 4
Joined: Sun Dec 30, 2012 6:07 pm
by r01r02i03i04 » Sun Dec 30, 2012 10:34 pm
Below is the web gui for the FreedomPop Freedom Stick Bolt 4g








EDIT: I didn't realize they would be shrunk / resized to the point of illegibility, if needed, I will post links to full resolution images.
Complete linux newbie.
Posts: 4
Joined: Sun Dec 30, 2012 6:07 pm
by r01r02i03i04 » Mon Dec 31, 2012 3:40 am
These are some speed test results using the internal antenna.


In house (approximately 634 m (2081 ft) from tower) with trees and house in between:

In yard, approximately 634 m (2081 ft) from tower with trees, and residences between:

In yard, approximately 1788 m (5866 ft) from tower with trees, residences, highway and lake between:

In car, approximately 33 m (108 ft) from tower with building between:
Complete linux newbie.
Posts: 4
Joined: Sun Dec 30, 2012 6:07 pm
by jbstanford » Mon Jan 07, 2013 3:31 am
I want to get my Raspberry Pi setup somehow to use FreedomPop for out of band management so that if my home dsl/router goes down I can use the freedompop to remote into my raspberry pi and reboot the connection (shutting the UPS off and on again if needed). I'm still working out details, but it is nice to read that it is supported out of the box.
Posts: 3
Joined: Fri Nov 23, 2012 4:27 am
by alexwhittemore » Wed Jan 30, 2013 5:58 am
r01r02i03i04 (what kind of a name IS that?!), what were the actual troubleshooting steps you used? I'm on the same OS image and my Bolt doesn't seem to be working out of the box. It pops up as a new network interface (eth1) but never seems to get a local IP (192.168.14.x), thus I can't troubleshoot any kind of connection issues beyond that.
Posts: 1
Joined: Wed Jan 30, 2013 5:55 am
by wteele » Fri Feb 08, 2013 3:07 am
Open up the terminal and type in ifconfig

It should show 3 devices eth0, eth1, and lo.

eth0 is the built-in ethernet port.
eth1 is the FreedomPop device
lo is the loopback interface

sudo dhclient eth1

That should enable the FreedomPop device. However, you need to do this network setting every time you restart the Pi. I guess you can write a script to automate it when it boots.
Posts: 1
Joined: Fri Feb 08, 2013 3:03 am
by sprombo » Fri Jun 07, 2013 7:52 am
I followed all of the steps that were mentioned, but my RPi's not even recognizing it as eth1. There's just eth0 and lo. Any suggestions?
Posts: 2
Joined: Fri Jun 07, 2013 7:35 am
by dadiduu » Sun Apr 27, 2014 11:15 pm
Hi, I was confused about connecting my Pi via Wlan (because my wifi adapter is not supported or I am too lazy to do some work around :D :D ).. And then I do Ifconfig and I found The Glorious ETH1, that I wasn't even intended to used... Now, that I found your POSTING about ~sudo dhclient eth1~ , I tried, and I succeed.... Thank you very much.... :D :D :D :D :D :D :D
Posts: 1
Joined: Wed Apr 23, 2014 2:26 pm