MountainRider
Posts: 3
Joined: Sat Nov 24, 2012 10:26 pm

USB Audio Problems

Sat Nov 24, 2012 10:34 pm

I am using a Turtle Beach Amigo II with my Raspberry Pi.

I commented out the line
# options snd-usb-audio index=-2
in /etc/modprobe.d/alsa-base.conf. However, when I run
aplay test.wav
there is no sound. However, if I run
aplay -D sysdefault:CARD=Audio test.wav
I hear sound out of the speaker output.

How do I make my USB audio device the default?

RPisces
Posts: 6
Joined: Tue Sep 11, 2012 4:56 am

Re: USB Audio Problems

Sun Dec 02, 2012 8:13 pm

I've been trying to search for a solution to this too but no luck. I am wondering how to make it the default audio card....

ski522
Posts: 394
Joined: Sun Sep 30, 2012 2:22 pm

Re: USB Audio Problems

Sun Dec 02, 2012 11:28 pm

MountainRider wrote: How do I make my USB audio device the default?
Change the line in the alsa-base.conf to

Code: Select all

options snd-usb-audio index=0

Return to “HATs and other add-ons”