tigerdog
Posts: 2
Joined: Wed Nov 21, 2012 11:17 pm

PIFACE - Relay output not outputting voltage

Wed Nov 21, 2012 11:28 pm

Relay clicks and corresponding on board led lights up but zero voltage on either NC and NO output pins - across the relays common (using a multimeter ) for both relays.

Have also tried removing jumpers JP5 and/or JP6 but this completely disables the relay.
The multimeter reads 5v from other non relay output pins.

Received my piface from shop.openlx.org.uk a couple of days ago.

using Python piface.pfio on rev1 Raspberry Pi - running recommended piface linux image from pi.cs.man.ac.uk/download/

Code: Select all

import piface.pfio as pfio
pfio.init()
r1 = pfio.Relay(1)
r1.init()
r1.turn_on()
Does anyone have any Ideas?

tigerdog
Posts: 2
Joined: Wed Nov 21, 2012 11:17 pm

Re: PIFACE - Relay output not outputting voltage

Thu Nov 22, 2012 12:11 pm

PROBLEM SOLVED

One of the guys at Pi-Face has helpfully pointed me in the right direction, and I now have my Raspberry Pi/Pi-Face running a Big Trak Jrn (all within 5 minutes). I would recommend it as a great combination for getting started in electronic projects. Next I need to get Scratch working with the Pi-Face so my nephew can program it.

Here is the solution:-
There shouldn't be any voltage on the two relays on the short side of
the board. They are not connected to any power supply so you are free to
connect it to whatever voltage you want. They act as switches that
change over between the centre terminal and NC and NO terminals. If you
want to use it for 5V out, you can connect the centre terminals the the
5V connector.

The other, non-relay outputs are open-collector and so capable of sinking current.

Return to “HATs and other add-ons”