mob-i-l
Posts: 256
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Google+ Twitter YouTube

Power antenna to TV HAT through antenna cable

Sun Feb 24, 2019 11:58 am

I have an indoor TV-antenna that is powered by 6V through a separate jack, but it can also be powered though the antenna cable when I use an old DVB-T box, but the TV HAT doesn't provide power. It would be less cluttering of cables if I could find some adapter that I could connect the 6 V to and power the antenna via the antenna cable to the TV µHAT. Is there such an adapter that works with the TV uHAT?
Have Pi0&1A&1B&1B+&2B&3B&4B w/ Raspbian. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

drgeoff
Posts: 9627
Joined: Wed Jan 25, 2012 6:39 pm

Re: Power antenna to TV HAT through antenna cable

Sun Feb 24, 2019 8:34 pm

It is almost trivial to make one if you have some experience of electronic construction and soldering.

You need a small value capacitor between the centre of the HAT coax socket and the cable to the amplifier. You can make a capacitor by tightly twisting together two lengths of thin insulated wire - say 2 cm.

Then you need a small value inductor between the non-ground (probably +ve) of the PSU and the centre of the coax to the amplifier. You can make the inductor from thin insulated wire - 10 turns, 5 mm diameter, 8 mm long (the coiled part). Connect together all 3 of outer of HAT coax socket, outer of coax to amplifier and ground of PSU.

mob-i-l
Posts: 256
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Google+ Twitter YouTube

Re: Power antenna to TV HAT through antenna cable

Mon Mar 04, 2019 11:23 pm

I now use the old DVB-T box to power the antenna in stead of the 6 V power supply. I connected the antenna to it on RF-in and the TV HAT to RF-out. This works even if the box is in standby, but if I pull the plug to the box the signal from the antenna disappears, as expected.
Have Pi0&1A&1B&1B+&2B&3B&4B w/ Raspbian. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

Return to “HATs and other add-ons”