Posts: 3
Joined: Sat Aug 04, 2012 5:14 pm
Location: Germany

Linux4Media LCD (l4m132c) influences USB + ETH @ RapBMC

Sat Aug 04, 2012 5:28 pm


I'm currently trying to use a L4M LCD as Display for RaspBMC and have huge problems installing ist properly. If i attach the Display directly the power consumption is to big and it doesn't power up. Now I power it up via a hub and start screen shows up. Unfortunately there are two big problems from that moment on:

1. The Ethernet connection seems to slow down extremely or even breaks.
2. Other USB devices attached to the hub or second port slow down or aren't available any longer.

This problem can be solved by removing the display.

I tried to install alls neccesary drivers as described on this site: ... mc-nutzen/

I'm not sure if it is a sofware issue or a hardware incopatibely incompatibility with the LCD controller (Cypress CY8C24894

I don't have much experience with unix and therefor don't know how to check what is the problem.

Thanks for your help.

Posts: 28
Joined: Sat Aug 04, 2012 3:04 pm
Location: Guimarães, Portugal

Re: Linux4Media LCD (l4m132c) influences USB + ETH @ RapBMC

Sun Aug 05, 2012 1:05 am


my first guess would be power issues. I tried to Google some more specs for that LCD, but couldn't find none (at least about power consumptions).
Does it have any option for external power, or does it only power itself via USB?

Posts: 3
Joined: Sat Aug 04, 2012 5:14 pm
Location: Germany

Re: Linux4Media LCD (l4m132c) influences USB + ETH @ RapBMC

Sun Aug 05, 2012 9:12 am


the LCD is powered seperately by an sufficient power source. It needs more than the 140 mA provided by the Pi. The LCD seems to startup, because i can access the PI via SSH before I attached the LCD. Then I plug in the LCD and it powers up and I can find these devices:


Therefor it sems to power up correctly and hardware is detected. The problem is that other USB-Devices and ethernet slow down extremely and I can't acces the LCD by software. Also SSH slows down and breaks up sometimes. As soon as i remove the LCD other USB devices are detected again and eveything is fine.
The voltage at TP 1&2 is >= 4,8V.

Posts: 3
Joined: Sat Aug 04, 2012 5:14 pm
Location: Germany

Re: Linux4Media LCD (l4m132c) influences USB + ETH @ RapBMC

Sun Aug 05, 2012 4:16 pm

Hi there,

I tried out OpenELEC today and have the same behavior of the system as described for RaspBMC.
I could not find a list of USB hub controllers which make trouble together with RasPi but I can say that everything works fine till the LCD comes into play. I made a Ping-test to show you the difference between LCD plugged in and removed:
LCD plugged in

Code: Select all

64 bytes from seq=215 ttl=46 time=19226.552 ms
64 bytes from seq=216 ttl=47 time=18183.872 ms
64 bytes from seq=217 ttl=47 time=17196.714 ms
64 bytes from seq=218 ttl=46 time=16102.431 ms
64 bytes from seq=219 ttl=47 time=15147.090 ms
64 bytes from seq=220 ttl=46 time=15172.464 ms
64 bytes from seq=221 ttl=46 time=14165.452 ms
64 bytes from seq=222 ttl=46 time=13099.700 ms
64 bytes from seq=223 ttl=47 time=12118.554 ms
64 bytes from seq=224 ttl=46 time=11138.850 ms
64 bytes from seq=225 ttl=46 time=10157.804 ms
64 bytes from seq=226 ttl=46 time=9175.954 ms
64 bytes from seq=227 ttl=47 time=8201.938 ms
64 bytes from seq=228 ttl=46 time=7221.483 ms
64 bytes from seq=229 ttl=47 time=6241.137 ms
64 bytes from seq=230 ttl=46 time=5261.040 ms
64 bytes from seq=231 ttl=47 time=4282.421 ms
64 bytes from seq=232 ttl=46 time=3301.796 ms
64 bytes from seq=233 ttl=47 time=2333.771 ms
64 bytes from seq=234 ttl=47 time=1550.795 ms
64 bytes from seq=235 ttl=46 time=776.355 ms
LCD removed:

Code: Select all

64 bytes from seq=0 ttl=46 time=21.931 ms
64 bytes from seq=1 ttl=46 time=24.344 ms
64 bytes from seq=2 ttl=47 time=21.414 ms
64 bytes from seq=3 ttl=46 time=20.161 ms
64 bytes from seq=4 ttl=47 time=23.500 ms
64 bytes from seq=5 ttl=46 time=24.119 ms
64 bytes from seq=6 ttl=46 time=21.418 ms
64 bytes from seq=7 ttl=47 time=21.509 ms
64 bytes from seq=8 ttl=46 time=21.176 ms
64 bytes from seq=9 ttl=47 time=21.269 ms
64 bytes from seq=10 ttl=46 time=20.802 ms
64 bytes from seq=11 ttl=47 time=22.785 ms
64 bytes from seq=12 ttl=47 time=21.710 ms
64 bytes from seq=13 ttl=46 time=21.671 ms
Another lead I found is lirc. It seams to me that lirc fully loads the system:

Code: Select all

Mem: 111996K used, 11548K free, 0K shrd, 27728K buff, 47540K cached
CPU: 77.0% usr 14.2% sys  0.0% nic  8.7% idle  0.0% io  0.0% irq  0.0% sirq
Load average: 1.18 1.72 1.67 1/79 1651
  954     1 root     R     214m177.8   0 83.6 /usr/lib/xbmc/xbmc.bin --standalone -fs --lircdev /var/run/lirc/lircd
  524     2 root     SW<      0  0.0   0  5.3 [VCHIQ-0]
  525     2 root     SW<      0  0.0   0  1.6 [VCHIQr-0]
Is it possible to check if lirc slows down the system. Please keep in mind that I am a newbie :-)

Return to “HATs and other add-ons”