benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Deleted

Wed May 27, 2015 1:27 pm

Deleted
Last edited by benspring100 on Thu Jan 05, 2017 10:17 pm, edited 1 time in total.

User avatar
Lob0426
Posts: 2198
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
Contact: Website

Re: Tontec 3.5" Screen - Only displaying white screen

Wed May 27, 2015 4:59 pm

Did you add the code to config.txt?

Code: Select all

sudo nano /boot/config.txt
dtpram=spi=on
dtoverlay=mz9486
Edit xorg file fbdev fb0 to fb1
Yours may be slightly different below

Code: Select all

sudo nano /usr/share/X11/org.conf.d/99-fab turbo.conf
"fbdev" "/dev/fb1"
Edit cmdline.txt

Code: Select all

sudo nano /boot/cmdline.txt
fbcon=map:10
Richard
512MB version 2.0 as WordPress Server
Motorola Lapdock with Pi2B
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!

benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Re: Tontec 3.5" Screen - Only displaying white screen

Wed May 27, 2015 5:03 pm

Lob0426 wrote:Did you add the code to config.txt?

Code: Select all

sudo nano /boot/config.txt
dtpram=spi=on
dtoverlay=mz9486
Edit xorg file fbdev fb0 to fb1
Yours may be slightly different below

Code: Select all

sudo nano /usr/share/X11/org.conf.d/99-fab turbo.conf
"fbdev" "/dev/fb1"
Edit cmdline.txt

Code: Select all

sudo nano /boot/cmdline.txt
fbcon=map:10
Richard
Yes, I have done all of this - Is this with the MZ350i drivers/files?

User avatar
Lob0426
Posts: 2198
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
Contact: Website

Re: Tontec 3.5" Screen - Only displaying white screen

Wed May 27, 2015 6:47 pm

I have the Tontec 3.5 MZ61581 display.

The drivers were included in the latest Raspbian updates.

Have you tried the latest update and upgrade. You may also try rpi-update to get the very latest kernel.
512MB version 2.0 as WordPress Server
Motorola Lapdock with Pi2B
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!

benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Re: Tontec 3.5" Screen - Only displaying white screen

Wed May 27, 2015 6:49 pm

Lob0426 wrote:I have the Tontec 3.5 MZ61581 display.

The drivers were included in the latest Raspbian updates.

Have you tried the latest update and upgrade. You may also try rpi-update to get the very latest kernel.
Yeah, I did both - Still just displays a white screen - never changes. Did this happen to yours?

benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Re: Tontec 3.5" Screen - Only displaying white screen

Wed May 27, 2015 6:53 pm

Could anyone help me over skype at all? Also this will work when it boots into the command line? As I havn't tried it on the startx GUI stuff.

benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Re: Tontec 3.5" Screen - Only displaying white screen

Wed May 27, 2015 6:56 pm

EDIT: Just tried doing "sudo raspi-config" and set it to boot to the GUI, nothing happend - Its still just a white screen

benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Re: Tontec 3.5" Screen - Only displaying white screen

Wed May 27, 2015 7:10 pm

Deleted
Last edited by benspring100 on Thu Jan 05, 2017 10:18 pm, edited 1 time in total.

User avatar
Lob0426
Posts: 2198
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
Contact: Website

Re: Tontec 3.5" Screen - Only displaying white screen

Thu May 28, 2015 1:14 am

I found this for your screen about getting a white screen. Hope it helps. Searched under Tontec mz9486. Look at the post from ttmz.

https://github.com/notro/fbtft/issues/222
512MB version 2.0 as WordPress Server
Motorola Lapdock with Pi2B
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!

benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Re: Tontec 3.5" Screen - Only displaying white screen

Thu May 28, 2015 12:51 pm

Lob0426 wrote:I found this for your screen about getting a white screen. Hope it helps. Searched under Tontec mz9486. Look at the post from ttmz.

https://github.com/notro/fbtft/issues/222
Okay, in ttmz's post it says "copy the above code to fb_r61581.c to replace the ili9486.c" when he says replace the ili9486 - DOes he mean I need to delete that file? Also the bits in his code that are greyed - What does that mean? Its got a grey background - Does that mean I need to change that some place else?

User avatar
Lob0426
Posts: 2198
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
Contact: Website

Re: Tontec 3.5" Screen - Only displaying white screen

Fri May 29, 2015 5:47 pm

I have not looked at that file. I would say that you are to look for the corresponding sections, denoted by the background color change, and replace those sections.

Create a new file by copying the ili9486.c file. Rename the copied file as fb_r62581.c. Then make the changes. When your done you can delete the old file. I would save a copy of it somewhere else just in case!
512MB version 2.0 as WordPress Server
Motorola Lapdock with Pi2B
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!

benspring100
Posts: 9
Joined: Wed May 27, 2015 1:13 pm

Re: Tontec 3.5" Screen - Only displaying white screen

Fri May 29, 2015 6:00 pm

Lob0426 wrote:I have not looked at that file. I would say that you are to look for the corresponding sections, denoted by the background color change, and replace those sections.

Create a new file by copying the ili9486.c file. Rename the copied file as fb_r62581.c. Then make the changes. When your done you can delete the old file. I would save a copy of it somewhere else just in case!
Thank you! Do you have Skype at all?

User avatar
Lob0426
Posts: 2198
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
Contact: Website

Re: Tontec 3.5" Screen - Only displaying white screen

Fri May 29, 2015 7:03 pm

No I do not.
512MB version 2.0 as WordPress Server
Motorola Lapdock with Pi2B
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!

rudiratlos
Posts: 129
Joined: Tue May 01, 2012 8:47 am

Re: Deleted

Mon May 20, 2019 12:37 pm

with new version of raspian, the boot process get stuck.
removing fbcon=map:10 from /boot/cmdline.txt every thing went fine.

Return to “HATs and other add-ons”