markfree
Posts: 5
Joined: Sun Aug 01, 2021 7:49 pm

PoE+ HAT Fan not working at lower state

Sun Aug 01, 2021 8:12 pm

I've got 2 Pi's with the new PoE+ Hat and both were working fine with the correct fan curve set by dtoverlay=rpi-poe-plus.
I've set it like this:

Code: Select all

# PoE+ FAN TEMPERATURE CONTROL
dtoverlay=rpi-poe-plus
dtparam=poe_fan_temp0=45000,dtparam=poe_fan_temp0_hyst=3000
dtparam=poe_fan_temp1=50000,dtparam=poe_fan_temp1_hyst=3000
dtparam=poe_fan_temp2=62000,dtparam=poe_fan_temp2_hyst=4000
dtparam=poe_fan_temp3=70000,dtparam=poe_fan_temp3_hyst=5000

After the latest firmware update, I noticed that fan_temp0 and fan_temp1 are probably not working anymore.

Code: Select all

$ uname -r
5.10.52-v8+

The fan only spins up when the temperature reaches 62ºC.
Now, my Pi's are running hotter and the fan only spins at a higher rpm.
When the fan is not spinning it shows state "2" and when it is spinning it shows state 3.

Code: Select all

$ cat /sys/class/thermal/cooling_device0/cur_state
2

When I check vcgencmd's config, there's no "rpi-poe-plus"

Any ideas on why that is happening with both HAT's?

markfree
Posts: 5
Joined: Sun Aug 01, 2021 7:49 pm

Re: PoE+ HAT Fan not working at lower state

Sun Aug 01, 2021 10:33 pm

If I set rpi-poe-plus as the overlay readme suggests,

Code: Select all

dtoverlay=rpi-poe-plus,poe_fan_temp0=45000,poe_fan_temp0_hyst=3000,poe_fan_temp1=50000,poe_fan_temp1_hyst=3000,poe_fan_temp2=62000,poe_fan_temp2_hyst=4000,poe_fan_temp3=70000,poe_fan_temp3_hyst=5000
It doesn't work. The fan spins up to match the default behavior, not the ones I set.

Code: Select all

$ cat /sys/class/hwmon/hwmon0/device/trip_point_0_temp
55000
$ cat /sys/class/hwmon/hwmon0/device/trip_point_1_temp
50000
$ cat /sys/class/hwmon/hwmon0/device/trip_point_2_temp
45000
$ cat /sys/class/hwmon/hwmon0/device/trip_point_3_temp
45000

Now, if I set it like this:

Code: Select all

dtoverlay=rpi-poe-plus
dtparam=poe_fan_temp0=45000,poe_fan_temp0_hyst=3000
dtparam=poe_fan_temp1=50000,poe_fan_temp1_hyst=3000
dtparam=poe_fan_temp2=62000,poe_fan_temp2_hyst=4000
dtparam=poe_fan_temp3=70000,poe_fan_temp3_hyst=5000
The strange behavior is the same. It works for states 3 and 4, not 1 and 2.

Code: Select all

$ cat /sys/class/hwmon/hwmon0/device/trip_point_0_temp
70000
$ cat /sys/class/hwmon/hwmon0/device/trip_point_1_temp
62000
$ cat /sys/class/hwmon/hwmon0/device/trip_point_2_temp
50000
$ cat /sys/class/hwmon/hwmon0/device/trip_point_3_temp
45000

It seems not to work at lower speeds anymore.
Last edited by markfree on Sun Aug 01, 2021 10:37 pm, edited 1 time in total.

markfree
Posts: 5
Joined: Sun Aug 01, 2021 7:49 pm

Re: PoE+ HAT Fan not working at lower state

Tue Aug 03, 2021 8:54 pm

I've reinstalled the Raspberry Pi OS and the strange behavior is the same, no spin at states 1 and 2.

It all started out of the blue with both PoE+ HATs, right after I rebooted and the kernal was updated to version "5.10.52-v8+". Prior version "5.10.17-v8+" was working fine.

I'm lost now. Any ideas?

pimeup
Posts: 1
Joined: Thu Aug 05, 2021 4:17 pm

Re: PoE+ HAT Fan not working at lower state

Thu Aug 05, 2021 4:22 pm

i thought 1 & 2 were working before as well. But im experiencing this on raspi os and ubuntu pi (21.04 64 bit). Initially i started with ubuntu pi, but then figured i should give the native os a shot real quick. so i loaded up raspi os and updated everything including firmware and then it seemed to stop working for me as well. I thought it was working normally in ubuntu so i ended switching back over. But when i went to set those values in ubuntu it was doing the same thing, ignore 1&2 and turn on for 3&4
Last edited by pimeup on Thu Aug 05, 2021 4:23 pm, edited 1 time in total.

markfree
Posts: 5
Joined: Sun Aug 01, 2021 7:49 pm

Re: PoE+ HAT Fan not working at lower state

Sat Aug 14, 2021 3:23 pm

I've created an issue at GitHub's "raspberrypi/firmware" and, with the help of fellow "chri-kai-in", I was able to get the fan working again.

I had to change the fan default cooling levels to make it work again.
It is all described at the issue above.

I hope it helps.

Return to “HATs and other add-ons”