McGregor80
Posts: 40
Joined: Wed Feb 20, 2013 10:35 am

I2c in Raspbian 2015-01-30 on Pi B+

Wed Feb 04, 2015 3:11 pm

Hi,
I just downloaded the latest Raspbian 2015-01-30 and wanted to run my application which utilizes i2c on Raspberry Pi B+
But there is no I2c device and there is no /etc/modprobe.d/raspi-blacklist.conf file.

I added the spi-dev in the /etc/modules but this didn't solve the problem.

How do i enable i2c in the Raspbian 2015-01-30 on Pi B+?
Is this related to the fact that the distribution is intended for RPi 2?

Thanks

User avatar
RaTTuS
Posts: 10558
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: I2c in Raspbian 2015-01-30 on Pi B+

Wed Feb 04, 2015 3:18 pm

How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

McGregor80
Posts: 40
Joined: Wed Feb 20, 2013 10:35 am

Re: I2c in Raspbian 2015-01-30 on Pi B+

Fri Feb 06, 2015 4:04 pm

Thank you RaTTuS.

That was the issue.
"dtparam=i2c_arm=on" in to the config.txt
and
"i2c_dev" in to the /etc/modules

McGregor80
Posts: 40
Joined: Wed Feb 20, 2013 10:35 am

Re: I2c in Raspbian 2015-01-30 on Pi B+

Mon Feb 09, 2015 1:58 pm

Are the GPIO also disabled by default?

The application i have usues also the GPIO but it doesn't seem to work.
I suspect that it can be the same issue here. Where i can enable the GPIO?

Is UART also changed?

It seems that i was inactive too long time in the raspberrys development.

Return to “Interfacing (DSI, CSI, I2C, etc.)”