Page 1 of 1

trouble installing python-imaging

Posted: Wed May 08, 2013 1:09 am
by pibuyer2013
Hi,
I've got adafriut's Digital RGB LED Weatherproof Strip 32 LED - (1m) (PID: 306) and I'm trying to follow the instructions at http://learn.adafruit.com/light-paintin ... pberry-pi/

When I try to install the Python Image module with

sudo apt-get install python-imaging

it seems to be progressing OK but after it says 1433 Kbytes will be used.. continue? (paraphrasing here) it turns up with a couple of 404s at mirrordirector.rasbian.org and when I run the python program it says "no module named image"


Could anyone please advise me how to proceed?

As long as I'm here I'll say a couple of other things...

Very odd that the led strip comes wired but the soldered on wires are on the output side instaed of the input, according to http://learn.adafruit.com/digital-led-strip/wiring "Some strips arrive with plugs pre-wired for testing at the factory, but these might be at either end of the strip and aren’t necessarily useful for connecting to the microcontroller — in most cases you’ll still have to solder your own wires. Check three times to make sure you’re connecting to the INPUT side! Just because your strip includes a plug does not mean it is useful. You might get lucky, but odds are against it."

If the wires are attached only for testing then why is the rubber cap siliconed down on top of it?
If the unit is supposed to be "waterproof" then why is it open to the weather on the input side?; It should at least incude a second cap piece for the input side.

But it's not all that much money; if I can get it to work I'm sure i'll be happy.

Thanks,
John

Re: trouble installing python-imaging

Posted: Fri May 10, 2013 8:14 pm
by pibuyer2013
I have made some progress; I ran
sudo apt-get install python-imaging --fix-missing
after which the program ran and found my picture but didn't light up the LEDs

The first time I powered the strip nothing happened, I didn't have any clock or data input.
The next time all but one LED came on and it lit up on when i pressed on it.
The next time all but the first five or so lit up and i couldn't massaging and wiggling it in a way that made them light.
Lastly it didn't light up at all.

During the above operations I ran the program many times but it didn't seem to have any effect besides reporting in the terminal window that it was working. Next I guess i'll look at the output with a scope and see if the raspberry pi is putting out.

Re: trouble installing python-imaging

Posted: Sat May 11, 2013 2:46 pm
by austinp
Yea, the step that they left out before:
sudo apt-get install python-imaging

was:
sudo apt-get update

I'd suggest checking these two things:

#1 which revision of the raspberry pi do you have and is the tutorial for that revision? I believe the GPIO pin outs have changed on the different revisions so if you're going solely based off of the pin location and not matching up based on the pin description you might be wiring it wrong to the pi. A photo of the wiring & pi could probably help people on this board answer that for you.

#2 what exact type of the led strip do you have? According to this page http://learn.adafruit.com/digital-led-strip adafruit sells a few different kinds and they've gone through some different versions. Look at that link & inspect your LED strip.

Re: trouble installing python-imaging

Posted: Wed May 15, 2013 3:35 am
by pibuyer2013
Thanks for you reply,

yes, I'm sure I have the right tutorial and for my LED strip and Rpi version.

I have now made substantial progress. With a scope connected to the to the data line (DI) and, at the same time, the LED strip to connected to 5V power and to the Rpi's DI and DO I ran the program and, this time, the LEDs flashed as the program wrote the columns. Hooray!

The scope showed that the clock was active but since the LEDs lit up it was not needed.

I have a question which I hope someone will answer:

What should the LED strip do when powered up with no data or clock input? It is inconsistent. Is that normal?

John

Re: trouble installing python-imaging

Posted: Wed Jun 12, 2013 2:35 am
by pibuyer2013
I am still not successful in getting my raspberry pi the light up my LED strip.
I though I wasn't powering the LED strip with enough amps so I connected a 16 gauge lamp cord to both ends and connected it to a variable bench supply that can put out 3 amps.

It seems that the lpd8806 chip is not passing the data and clock well enough. Looking at the inputs on a scope at the 1st chip I have good voltage levels but the output on the chip is low. I think it's broken.