cazz
Posts: 220
Joined: Wed Nov 14, 2012 9:01 pm
Location: Sweden

Get a error when I run modprobe w1-gpio

Fri Mar 08, 2013 4:57 pm

Hi
I have use both

Code: Select all

sudo apt-get update
and

Code: Select all

sudo apt-get upgrade
It was alot to update but when I trying to run

Code: Select all

sudo modprobe w1-gpio
I get
libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file '/lib/modules/3.2.27+/modules.dep.bin'
So what more do I have to update or upgrade?
/Cazz

cazz
Posts: 220
Joined: Wed Nov 14, 2012 9:01 pm
Location: Sweden

Re: Get a error when I run modprobe w1-gpio

Fri Mar 08, 2013 9:58 pm

I forgot to reboot after the update :lol: :oops:
/Cazz

mdce4
Posts: 1
Joined: Sat May 10, 2014 10:53 pm

Re: Get a error when I run modprobe w1-gpio

Sat May 10, 2014 11:24 pm

I'm also getting an error when running modprobe. I am trying to use i2c but cant get it working. Already installed i2c with
sudo apt-get install i2c-tools.
However, when I run the command sudo i2cdetect –y 0 get the following error:
Could not open file `/dev/i2c-1' or `/dev/i2c/1': No such file or directory

Then I tried:
sudo modprobe i2c-dev
and got this error:
libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file ‘/lib/modules/3.2.27+/modules.dep.bin’

I have already tried sudo apt-get update and apt-get upgrade, and rebooted the PI each time. No luck. Anyone have any suggestions?

Return to “Interfacing (DSI, CSI, I2C, etc.)”