poproar
Posts: 3
Joined: Thu Aug 08, 2019 12:55 am

Module ds28e17 missing

Thu Aug 08, 2019 1:09 am

Hello,
I just installed buster-lite and the kernel module w1_ds28e17 seems to be missing:

Code: Select all

modprobe w1_ds28e17 
modprobe: FATAL: Module w1_ds28e17 not found in directory /lib/modules/4.19.58-v7+
Yet it looks like it is part of the main from here
https://github.com/raspberrypi/linux/bl ... _ds28e17.c

What do I need to do to get this without patching the kernel? Is there a config setting?
When I do a

Code: Select all

ls /lib/modules/$(uname -r)/kernel/drivers/w1/slaves
It is not there.

User avatar
DougieLawson
Posts: 36159
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Module ds28e17 missing

Thu Aug 08, 2019 7:36 am

The kernel config doesn't have CONFIG_W1_SLAVE_DS28E17 set. So that module won't get built.

Open an issue at https://github.com/raspberrypi/linux/issues and ask if the RPi folks can build that into their standard config. If they accept that request it could turn up with the next rpi-update.

You can do it yourself by building your own kernel. https://www.raspberrypi.org/documentati ... uilding.md
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Fux
Posts: 4
Joined: Sat Mar 07, 2015 9:47 pm

Re: Module ds28e17 missing

Sun Aug 11, 2019 10:46 am

I second the request and opened an issue as it seems that the thread creator it hasn't done yet:
https://github.com/raspberrypi/linux/issues/3141

poproar
Posts: 3
Joined: Thu Aug 08, 2019 12:55 am

Re: Module ds28e17 missing

Mon Aug 12, 2019 5:47 pm

Thank you @Fux
Don't know why I hesitated.

Fux
Posts: 4
Joined: Sat Mar 07, 2015 9:47 pm

Re: Module ds28e17 missing

Thu Aug 15, 2019 9:37 pm

@poproar
You are welcome.
I just compiled the latest Kernel with the module by myself. The module is loading fine but it can't recognize the DS28E17.
I have as 1Wire master a DS2482-S100 connected to I2C. There is no message at all at dmesg even if I load it manually by insmod.
The DS28E17 is tested and works fine at my Linux Mint desktop.
Did you test it already at the Raspberry Pi?

EDIT: It works fine with a DS2490 (blue 1Wire-USB Dongle), but doesn't with a DS2482S-100 at galvanic decoupled I2C by an ADUM1250ARZ.

poproar
Posts: 3
Joined: Thu Aug 08, 2019 12:55 am

Re: Module ds28e17 missing

Mon Aug 19, 2019 7:40 pm

@Fux, Did you compile it directly on the Pi or cross compile on the Mint desktop?
It works fine with a DS2490 (blue 1Wire-USB Dongle), but doesn't with a DS2482S-100 at galvanic decoupled I2C by an ADUM1250ARZ
Sorry I can't say much about that, my knowledge of hardware is limited.

Return to “Interfacing (DSI, CSI, I2C, etc.)”