DonnerPlays
Posts: 1
Joined: Sat Jun 08, 2019 3:07 pm

Raspberry Pi communicating with RDA5807M problems

Sat Jun 08, 2019 3:17 pm

Hello Guys,

I'm currently trying to communicate with a RDA5807M using my Raspberry Pi 3B+ but cannnot get it to work as i want to.
RDA5807M that i got -> http://wiki.seeedstudio.com/Grove-I2C_FM_Receiver/

the RDA5807M is directly connected to the rpi (without external pull ups)

I already found out that there are 3 ways to communicate with it.
0x60 is TEA5767 compatible mode
0x10 is RDA5807 mode, sequential register address
0x11 is RDA5807 mode, random access mode.

but I'm only able to use 0x60.
when i do i2cdetect -y 1 i get 60 and 10
i can talk to 60 no problem but when i try to read/write to 0x10 i get Error: Read Failed or Error: Write Failed.
After that when i do i2cdetect the 10 is gone and will only appear again when doing another i2cdetect
I already tried it with i2cset/get
pi4j using Java (my programm will be a gui to controll the radio)
nothing will work.

I already saw some people use the same Grove RDA5807M and using 0x10 or 0x11. Even some having 0x60 0x10 and 0x11 on their i2cdetect

Could somebody maybe help me or has an idea what could be the problem?


EDIT:
I found out that it has to be a problem with the rpi, I tried the code supplied by grove using an Arduino UNO.
I connected everything just like i had with rpi,
GND -> GND
3.3V -> 3.3V
SDA -> SDA
SCL -> SCL
and the programm (which used 0x10 - which i want to use) worked without a problem and i could also set stuff like volume which i can't in TEA5767 mode.

Return to “Interfacing (DSI, CSI, I2C, etc.)”