Peter247
Posts: 56
Joined: Wed Nov 21, 2012 12:29 am

pin 11 isn`t working

Wed Nov 21, 2012 12:48 am

Hi , In a normal set up is there a reason why pin 11 isn`t working , ( Rev 2 board ) .
I tried controlling a Tri colour led using RPi.GPIO, so tested it out with pins 7 , 11 , 13 .
Found from that that pin 11 isn`t working as IN or OUT , but no real biggie for most of my control is by I2C.
http://www.peter224722.blogspot.co.uk/

Wendo
Posts: 142
Joined: Sun Jun 10, 2012 8:27 pm

Re: pin 11 isn`t working

Wed Nov 21, 2012 4:44 am

From memory pin 11 was remapped with the rev2 boards, so you're probably flipping the wrong GPIO pin on a rev 2 board.

What are you using to access the pins?

Peter247
Posts: 56
Joined: Wed Nov 21, 2012 12:29 am

Re: pin 11 isn`t working

Wed Nov 21, 2012 12:05 pm

Hi , looking at my diagrams with Rev 1 and Rev 2 boards , Board pin 11 is GPIO17 with Alternative Functions of UART0_RTS, ALT5 = UART1_RTS.

I`m using library RPi.GPIO 0.4.1a .

Code: Select all

 #! /usr/bin/python

import RPi.GPIO as GPIO
import time
# pin 11 not working
# pins 7 , 13 , 15
Red = 7
Green = 13
Blue = 15
GPIO.cleanup()
GPIO.setmode(GPIO.BOARD) 

GPIO.setup( Red   , GPIO.OUT)
GPIO.setup( Green , GPIO.OUT)
GPIO.setup( Blue  , GPIO.OUT)

# pins : is board markings on the header plug
while 1:
	try:

		GPIO.output( Red , GPIO.LOW)
		time.sleep(.1)
		GPIO.output( Red , GPIO.HIGH)
		time.sleep(.1)

		GPIO.output( Green , GPIO.LOW)
		time.sleep(.1)
		GPIO.output( Green , GPIO.HIGH)
		time.sleep(.1)

		GPIO.output( Blue , GPIO.LOW)
		time.sleep(.1)
		GPIO.output( Blue , GPIO.HIGH)
		time.sleep(.1)

	except :
		GPIO.cleanup()
		exit()
http://www.peter224722.blogspot.co.uk/

Wendo
Posts: 142
Joined: Sun Jun 10, 2012 8:27 pm

Re: pin 11 isn`t working

Fri Nov 23, 2012 4:50 am

Yup, sorry, was thinking pin 13 now that I look it up.

Most likely the pin is fried then would be my guess :(

I've managed to blow a pin on one of my pi's somehow, it's now running as a media center

Return to “Interfacing (DSI, CSI, I2C, etc.)”