MuntyScruntfundle
Posts: 125
Joined: Fri Oct 27, 2017 11:14 pm

SPI file errors.

Sun Jan 07, 2018 3:36 pm

Hi folks.

I'm having some problems with GPIO and SPI. I've been trying to get 2.4ghz comms working with little success so far. I've hit a problem with my receiving pi where the SPI drivers report an error: FATAL: Module spi-2708 not found in directory /lib/modules/4.9.59-v7+

At some point the /dev/spidev0..0 and spider0.1 directories have become corrupt. I've tried every way to recreate these character files I can find googles for but I just bump into this error over and over. I can't copy them, I either get 'null' cannot copy file, or File is too large errors.

Is it possible to manually force a reinstall of the GPIO and SPI stuff?

I can format the sd and start from scratch again if I really need to, but I don't want to.

Thanks.

MuntyScruntfundle
Posts: 125
Joined: Fri Oct 27, 2017 11:14 pm

Re: SPI file errors.

Sun Jan 07, 2018 8:13 pm

Yesterday resetting spi in rasp-config didn't fix the problem. Later today I reset everything in interfacing and I've got it back again. Phew.

Still can't get any RF2.4 example working though, and these are the expensive modules, not the cheapo ebay stuff.

I'm at a real loss. I've tried everything I can think of with nrf24 and lib_nrf24, can't get any data from one pi to another.

This is a plea going out to anyone who might have the smallest working python example of rf2.4 comms, anything you might share would be so appreciated!

User avatar
joan
Posts: 13556
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: SPI file errors.

Sun Jan 07, 2018 10:23 pm

I posted some working code for the NRF24L01 in response to https://raspberrypi.stackexchange.com/q ... -registers

craig42
Posts: 1
Joined: Wed Jan 10, 2018 9:32 am

Re: SPI file errors.

Wed Jan 10, 2018 9:50 am

Hi,

I have a Raspberry Pi 3 and a chisteraPi which uses SPI communication.

I have a similar problem, after upgrading to linux kernel 4.9.59-v7+, my chisteraPi doesn't work anymore.

I use lora_chistera program :
https://github.com/Snootlab/lora_chisterapi
This program use RadioHead library.

With a raspberry not updated with linux kernel 4.9.35-v7+, chisteraPi works.

I can't tell if it's a problem from the kernel or from raspi-config...

User avatar
eddy33
Posts: 4
Joined: Thu Jul 05, 2018 9:48 am

Re: SPI file errors.

Mon Sep 03, 2018 12:33 pm

Hi craig42,

After studying the source code for LoRa with the ChisteraPi board, I've found the problem.

For the LoRa stack, in file lib/radiohead/RH_RF95.cpp, after line 46, please add the call of the begin() method for RHLinuxSPI objet:

Code: Select all

Code: Select all

    #if (RH_PLATFORM == RH_PLATFORM_RPI)
        RHLinuxSPI::begin("/dev/spidev0.0");
    #endif
Don't care about the "char *" warning at the compilation.
It works great after with the RPi 3B model and with the RPi 3B+ model too.

I've tested this (sender.cpp and receiver.cpp examples):
- OK with Raspbian 2017-09-07. Kernel version: 4.9.41-v7+.
- OK with Raspbian 2018-06-27. Kernel version: 4.14.50-v7+

Cheers.

Return to “Interfacing (DSI, CSI, I2C, etc.)”

Who is online

Users browsing this forum: No registered users and 12 guests