ranpitime
Posts: 65
Joined: Sat Mar 23, 2013 5:21 am

SPI does not work on current stretch version

Thu Dec 14, 2017 7:23 am

Hi,

are there any changes in the SPI implementation between Jessi and latest Stretch Version?

My project does not work anymore for example I'm using a Piface with SPI:
-using Jessi - >it works
-using Stretch 2017-09-07-raspbian-stretch-lite.img -it works
-using latest Stretch - >does not work

-no changes on my side so i'm wondering where to start look in to.

For me this sounds like an 'accident' in lates release?
Anyone could confirm this?

Additional info:
if we reduce the spi maxspeed it will work - but why
in older Raspbian we could have 125000 as SPI maxspeed - now we Need to reduce this?
Why, this is not nice for existing applications?

BR
ranpitime

Return to “Interfacing (DSI, CSI, I2C, etc.)”

Who is online

Users browsing this forum: No registered users and 7 guests