User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Sun Apr 19, 2020 3:36 pm

Hi,
first download the two attached 320x240 "565 format" images to your Pi0.

If using a single SPI display on SPI0, a single "sudo modprobe" command is all that is needed.
This command does not allow to use two SPI displays.
Therefore I used two dtoverlays, we will come to that later:
  • spi1-3cs
  • pi-displa0
The first enables SPI1, the 2nd allows to use SPI0 display without "sudo modprobe".

The first step for you is to verify that indeed both displays work.
So connect one of the displays as you described before.
Then execute these commands:

Code: Select all

$ dmesg > before
$ sudo modprobe fbtft_device name=rpi-display gpios=reset:25,dc:23,led:18 rotate=270
$ dmesg > after
$ diff before after
There should be a diff on first execution.
In case you see the diff, execute this and you should see giraffe on SPI display:

Code: Select all

$ tail --bytes 153600 /home/pi/fb1.565.bmp > /dev/fb1
$
If that works, then disconnect that SPI display, and connect the other SPI display to the exact same pins, and repeat the commands.
If that works as well, we know that both displays work and we can do next step(s).

P.S:
I have soldered display LED to display VCC, so did only use 8 cables to the Pi0 with my 2x4 connectors.
And I have connected display Miso with Pi0 Miso, which is not used for display -- just to keep superglued 2x4 connectors:
If you connect LED to GPIO18, that pin needs to go high, eg. by:

Code: Select all

$ sudo apt-get install pigpio
$ sudo pigpiod
$ pigs m 18 w
$ pigs w 18 1
led_vcc.jpg
led_vcc.jpg
led_vcc.jpg (47.71 KiB) Viewed 1064 times
2x4.connectors.jpg
File comment Size Status
2x4.connectors.jpg
2x4.connectors.jpg (73.53 KiB) Viewed 1062 times
Attachments
fbs.zip
two framebuffer images
(155.61 KiB) Downloaded 21 times
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Tue Apr 21, 2020 8:09 am

Ok! so I checked both of the displays separately with "FRAMEBUFFER" and they work fine I installed the pins for them both but in a different way, for now, because I cant solder them for the time being.Image this is how it looks.
I was wondering about the last attachment you sent, what is it for?

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Wed Apr 22, 2020 12:44 am

Ebben wrote:
Tue Apr 21, 2020 8:09 am
I was wondering about the last attachment you sent, what is it for?
It contains fb1.565.bmp and fb2,565,bmp images in format that can be directly copied to ili9341 display connected.
Copy both images to your Pi0, and then execute this command on Pi0 -- should display giraffe with text "/dev/fb1" on your lcd:

Code: Select all

$ tail --bytes 153600 /home/pi/fb1.565.bmp > /dev/fb1
$
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Wed Apr 22, 2020 11:38 am

Ok done!
So what's next? Now I need both of the screens to display the pi0 at the same time but extended, how?

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Wed Apr 22, 2020 12:02 pm

So now you have verified that both displays work on SPI0.

Next is to make one work on SPI1.
Do edit your /boot/config.txt and add the 2nd line (from your successful tests we know that 1st line is present already).
That line enables 3-line SPI1 interface:

Code: Select all

...
dtparam=spi=on
dtoverlay=spi1-3cs
...

After reboot execute these two commands, and the display connected to SPI1 should show a house with "/dev/fb2" indicator:

Code: Select all

sudo modprobe fbtft_device name=rpi-display gpios=reset:6,dc:26,led:16 rotate=270 cs=2 busnum=1
tail --bytes 153600 fb2.565.bmp > /dev/fb2
house.fb2.png
house.fb2.png
house.fb2.png (18.11 KiB) Viewed 984 times
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Thu Apr 23, 2020 8:15 am

Done! Thank you so much. But can you start giving me two steps in a row because I have a deadline, thanks

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Thu Apr 23, 2020 11:27 am

Ebben wrote:
Thu Apr 23, 2020 8:15 am
Done! Thank you so much. But can you start giving me two steps in a row because I have a deadline, thanks
OK, only two steps left after you have a working SPI1 display now.

1) create rpi-displa0 overlay as described in this posting, add to /boot/config.txt and reboot. Then do "tail --bytes 153600 fb1.565.bmp > /dev/fb1" to verify that SPI0 display (which should have become black by the reboot) shows the image:
viewtopic.php?f=44&t=194423#p1217626

2) add commands to /etc/rc.local as described in this posting and reboot -- you should see /dev/fb1 and /dev/fb2 indicator images on the displays automatically after reboot with that, like my end of reboot phase:
viewtopic.php?f=43&t=193722&p=1217930#p1217930
Image


P.S:
On success, you might attach a photo of what you are using the two displays for.
I used them to get two different robot live views on line following course:
Image
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Thu Apr 23, 2020 12:38 pm

Perfect! so now how can I framebuffer them both into raspberry pi zero w?

George441
Posts: 22
Joined: Tue Jan 21, 2020 4:13 pm
Location: 571 Willow Oak Dr 36695, Mobile, AL, US
Contact: Website

Re: How to enable ili9341 display during boot? (and ili9481)

Thu Apr 23, 2020 12:55 pm

It seems you got the answer from fellow members.
This post might help you...
https://github.com/notro/fbtft/wiki
*************************************************************************
"Save a Tree - Save The Environment - Save Your Life "
=========================================================

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Thu Apr 23, 2020 4:54 pm

George441 wrote:
Thu Apr 23, 2020 12:55 pm
It seems you got the answer from fellow members.
This post might help you...
https://github.com/notro/fbtft/wiki
I checked it out but it doesn't seem to show how to framebuffer two screens together.

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Thu Apr 23, 2020 11:32 pm

What does "to framebuffer two displays together" mean?
The pointed to wiki shows what you can do with the two new framebuffers fb1 and fb2.
What do you want to do?
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Fri Apr 24, 2020 9:06 am

HermannSW wrote:
Thu Apr 23, 2020 11:32 pm
What does "to framebuffer two displays together" mean?
The pointed to wiki shows what you can do with the two new framebuffers fb1 and fb2.
What do you want to do?
I want to display the raspberry pi zero w on the two screens (one half on one screen and the other half on the other screen) I want the raspberry pi to show my game on boot and the game requires a camera

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Fri Apr 24, 2020 10:25 am

In case your game is running in console, it needs to deal with two framebuffers, I am not aware of a virtual framebuffer that joins two framebuffers.
Or use one display for one application, as shown earlier in this thread:
Image


With (old) X11 it is possible:
https://www.youtube.com/watch?v=wxJpWRPKe-g
X11on2SPIdisplays.jpg
X11on2SPIdisplays.jpg
X11on2SPIdisplays.jpg (97.28 KiB) Viewed 833 times

The easiest approach is to use single 9$ 480x320 SPI display with exactly the resolution of the two 320x240 displays together, and without a border between:
viewtopic.php?f=44&t=194423#p1561837
Image
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Fri Apr 24, 2020 11:54 am

HermannSW wrote:
Fri Apr 24, 2020 10:25 am
With (old) X11 it is possible:
So how can I get this (old )X11 running on my pi0?
because my project works with two displays

In this video how did he make it work?
Or is there a way to display the game the same way I did with the images.

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Fri Apr 24, 2020 12:41 pm

In the video he just did "startx", so the secret is in some file.
I cannot test, because I have no X11 installed on my Pi0, and because currently SPI0 display does not work, some connectivity issue.

notro shows how to start X11 with specified framebuffer:
https://github.com/notro/fbtft/wiki/Fra ... e#x-server

Code: Select all

FRAMEBUFFER=/dev/fb1 startx

You should test

Code: Select all

FRAMEBUFFER=/dev/fb2 startx
in addition, to verify that X11 can run on each of your displays separately.

Then perhap try (alternatively separated with colon instead of space):

Code: Select all

FRAMEBUFFER="/dev/fb1 /dev/fb2" startx
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Fri Apr 24, 2020 1:43 pm

Ok. So I did what you said. Usually, it works but now it gives me this:

Code: Select all

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-48-generic armv8l Raspbian
Current Operating System: Linux raspberrypi 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l
Kernel command line: coherent_pool=1M bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 smsc95xx.macaddr=B8:27:EB:A1:B4:46 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  console=ttyAMA0,115200 console=tty1 root=PARTUUID=97709164-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait modules-load=dwc2,g_ether quiet splash plymouth.ignore-serial-consoles
Build Date: 05 June 2019  12:49:54PM
xorg-server 2:1.20.4-1+rpt1 (https://www.debian.org/support)
Current version of pixman: 0.36.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 14 05:40:57 2020
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
and then just a white screen, with both displays seperatly.
Does it have something to do with the code in "rc.local" or the "/boot/config.txt" from before?

This is when "FRAMBUFFER=/dev/fb1,/dev/fb2 startx"

Code: Select all

(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Fri Apr 24, 2020 6:48 pm

I did fix my SPI0 display connectivity issue.
Then I tried to install X11 on the Pi0 with Raspian Stretch lite:

Code: Select all

 1260  sudo apt-get install xserver-xorg-video-fbdev
 1262  sudo apt-get install xserver-xorg
 1265  sudo apt-get install xinit
 1291  sudo apt-get install xserver-xorg-core
 1292  sudo apt-get install xserver-xorg-input-all
 1293  sudo apt-get install xserver-xorg-video-all
But that was not enough, this is the error message I got for "FRAMEBUFFER=/dev/fb1 startx" (captured with "fbcat /dev/fb1 > fb1.ppm"):
fb1.ppm.png
fb1.ppm.png
fb1.ppm.png (623 Bytes) Viewed 783 times

What you are searching for now (how to start X11 on two framebuffers) may find answers in other boards of the forum, perhaps on "Raspbian".
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Fri Apr 24, 2020 11:09 pm

Thanks for reminding me on my 320x240 SPI displays -- the 3rd such display I have found a new home on my raspcatbot. 320x240 is exactly the format of the frames I capture during robot drive at 204fps framerate from Arducam ov7251 monochrome global shutter camera! raspcatbot drives autonomously based on the frames captured. The display is connected to SPI1, but nevertheless it is /dev/fb1:
viewtopic.php?f=37&t=267999&p=1649212#p1649212
Image


P.S:
The connectors I used for the dual SPI displays with the Pi0 had LED soldered to VCC (full brightness).
On raspcatbot I did connect display LED pin to Pi GPIO6.
Now dimming works like a charme (not sure what this can be useful for), this sets half display brightness:

Code: Select all

sudo pigpiod
pigs p 6 128

With idling Pi3A+, no lights on and no motor movement, raspcatbot did draw 0.264A.
With added display raspcatbot draws 0.277A/0.279A/0.280A for PWM=0/128/255.
16mA for the Giraffe /dev/fb1 indicator image surprised me.
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Sat Apr 25, 2020 9:18 am

Great!
Now using FRAMEBUFFER on one display doesn't work anymore can you help with that?

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Sat Apr 25, 2020 9:58 pm

I switched to a Pi3B that had full Raspbian Buster installed.
I changed it to boot into console with raspi-config.

Then I did all the steps to get both SPI displays working on boot.
Then I did install the framebuffer X11 server according to:
https://github.com/notro/fbtft/wiki/Fra ... e#x-server
Finally I played with "/usr/share/X11/xorg.conf.d/99-fbdev.conf".

Documentation says:
https://www.x.org/releases/current/doc/ ... ev.4.xhtml
Option "fbdev" "string"
The framebuffer device to use. Default: /dev/fb0.
It turned out that only the 1st fbdev option is taken.

Code: Select all

Section "Device"
  Identifier "myfb"
  Driver "fbdev"
  Option "fbdev" "/dev/fb1"
  Option "fbdev" "/dev/fb2"
EndSection
X11.fb1.png
X11.fb1.png
X11.fb1.png (235.06 KiB) Viewed 729 times

But we have seen that two framebuffer X11 is possible.
Btw, with that file just "startx" starts X server on the specified framebuffer.

Using 320x240 X11 is so sweet ;-)
X11.fb2.ppm.png
X11.fb2.ppm.png
X11.fb2.ppm.png (12.09 KiB) Viewed 729 times
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Mon Apr 27, 2020 12:42 am

So what are you saying? I can't get two screens working on my rpi0w nor can I make them display my game.
Right now I'm facing the challenge of getting FRAMEBUFFER working on only one screen.

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Mon Apr 27, 2020 6:28 am

Ebben wrote:
Mon Apr 27, 2020 12:42 am
So what are you saying? I can't get two screens working on my rpi0w nor can I make them display my game.
No.
I think you see this after booting like I:
Image

Right now I'm facing the challenge of getting FRAMEBUFFER working on only one screen.
I just tried, FRAMEBUFFER=/dev/fb2 does not work for me either, doc seems not to be correct about that for Buster on Pi3B+:
https://github.com/notro/fbtft/wiki/Framebuffer-use

I will now tell you the steps I did to make this work:
20200427_081152.20%.part.jpg
20200427_081152.20%.part.jpg
20200427_081152.20%.part.jpg (63.9 KiB) Viewed 673 times
  1. sudo apt-get install xserver-xorg-video-fbdev
  2. add con2fbmap to /etc/rc.local

    Code: Select all

    $ tail -9 /etc/rc.local 
    tail --bytes 153600 /home/pi/fb1.565.bmp> /dev/fb1
    
    sleep 1
    sudo modprobe fbtft_device name=rpi-display gpios=reset:13,dc:26,led:28 rotate=270 cs=2 busnum=1
    tail --bytes 153600 /home/pi/fb2.565.bmp> /dev/fb2
    
    con2fbmap 1 1
    
    exit 0
    $
  3. add this file with "sudo vi":

    Code: Select all

    $ cat /usr/share/X11/xorg.conf.d/99-fbdev.conf 
    Section "Device"  
      Identifier "myfb"
      Driver "fbdev"
      Option "fbdev" "/dev/fb2"
    EndSection
    
    $
    
  4. add USB keyboard to the Pi and reboot
  5. login to the console that appears on /dev/fb1 with added keyboard
  6. execute "startx"
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Mon Apr 27, 2020 12:22 pm

I don't get this step, What am I supposed to do exactly to enter the code? write the code exactly? Sorry
HermannSW wrote:
Mon Apr 27, 2020 6:28 am


[*]add this file with "sudo vi":

Code: Select all

$ cat /usr/share/X11/xorg.conf.d/99-fbdev.conf 
Section "Device"  
  Identifier "myfb"
  Driver "fbdev"
  Option "fbdev" "/dev/fb2"
EndSection

$

User avatar
HermannSW
Posts: 2805
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: How to enable ili9341 display during boot? (and ili9481)

Mon Apr 27, 2020 4:44 pm

Extract the file from attached zip, and copy into directory "/usr/share/X11/xorg.conf.d/" on your Pi.
Attachments
99-fbdev.conf.zip
99-fbdev.conf.zip
(255 Bytes) Downloaded 21 times
https://stamm-wilbrandt.de/en/Raspberry_camera.html
https://stamm-wilbrandt.de/en#raspcatbot
https://github.com/Hermann-SW/raspiraw
https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264

Ebben
Posts: 21
Joined: Wed Mar 18, 2020 10:44 pm

Re: How to enable ili9341 display during boot? (and ili9481)

Mon Apr 27, 2020 10:02 pm

Thank you so much! But since I don't have a rpi3 I'm gonna go on with just one screen on my rpi0w, Should i change anything in the codes to make FRAMEBUFFER work on one because I don't think it's working anymore.

Code: Select all

pi@raspberrypi:~ $ sudo modprobe fbtft_device name=tm022hdh26 rotate=90
pi@raspberrypi:~ $ sudo FRAMEBUFFER=/dev/fb1 startx


X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-48-generic armv8l Raspbian
Current Operating System: Linux raspberrypi 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l
Kernel command line: coherent_pool=1M bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 smsc95xx.macaddr=B8:27:EB:A1:B4:46 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  console=ttyAMA0,115200 console=tty1 root=PARTUUID=97709164-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait modules-load=dwc2,g_ether quiet splash plymouth.ignore-serial-consoles
Build Date: 05 June 2019  12:49:54PM
xorg-server 2:1.20.4-1+rpt1 (https://www.debian.org/support)
Current version of pixman: 0.36.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Feb 13 20:18:32 2020
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
can yo uhelp with this error?
I Want to focus on displaying my game on one display for now! Sorry to have bothered you a lot.

Return to “Interfacing (DSI, CSI, I2C, etc.)”