JohnCitiizen
Posts: 1
Joined: Thu Oct 12, 2017 6:22 am

Troubles using GPS with tx rx

Thu Oct 12, 2017 6:46 am

HI,

Ive been stuck for a while on this one. Im currently having trouble getting consistent data out of a ublox neo-6m (data sheet for reference https://www.u-blox.com/sites/default/fi ... 09005).pdf). Im able to get data for a short while but then receive a "Read error from device"

Ive followed the following instructions to get things up and running on a fresh pi (wiped the disk and re installed):

https://openenergymonitor.org/forum-arc ... 12311.html

i also run the following to make sure i can use gpsd (specifically gpsmon)

Code: Select all

sudo apt-get install gpsd gpsd-clients python-gps

I then reboot the pi and and use the following command to open a serial connection and check data is coming through

Code: Select all

sudo stty -F /dev/serial0 9600
sudo cat /dev/serial0
Finally i run gpsmon to display the data from the UI

Code: Select all

sudo gpsmon /dev/serial0
Image
https://ibb.co/ncYEFb
this will run sometimes for a few minutes, sometimes for a few seconds before the application closes and i receive a "Read error from device".

Image
https://ibb.co/fZ8gvb

I'm not sure as to what the read error is, the only thing i can see in the /dev/serial0 that might suggest a problem is this line

Code: Select all

$GPTXT,01,01,01,NMEA unknown msg*58
I've tried googling the problem but the only suggestions i can see is the application is misinterpreting the control characters.

To try and isolate the issue i have two ublox neo-6m units to cross reference the results, testing each one individually, they both appear to be working and getting a gps lock (i only say this because the blue LED starts to flash). When testing, both units are placed outside to get the best gps lock.

Any suggestions on how to troubleshoot or resolve would be great :)

Return to “Interfacing (DSI, CSI, I2C, etc.)”

Who is online

Users browsing this forum: No registered users and 12 guests