skypi
Posts: 111
Joined: Sat Aug 09, 2014 11:48 pm

Re: Picamera long exposure - really?

Sat Sep 13, 2014 9:16 pm

waveform80 wrote:
skypi wrote:Just updated to 1.8 in an upgrade, and leaving all params on auto except set framerate and shutter speed and ISO (not sure if thats even necessary) and gives a very nice night exposure at 6s. But the exif data does not reflect any params if you switch any mode off.
Not quite sure I understand what you mean by "switch any mode off"? Do you have a code example that could reproduce the lack of Exif data?
-----
from further testing it seems exposure_mode = 'off' is what causes the problem, exif data = 6?? and a black exposure, running same example with that commented out works OK and exif ISO is what you set it to using the ISO parameter.

(as if setting ISO value turns exposure mode off anyway)
skypi wrote:I guess exposure_compensation is moot as it's fixed aperture, (brightness the same?) so vary shutter speed really all you've got. It also now sets a reasonable white balance by default.
exposure comp seems to have some effect (at least when I last looked at it in picroscopy) but I assumed it's just fiddling with gains under the hood (I haven't checked this though - might be interesting to query analog_gain and digital_gain while fiddling with exposure_compensation) or doing some post-processing to emulate the effect.
----
yeah, got in a knot trying so many things not so scientifically, it may work, didn't visibly notice it.
skypi wrote:I'd say in the docs, just recommend the commit # for rpi-update.
I added in a note in the install section for 1.8 which recommends just updating to the latest firmware with rpi-update - I figure that's probably enough for now (no need to confuse newcomers with commit hashes just yet :)
-----
I was running Ron Ostafichuk's picamera motion detection example, which was working OK on raspbian on B+, and thought, lets have another crack with arch see if that's fixed yet (as cam wasn't working on B+) and it is, but now that's python 3, so did a pip install of picamera 1.8 and now it fails when trying to take the motion-detected stills at full resolution, yet it works at 1600,1200

Traceback (most recent call last):
File "PWRmd.py", line 81, in <module>
camera.resolution = (widthH,heightH)
File "/usr/lib/python3.4/site-packages/picamera/camera.py", line 2035, in _set_resolution
self._enable_camera()
File "/usr/lib/python3.4/site-packages/picamera/camera.py", line 598, in _enable_camera
prefix="Failed to enable camera")
File "/usr/lib/python3.4/site-packages/picamera/exc.py", line 133, in mmal_check
raise PiCameraMMALError(status, prefix)
picamera.exc.PiCameraMMALError: Failed to enable camera: Out of resources (other than memory)

gpu_mem is 192 though that makes no difference to 128

gpu_mem = 192
#gpu_mem_512=128
#gpu_mem_256=128
#cma_lwm=
#cma_hwm=
#cma_offline_start=

#start_file=start_x.elf
#fixup_file=fixup_x.dat

disable_camera_led=1
start_x=1

wondering what config.txt should look like for arch? (raspistill works ok, and just doing a simple capture at full res works, but the motion example which uses a stream and another capture fails at full res.)

wondering if its just firmware again, how do you tell what firmware you are running on arch?

(I noticed you said you are not an arch expert, so don't worry about it too much, works OK up to a point, and may just have to wait for later firmware to percolate)

Dave.
Anyway, cool, Thanks.

Return to “Camera board”