ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6195
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: B+ Camera is not detected (workaround available)

Tue Sep 09, 2014 10:15 pm

Ah okay, that makes more sense.

claggierk
Posts: 4
Joined: Fri Sep 12, 2014 9:11 pm

Re: B+ Camera is not detected (workaround available)

Fri Sep 12, 2014 9:25 pm

Hey guys,

I am a software developer (C++, python, go) and know my way around Linux.

I just got my first raspberry pi (B+) and am having a problem with the camera.

I have read all of the comments on the current 4 pages that this forum constitutes and I am not sure if I should create a new forum asking my questions or continue on this one. Please let me know if I should start a new thread. The title of this thread is exactly my problem... I have a B+ Pi and the camera is NOT being detected. However, it does not seem to matter whether I enable I2C in via raspi-config or disable it.

No matter what I do, I see the following:

Code: Select all

[email protected] ~/projects/camera $ vcgencmd get_camera
supported=1 detected=0
When I try the raspistill: (not surprising as the camera is not being detected)

Code: Select all

[email protected] ~/projects/camera $ sudo raspistill -v -o test.jpg
...
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly
Are these supposed to be commented out? Or NOT commented out? Does it matter?

Code: Select all

[email protected] ~/projects/camera $ cat /etc/modprobe.d/raspi-blacklist.conf 
# blacklist spi and i2c by default (many users don't need them)
blacklist spi-bcm2708
blacklist i2c-bcm2708
I am happy to provide any details that may help solve my problem.

These might be helpful:

Code: Select all

raspistill Camera App v1.3.8

Code: Select all

[email protected] ~/projects/camera $ uname -a
Linux rpi13 3.12.28+ #710 PREEMPT Wed Sep 10 15:23:42 BST 2014 armv6l GNU/Linux

Code: Select all

[email protected] ~/projects/camera $ vcgencmd version
Sep  8 2014 18:59:28 
Copyright (c) 2012 Broadcom
version 3f2f2607186be72e4945cfa8edc77872dfc73195 (clean) (release)

LapplandsCohan
Posts: 4
Joined: Fri Oct 24, 2014 7:29 am

Re: B+ Camera is not detected (workaround available)

Fri Oct 24, 2014 7:59 am

I have, too, read through all four pages but the workaround does not work for me either.

Ran rpi-update, rebooted, executed camerafix.sh directly after logon

Code: Select all

[email protected] ~ $ vcgencmd get_camera
supported=1 detected=0
[email protected] ~ $ vcgencmd get_mem arm
arm=384M
[email protected] ~ $ vcgencmd get_mem gpu
gpu=128M
[email protected] ~ $ vcgencmd version
Oct 17 2014 17:56:05 
Copyright (c) 2012 Broadcom
version 845092531e360acd37f2f1964157f8079c77edfb (clean) (release)
[email protected] ~ $ gpio readall
 +-----+-----+---------+------+---+--B Plus--+---+------+---------+-----+-----+
 | BCM | wPi |   Name  | Mode | V | Physical | V | Mode | Name    | wPi | BCM |
 +-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+
 |     |     |    3.3v |      |   |  1 || 2  |   |      | 5v      |     |     |
 |   2 |   8 |   SDA.1 |   IN | 1 |  3 || 4  |   |      | 5V      |     |     |
 |   3 |   9 |   SCL.1 |   IN | 1 |  5 || 6  |   |      | 0v      |     |     |
 |   4 |   7 | GPIO. 7 |   IN | 1 |  7 || 8  | 1 | ALT0 | TxD     | 15  | 14  |
 |     |     |      0v |      |   |  9 || 10 | 1 | ALT0 | RxD     | 16  | 15  |
 |  17 |   0 | GPIO. 0 |   IN | 0 | 11 || 12 | 0 | IN   | GPIO. 1 | 1   | 18  |
 |  27 |   2 | GPIO. 2 |   IN | 0 | 13 || 14 |   |      | 0v      |     |     |
 |  22 |   3 | GPIO. 3 |   IN | 0 | 15 || 16 | 0 | IN   | GPIO. 4 | 4   | 23  |
 |     |     |    3.3v |      |   | 17 || 18 | 0 | IN   | GPIO. 5 | 5   | 24  |
 |  10 |  12 |    MOSI |   IN | 0 | 19 || 20 |   |      | 0v      |     |     |
 |   9 |  13 |    MISO |   IN | 0 | 21 || 22 | 0 | IN   | GPIO. 6 | 6   | 25  |
 |  11 |  14 |    SCLK |   IN | 0 | 23 || 24 | 1 | IN   | CE0     | 10  | 8   |
 |     |     |      0v |      |   | 25 || 26 | 1 | IN   | CE1     | 11  | 7   |
 |   0 |  30 |   SDA.0 |   IN | 1 | 27 || 28 | 1 | IN   | SCL.0   | 31  | 1   |
 |   5 |  21 | GPIO.21 |   IN | 1 | 29 || 30 |   |      | 0v      |     |     |
 |   6 |  22 | GPIO.22 |   IN | 1 | 31 || 32 | 0 | IN   | GPIO.26 | 26  | 12  |
 |  13 |  23 | GPIO.23 |   IN | 0 | 33 || 34 |   |      | 0v      |     |     |
 |  19 |  24 | GPIO.24 |   IN | 0 | 35 || 36 | 0 | IN   | GPIO.27 | 27  | 16  |
 |  26 |  25 | GPIO.25 |   IN | 0 | 37 || 38 | 0 | IN   | GPIO.28 | 28  | 20  |
 |     |     |      0v |      |   | 39 || 40 | 0 | IN   | GPIO.29 | 29  | 21  |
 +-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+
 | BCM | wPi |   Name  | Mode | V | Physical | V | Mode | Name    | wPi | BCM |
 +-----+-----+---------+------+---+--B Plus--+---+------+---------+-----+-----+
I must have checked the camera cable connection twenty times by now. Anyone with any ideas?

ashwinraj8
Posts: 2
Joined: Fri Sep 19, 2014 7:05 am

Re: B+ Camera is not detected (workaround available)

Mon Nov 10, 2014 5:24 am

I think when ever you install pitft display it will install older kernal
if you update it to 3.12.32+#721 both rtc and camera will work together but pitft will not work.
working on to provide better solution.

User avatar
DougieLawson
Posts: 37607
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: B+ Camera is not detected (workaround available)

Mon Nov 10, 2014 11:56 am

You need to run with Notro's custom kernel (currently 3.12.25+).

sudo REPO_URI=https://github.com/notro/rpi-firmware rpi-update
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

LapplandsCohan
Posts: 4
Joined: Fri Oct 24, 2014 7:29 am

Re: B+ Camera is not detected (workaround available)

Mon Nov 10, 2014 3:15 pm

Updated kernel, rebooted, still same error.

claggierk
Posts: 4
Joined: Fri Sep 12, 2014 9:11 pm

Re: B+ Camera is not detected (workaround available)

Wed Dec 03, 2014 3:07 am

So I bought this camera:
http://www.newegg.com/Product/Product.a ... 5PC1Y22185

And it all worked fine.

This is the camera that created problems for me:
http://www.amazon.com/gp/product/B00E1G ... UTF8&psc=1

soultrane
Posts: 4
Joined: Tue Dec 02, 2014 5:12 pm

Re: B+ Camera is not detected (workaround available)

Wed Dec 03, 2014 5:40 pm

Is there any update on this issue?

I have a B+ and my camera is not working. It is not a physical default as far as I can tell, because when booting up on a model B (and different SD card) the camera LED turns on, but that software is from a friend's Pi and I cannot test it.

I installed a fresh copy of Raspbian, performed update, upgrade and rpi-update, and the camera still does not work.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6195
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: B+ Camera is not detected (workaround available)

Wed Dec 03, 2014 6:22 pm

The issue described in this thread has been long resolved. If your camera doesn't work, it is NOT because of what's in this thread. Please make a new one with all the relevant details included.

Return to “Camera board”