dgupta
Posts: 5
Joined: Mon May 26, 2014 1:48 pm

Unable to install Python3 picamera module

Mon Jun 02, 2014 1:25 pm

With my picamera connected and the raspberry pi booted up to install the python picamera module, when typing into LXTerminal the following:
sudo apt-get install python-picamera python3-picamera python-rpi.gpio

I receive:
reading package list... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python-picamera
E: Unable to locate package python3-picamera


Can anybody direct me as to why I receive this and how to fix it
Thanks,

User avatar
waveform80
Posts: 303
Joined: Mon Sep 23, 2013 1:28 pm
Location: Manchester, UK

Re: Unable to install Python3 picamera module

Mon Jun 02, 2014 2:45 pm

dgupta wrote:With my picamera connected and the raspberry pi booted up to install the python picamera module, when typing into LXTerminal the following:
sudo apt-get install python-picamera python3-picamera python-rpi.gpio

I receive:
reading package list... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python-picamera
E: Unable to locate package python3-picamera


Can anybody direct me as to why I receive this and how to fix it
Thanks,
It's possible your package list hasn't been updated for a long time. Try "sudo apt-get update" to refresh the package list and then retry the installation.


Dave.

chollins
Posts: 1
Joined: Sun Jun 29, 2014 1:17 am

Re: Unable to install Python3 picamera module

Sun Jun 29, 2014 1:21 am

I had the same problem and this solution worked. Thanks!

510climber
Posts: 1
Joined: Thu Jul 03, 2014 12:30 am

Re: Unable to install Python3 picamera module

Thu Jul 03, 2014 12:32 am

Worked for me too, thanks!

User avatar
waveform80
Posts: 303
Joined: Mon Sep 23, 2013 1:28 pm
Location: Manchester, UK

Re: Unable to install Python3 picamera module

Fri Jul 04, 2014 8:53 am

Sounds like I need to add this to the docs (or at least to the FAQ)!

Dave.

Prockie
Posts: 4
Joined: Mon Sep 15, 2014 7:43 am
Location: Ipswich, England
Contact: Website

Re: Unable to install Python3 picamera module

Wed Dec 10, 2014 10:56 pm

Can anyone help, got a new Pi and want to install some packages. I'm getting the message "E: Unable to locate package tweepy." It has read the state information... Done and built dependency tree but it stops with the message above? It's the same for pygame too. I've done the update too. Thanks in advance...
Check out my RaspberryPi connected to a container delivery truck. Search YouTube for iDataTruck - more being added too.

DirkS
Posts: 9867
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Unable to install Python3 picamera module

Wed Dec 10, 2014 11:02 pm

Prockie wrote:Can anyone help, got a new Pi and want to install some packages. I'm getting the message "E: Unable to locate package tweepy." It has read the state information... Done and built dependency tree but it stops with the message above? It's the same for pygame too. I've done the update too. Thanks in advance...
Doesn't look to be directly related to the original topic. Please start a new topic and also add how exactly you are trying to install programs (apt-get, etc)
Also for which version of python.

Gr.
Dirk.

digix
Posts: 2
Joined: Tue May 24, 2016 7:52 pm

Re: Unable to install Python3 picamera module

Tue May 24, 2016 8:01 pm

I'm using OSMC, I've tried:
sudo apt-get update
sudo apt-get install python3-picamera
but I get:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python3-picamera
The same with python-picamera

Is python3-picamera included in OSM repositories?
If not how can I add it in the cleanest possible way?
Thank you very much for any help

Ciao

User avatar
waveform80
Posts: 303
Joined: Mon Sep 23, 2013 1:28 pm
Location: Manchester, UK

Re: Unable to install Python3 picamera module

Wed May 25, 2016 8:30 am

digix wrote:I'm using OSMC, I've tried:
sudo apt-get update
sudo apt-get install python3-picamera
but I get:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python3-picamera
The same with python-picamera

Is python3-picamera included in OSM repositories?
If not how can I add it in the cleanest possible way?
Thank you very much for any help

Ciao
I doubt it's in the OSM repos. You could try downloading the .deb package (apt-get download python3-picamera on a raspbian box), copy the file to your OSM box, and install it directly with "sudo dpkg -i python3-picamera_1.10-1_armhf.deb"; the dependencies of the package (python3, libraspberrypi00, python3-numpy) can either be installed before-hand or fixed up afterward with "sudo apt-get -f install".

However, be aware that camera support requires a lot more than just the libraries - as a rough rule of thumb if you can get the "raspistill" command working on the OS, picamera should be a doddle. If "raspistill" doesn't work, there's a lot more to do (camera firmware, vchiq device, etc.)

Dave.

digix
Posts: 2
Joined: Tue May 24, 2016 7:52 pm

Re: Unable to install Python3 picamera module

Tue Jun 14, 2016 8:04 am

Thank you Dave, I've managed to install it via pip. But I still have to try it.


Return to “Camera board”